ncat and conflicting requests.

Issues related to applications and software problems and general support
Post Reply
hack3rcon
Posts: 697
Joined: 2014/11/24 11:04:37

ncat and conflicting requests.

Post by hack3rcon » 2020/10/17 20:30:19

Hello,
I'm using CentOS 8 x86_64 as a web server and I want to remove netcat from my server, but it show me something about other programs like "MySQL" and etc.

Code: Select all

# yum remove nc
Modular dependency problems:

 Problem 1: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-DBD-MySQL:4.046:8010020191114030811:073fa5fe-0.x86_64
 Problem 2: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-DBD-SQLite:1.58:8010020191114033549:073fa5fe-0.x86_64
 Problem 3: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-DBI:1.641:8010020191113222731:16b3ab4d-0.x86_64
Dependencies resolved.
================================================================================
 Package           Arch   Version                              Repository  Size
================================================================================
Removing:
 nmap-ncat         x86_64 2:7.70-5.el8                         @AppStream 681 k
Removing dependent packages:
 pcp-testsuite     x86_64 5.0.2-5.el8                          @AppStream 112 M
Removing unused dependencies:
 bpftrace          x86_64 0.9.2-1.el8                          @AppStream 1.4 M
 cyrus-sasl        x86_64 2.1.27-1.el8                         @anaconda  160 k
 libpq             x86_64 12.4-1.el8_2                         @AppStream 719 k
 libvirt-libs      x86_64 4.5.0-42.module_el8.2.0+320+13f867d7 @AppStream  22 M
 pcp-pmda-bpftrace x86_64 5.0.2-5.el8                          @AppStream  57 k
 pcp-pmda-libvirt  x86_64 5.0.2-5.el8                          @AppStream  59 k
 pcp-pmda-mssql    x86_64 5.0.2-5.el8                          @AppStream  75 k
 pcp-pmda-netcheck x86_64 5.0.2-5.el8                          @AppStream  62 k
 pcp-pmda-podman   x86_64 5.0.2-5.el8                          @AppStream  67 k
 pcp-pmda-postgresql
                   x86_64 5.0.2-5.el8                          @AppStream  74 k
 python3-html5lib  noarch 1:0.999999999-6.el8                  @AppStream 1.1 M
 python3-libvirt   x86_64 4.5.0-2.module_el8.2.0+320+13f867d7  @AppStream 1.4 M
 python3-lxml      x86_64 4.2.3-1.el8                          @AppStream 4.8 M
 python3-psycopg2  x86_64 2.7.5-7.el8                          @AppStream 545 k
 python3-webencodings
                   noarch 0.5.1-6.el8                          @AppStream  72 k

Transaction Summary
================================================================================
Remove  17 Packages

Freed space: 145 M
Is this ok [y/N]: 
Can it make any problem for my web server?

Thank you.

lightman47
Posts: 1205
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: ncat and conflicting requests.

Post by lightman47 » 2020/10/17 20:39:40

Yes
Remember - importing/building packages will likely "byte you in the butt" come update time, long after you'd forgotten you did that! Use repos whenever possible.

hack3rcon
Posts: 697
Joined: 2014/11/24 11:04:37

Re: ncat and conflicting requests.

Post by hack3rcon » 2020/10/18 04:53:59

How can I remove netcat?

Post Reply

Return to “CentOS 8 - General Support”