Running AppImage

General support questions
Post Reply
gw1500se
Posts: 199
Joined: 2012/05/07 13:53:35

Running AppImage

Post by gw1500se » 2020/07/02 18:51:28

Supposedly appImage files are simply executable files like a shell script. However, it looks to me more like an HTML file. I have one that does not run on Centos. Is there something different about Centos compared to other *nix's? TIA.

Code: Select all

$ ./MKVToolNix_GUI-48.0.0-x86_64.AppImage
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 1: !DOCTYPE: No such file or directory
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 2: html: No such file or directory
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 3: head: No such file or directory
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 4: meta: No such file or directory
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 5: meta: No such file or directory
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 6: !--: No such file or directory
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 7: $'\r': command not found
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 8: meta: No such file or directory
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 9: $'\r': command not found
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 10: $'\r': command not found
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 11: title: No such file or directory
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 12: link: No such file or directory
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 13: link: No such file or directory
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 14: link: No such file or directory
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 15: $'\r': command not found
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 16: $'\r': command not found
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 17: $'\r': command not found
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 18: !--[if: No such file or directory
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 19: link: No such file or directory
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 20: ![endif]--: No such file or directory
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 21: $'\r': command not found
./MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 22: syntax error near unexpected token `<'
'/MKVToolNix_GUI-48.0.0-x86_64.AppImage: line 22: `<!--<script  src='/oxp/www/d/spcjs.php?id=1'></script>-->

lightman47
Posts: 1224
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: Running AppImage

Post by lightman47 » 2020/07/02 20:20:42

With the little info supplied, your 'results' seem to indicate an HTML file to me as well. Does it run in your browser?
Remember - importing/building packages will likely "byte you in the butt" come update time, long after you'd forgotten you did that! Use repos whenever possible.

gw1500se
Posts: 199
Joined: 2012/05/07 13:53:35

Re: Running AppImage

Post by gw1500se » 2020/07/02 20:25:36

It does but simply asks to download the file. The result is a duplicate file. I haven't had a chance to actually look at the content yet but I'm not sure what I am supposed to see.

lightman47
Posts: 1224
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: Running AppImage

Post by lightman47 » 2020/07/02 20:30:05

Code: Select all

!DOCTYPE
is the header (as many of the following lines are) for an HTML document. It may run in your web browser (or not at all if it's from an actual Web page containing the resources it seems to be using).
.
Remember - importing/building packages will likely "byte you in the butt" come update time, long after you'd forgotten you did that! Use repos whenever possible.

bonedome
Posts: 181
Joined: 2017/04/22 08:11:04

Re: Running AppImage

Post by bonedome » 2020/07/02 22:34:04

Hello
I have (a working) MKVToolNix from their repo https://mkvtoolnix.download/downloads.html#centos just install the repo and use yum to install mkvtoolnix rpm

gw1500se
Posts: 199
Joined: 2012/05/07 13:53:35

Re: Running AppImage

Post by gw1500se » 2020/07/02 23:01:20

Thanks. I didn't think there was a version in the repo.

Post Reply

Return to “CentOS 7 - General Support”