[SOLVED] BIND Slow Initial/Intermittent Recursion Lookup

Issues related to configuring your network
Post Reply
Posts: 52
Joined: 2010/09/14 21:05:16

[SOLVED] BIND Slow Initial/Intermittent Recursion Lookup

Post by Al_Stu » 2020/05/30 23:02:53

Lets get right to the solution since that is really what you're seeking. :)

If the system is capable of IPv6 but has no IPv6 interface configured, run named with the -4 option (IPv4 only).
For example. Add the -4 flag to the ExecStart named command in "/usr/lib/systemd/system/named.service".
Like this: ExecStart=/usr/sbin/named -4 -u named -c ${NAMEDCONF} $OPTIONS
Or preferably by adding the option to /etc/sysconfig/named. Like this: OPTIONS="-4"

For good measure. In addition also remove/comment out all things IPv6 in the BIND configuration.

o This will prevent named from trying to use IPv6 to access the root servers.
o Don't think it is necessary to remove the AAAA records from the root hints. Think they will just be ignored.
o Don't know whether or not forwarders are afflicted by this.

A few symptoms of this issue are:
1) Slow initial/intermittent recursion lookups. About 10 seconds was the experience here on this system.
2) A lot of "resolver: info: resolver priming query complete" log entries.
3) Slow to get the cache primed after start up.

CentOS Linux release 7.8.2003 (Core)
Derived from Red Hat Enterprise Linux 7.8 (Source)
BIND 9.11.4-P2-RedHat-9.11.4-16.P2.el7_8.3 (Extended Support Version) <id:7107deb>

Hopefully this has been fixed by default in later versions. But for those not there yet...
Enjoy the fruits of my labor, as I am doing, with snappy recursive resolving and a more stable BIND implementation.

Post Reply

Return to “CentOS 7 - Networking Support”