You could try using --skip-broken to work around the problem

Issues related to applications and software problems
Post Reply
Eminent2021
Posts: 31
Joined: 2018/12/03 12:26:41

You could try using --skip-broken to work around the problem

Post by Eminent2021 » 2020/04/15 09:14:47

Hi,
When I run

Code: Select all

# yum update
I get this error:

Code: Select all

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
What I've tried:

Code: Select all

# yum clean all
# package-cleanup --problems
# package-cleanup --dupes
# rpm -Va --nofiles --nodigest
I get the same error. Any idea?
EDIT-1: I don't want to skip the broken packages.
EDIT-2: "yum update" output:

Code: Select all

Loaded plugins: fastestmirror, security
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base: mirror.plusweb.com.tr
 * extras: mirror.plusweb.com.tr
 * remi-php70: remi.mirror.liteserver.nl
 * remi-php71: remi.mirror.liteserver.nl
 * remi-php72: remi.mirror.liteserver.nl
 * remi-safe: remi.mirror.liteserver.nl
 * updates: mirrors.afghan-wireless.com
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:5.4.45-9.el6.remi will be updated
---> Package php.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: httpd-mmn = 20120211x8664 for package: php-7.2.29-1.e                                                                                                                     l7.remi.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: ph                                                                                                                     p-7.2.29-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-7.2.29-                                                                                                                     1.el7.remi.x86_64
--> Processing Dependency: libargon2.so.0()(64bit) for package: php-7.2.29-1.el7                                                                                                                     .remi.x86_64
---> Package php-cli.x86_64 0:5.4.45-9.el6.remi will be updated
---> Package php-cli.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: ph                                                                                                                     p-cli-7.2.29-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-cli-7.2                                                                                                                     .29-1.el7.remi.x86_64
--> Processing Dependency: libargon2.so.0()(64bit) for package: php-cli-7.2.29-1                                                                                                                     .el7.remi.x86_64
---> Package php-common.x86_64 0:5.4.45-9.el6.remi will be updated
--> Processing Dependency: php-json(x86-64) = 7.2.29-1.el7.remi for package: php                                                                                                                     -common-7.2.29-1.el7.remi.x86_64
---> Package php-common.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-common-                                                                                                                     7.2.29-1.el7.remi.x86_64
---> Package php-gd.x86_64 0:5.4.45-9.el6.remi will be updated
---> Package php-gd.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: gd-last(x86-64) >= 2.1.1 for package: php-gd-7.2.29-1                                                                                                                     .el7.remi.x86_64
--> Processing Dependency: libgd.so.3()(64bit) for package: php-gd-7.2.29-1.el7.                                                                                                                     remi.x86_64
--> Processing Dependency: libpng15.so.15()(64bit) for package: php-gd-7.2.29-1.                                                                                                                     el7.remi.x86_64
---> Package php-ldap.x86_64 0:5.4.45-9.el6.remi will be updated
---> Package php-ldap.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-ldap-7.                                                                                                                     2.29-1.el7.remi.x86_64
--> Processing Dependency: libsasl2.so.3()(64bit) for package: php-ldap-7.2.29-1                                                                                                                     .el7.remi.x86_64
---> Package php-mysql.x86_64 0:5.4.45-9.el6.remi will be obsoleted
---> Package php-mysqlnd.x86_64 0:7.2.29-1.el7.remi will be obsoleting
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-mysqlnd                                                                                                                     -7.2.29-1.el7.remi.x86_64
---> Package php-odbc.x86_64 0:5.4.45-9.el6.remi will be updated
---> Package php-odbc.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-odbc-7.                                                                                                                     2.29-1.el7.remi.x86_64
---> Package php-pdo.x86_64 0:5.4.45-9.el6.remi will be updated
---> Package php-pdo.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-pdo-7.2                                                                                                                     .29-1.el7.remi.x86_64
---> Package php-pear.noarch 1:1.9.4-5.el6 will be updated
---> Package php-pear.noarch 1:1.10.11-1.el7.remi will be an update
--> Processing Dependency: php-composer(fedora/autoloader) for package: 1:php-pe                                                                                                                     ar-1.10.11-1.el7.remi.noarch
--> Processing Dependency: php-posix for package: 1:php-pear-1.10.11-1.el7.remi.                                                                                                                     noarch
---> Package php-pecl-apc.x86_64 0:3.1.15-0.4.20130912.el6.remi.5.4 will be obso                                                                                                                     leted
---> Package php-pecl-apcu-bc.x86_64 0:1.0.5-1.el7.remi.7.2 will be obsoleting
--> Processing Dependency: php-pecl-apcu(x86-64) >= 5.1.2 for package: php-pecl-                                                                                                                     apcu-bc-1.0.5-1.el7.remi.7.2.x86_64
---> Package php-pecl-memcache.x86_64 0:3.0.8-2.el6.remi.5.4 will be updated
---> Package php-pecl-memcache.x86_64 0:4.0.5.2-1.el7.remi.7.2 will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-pecl-me                                                                                                                     mcache-4.0.5.2-1.el7.remi.7.2.x86_64
---> Package php-pgsql.x86_64 0:5.4.45-9.el6.remi will be updated
---> Package php-pgsql.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-pgsql-7                                                                                                                     .2.29-1.el7.remi.x86_64
---> Package php-soap.x86_64 0:5.4.45-9.el6.remi will be updated
---> Package php-soap.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-soap-7.                                                                                                                     2.29-1.el7.remi.x86_64
---> Package php-xml.x86_64 0:5.4.45-9.el6.remi will be updated
---> Package php-xml.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libxml2.so.2(LIBXML2_2.9.0)(64bit) for package: php-x                                                                                                                     ml-7.2.29-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-xml-7.2                                                                                                                     .29-1.el7.remi.x86_64
---> Package php-xmlrpc.x86_64 0:5.4.45-9.el6.remi will be updated
---> Package php-xmlrpc.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-xmlrpc-                                                                                                                     7.2.29-1.el7.remi.x86_64
--> Running transaction check
---> Package gd-last.x86_64 0:2.3.0-1.el7.remi will be installed
--> Processing Dependency: libpng15.so.15(PNG15_0)(64bit) for package: gd-last-2                                                                                                                     .3.0-1.el7.remi.x86_64
--> Processing Dependency: libtiff.so.5(LIBTIFF_4.0)(64bit) for package: gd-last                                                                                                                     -2.3.0-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: gd-last-2.3                                                                                                                     .0-1.el7.remi.x86_64
--> Processing Dependency: libpng15.so.15()(64bit) for package: gd-last-2.3.0-1.                                                                                                                     el7.remi.x86_64
--> Processing Dependency: libraqm.so.0()(64bit) for package: gd-last-2.3.0-1.el                                                                                                                     7.remi.x86_64
--> Processing Dependency: libtiff.so.5()(64bit) for package: gd-last-2.3.0-1.el                                                                                                                     7.remi.x86_64
--> Processing Dependency: libwebp.so.7()(64bit) for package: gd-last-2.3.0-1.el                                                                                                                     7.remi.x86_64
---> Package php.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: httpd-mmn = 20120211x8664 for package: php-7.2.29-1.e                                                                                                                     l7.remi.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: ph                                                                                                                     p-7.2.29-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-7.2.29-                                                                                                                     1.el7.remi.x86_64
--> Processing Dependency: libargon2.so.0()(64bit) for package: php-7.2.29-1.el7                                                                                                                     .remi.x86_64
---> Package php-cli.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: ph                                                                                                                     p-cli-7.2.29-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-cli-7.2                                                                                                                     .29-1.el7.remi.x86_64
--> Processing Dependency: libargon2.so.0()(64bit) for package: php-cli-7.2.29-1                                                                                                                     .el7.remi.x86_64
---> Package php-common.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-common-                                                                                                                     7.2.29-1.el7.remi.x86_64
---> Package php-fedora-autoloader.noarch 0:1.0.1-2.el6 will be installed
---> Package php-gd.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libpng15.so.15()(64bit) for package: php-gd-7.2.29-1.                                                                                                                     el7.remi.x86_64
---> Package php-json.x86_64 0:7.2.29-1.el7.remi will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-json-7.                                                                                                                     2.29-1.el7.remi.x86_64
---> Package php-ldap.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-ldap-7.                                                                                                                     2.29-1.el7.remi.x86_64
--> Processing Dependency: libsasl2.so.3()(64bit) for package: php-ldap-7.2.29-1                                                                                                                     .el7.remi.x86_64
---> Package php-mysqlnd.x86_64 0:7.2.29-1.el7.remi will be obsoleting
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-mysqlnd                                                                                                                     -7.2.29-1.el7.remi.x86_64
---> Package php-odbc.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-odbc-7.                                                                                                                     2.29-1.el7.remi.x86_64
---> Package php-pdo.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-pdo-7.2                                                                                                                     .29-1.el7.remi.x86_64
---> Package php-pecl-apcu.x86_64 0:5.1.18-1.el7.remi.7.2 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-pecl-ap                                                                                                                     cu-5.1.18-1.el7.remi.7.2.x86_64
---> Package php-pecl-memcache.x86_64 0:4.0.5.2-1.el7.remi.7.2 will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-pecl-me                                                                                                                     mcache-4.0.5.2-1.el7.remi.7.2.x86_64
---> Package php-pgsql.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-pgsql-7                                                                                                                     .2.29-1.el7.remi.x86_64
---> Package php-process.x86_64 0:7.2.29-1.el7.remi will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-process                                                                                                                     -7.2.29-1.el7.remi.x86_64
---> Package php-soap.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-soap-7.                                                                                                                     2.29-1.el7.remi.x86_64
---> Package php-xml.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libxml2.so.2(LIBXML2_2.9.0)(64bit) for package: php-x                                                                                                                     ml-7.2.29-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-xml-7.2                                                                                                                     .29-1.el7.remi.x86_64
---> Package php-xmlrpc.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-xmlrpc-                                                                                                                     7.2.29-1.el7.remi.x86_64
--> Running transaction check
---> Package gd-last.x86_64 0:2.3.0-1.el7.remi will be installed
--> Processing Dependency: libpng15.so.15(PNG15_0)(64bit) for package: gd-last-2                                                                                                                     .3.0-1.el7.remi.x86_64
--> Processing Dependency: libtiff.so.5(LIBTIFF_4.0)(64bit) for package: gd-last                                                                                                                     -2.3.0-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: gd-last-2.3                                                                                                                     .0-1.el7.remi.x86_64
--> Processing Dependency: libpng15.so.15()(64bit) for package: gd-last-2.3.0-1.                                                                                                                     el7.remi.x86_64
--> Processing Dependency: libraqm.so.0()(64bit) for package: gd-last-2.3.0-1.el                                                                                                                     7.remi.x86_64
--> Processing Dependency: libtiff.so.5()(64bit) for package: gd-last-2.3.0-1.el                                                                                                                     7.remi.x86_64
---> Package libwebp7.x86_64 0:1.0.3-1.el7.remi will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libwebp7-1.                                                                                                                     0.3-1.el7.remi.x86_64
---> Package php.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: httpd-mmn = 20120211x8664 for package: php-7.2.29-1.e                                                                                                                     l7.remi.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: ph                                                                                                                     p-7.2.29-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-7.2.29-                                                                                                                     1.el7.remi.x86_64
--> Processing Dependency: libargon2.so.0()(64bit) for package: php-7.2.29-1.el7                                                                                                                     .remi.x86_64
---> Package php-cli.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: ph                                                                                                                     p-cli-7.2.29-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-cli-7.2                                                                                                                     .29-1.el7.remi.x86_64
--> Processing Dependency: libargon2.so.0()(64bit) for package: php-cli-7.2.29-1                                                                                                                     .el7.remi.x86_64
---> Package php-common.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-common-                                                                                                                     7.2.29-1.el7.remi.x86_64
---> Package php-gd.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libpng15.so.15()(64bit) for package: php-gd-7.2.29-1.                                                                                                                     el7.remi.x86_64
---> Package php-json.x86_64 0:7.2.29-1.el7.remi will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-json-7.                                                                                                                     2.29-1.el7.remi.x86_64
---> Package php-ldap.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-ldap-7.                                                                                                                     2.29-1.el7.remi.x86_64
--> Processing Dependency: libsasl2.so.3()(64bit) for package: php-ldap-7.2.29-1                                                                                                                     .el7.remi.x86_64
---> Package php-mysqlnd.x86_64 0:7.2.29-1.el7.remi will be obsoleting
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-mysqlnd                                                                                                                     -7.2.29-1.el7.remi.x86_64
---> Package php-odbc.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-odbc-7.                                                                                                                     2.29-1.el7.remi.x86_64
---> Package php-pdo.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-pdo-7.2                                                                                                                     .29-1.el7.remi.x86_64
---> Package php-pecl-apcu.x86_64 0:5.1.18-1.el7.remi.7.2 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-pecl-ap                                                                                                                     cu-5.1.18-1.el7.remi.7.2.x86_64
---> Package php-pecl-memcache.x86_64 0:4.0.5.2-1.el7.remi.7.2 will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-pecl-me                                                                                                                     mcache-4.0.5.2-1.el7.remi.7.2.x86_64
---> Package php-pgsql.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-pgsql-7                                                                                                                     .2.29-1.el7.remi.x86_64
---> Package php-process.x86_64 0:7.2.29-1.el7.remi will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-process                                                                                                                     -7.2.29-1.el7.remi.x86_64
---> Package php-soap.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-soap-7.                                                                                                                     2.29-1.el7.remi.x86_64
---> Package php-xml.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libxml2.so.2(LIBXML2_2.9.0)(64bit) for package: php-x                                                                                                                     ml-7.2.29-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-xml-7.2                                                                                                                     .29-1.el7.remi.x86_64
---> Package php-xmlrpc.x86_64 0:7.2.29-1.el7.remi will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-xmlrpc-                                                                                                                     7.2.29-1.el7.remi.x86_64
--> Finished Dependency Resolution
Error: Package: php-pdo-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-ldap-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-json-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-ldap-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libsasl2.so.3()(64bit)
Error: Package: php-mysqlnd-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-pecl-memcache-4.0.5.2-1.el7.remi.7.2.x86_64 (remi-php72)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-cli-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Error: Package: php-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Error: Package: php-pgsql-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-gd-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libpng15.so.15()(64bit)
Error: Package: gd-last-2.3.0-1.el7.remi.x86_64 (remi-safe)
           Requires: libtiff.so.5(LIBTIFF_4.0)(64bit)
Error: Package: gd-last-2.3.0-1.el7.remi.x86_64 (remi-safe)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-odbc-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: gd-last-2.3.0-1.el7.remi.x86_64 (remi-safe)
           Requires: libpng15.so.15()(64bit)
Error: Package: gd-last-2.3.0-1.el7.remi.x86_64 (remi-safe)
           Requires: libpng15.so.15(PNG15_0)(64bit)
Error: Package: gd-last-2.3.0-1.el7.remi.x86_64 (remi-safe)
           Requires: libraqm.so.0()(64bit)
Error: Package: php-xml-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-pecl-apcu-5.1.18-1.el7.remi.7.2.x86_64 (remi-php72)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-process-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-xml-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libxml2.so.2(LIBXML2_2.9.0)(64bit)
Error: Package: gd-last-2.3.0-1.el7.remi.x86_64 (remi-safe)
           Requires: libtiff.so.5()(64bit)
Error: Package: php-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: httpd-mmn = 20120211x8664
           Installed: httpd-2.2.15-69.el6.centos.x86_64 (@base)
               httpd-mmn = 20051115
Error: Package: php-common-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-cli-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-soap-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-xmlrpc-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-cli-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libargon2.so.0()(64bit)
Error: Package: php-7.2.29-1.el7.remi.x86_64 (remi-php72)
           Requires: libargon2.so.0()(64bit)
Error: Package: libwebp7-1.0.3-1.el7.remi.x86_64 (remi-safe)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

User avatar
TrevorH
Forum Moderator
Posts: 29903
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: You could try using --skip-broken to work around the problem

Post by TrevorH » 2020/04/15 13:28:28

Your problem is that you've added the CentOS 7 "Remi" repo to your CentOS 6 system. Run yum clean all then yum remove remi-release or whatever the -release package is called. Now go get the correct remi-release for CentOS 6 and install that.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 6 - Software Support”