[Solved] [I am an idiot] Installation process halts with black screen

General support questions
Post Reply
cockatiel
Posts: 4
Joined: 2020/02/15 03:37:49

[Solved] [I am an idiot] Installation process halts with black screen

Post by cockatiel » 2020/02/15 03:52:04

Hello, i had tried to install CentOS 7.7 on my system. But it failed.

When i select anything (e.g. Install CentOS 7, Test this media & install CentOS 7) at the first page of installation, screen goes to be black (CentOS 7.6) or print black screen with partially broken graphic (CentOS 7.7, CentOS 8.1) and halt.

Below is the configuration of my system.
======================================
CPU : Xeon scalable gold 5220
GPU : NVIDIA RTX 2060
MB : GIGABYTE C621-SU8
SSD : 970 EVO+ 1TB


If you know why this happens, please help me.


==================[Solved]======================

This issue happens from connecting monitor with external graphic card.

After i connected monitor with motherboard, it works well.


Thank you for everyone who replied for my question!
Last edited by cockatiel on 2020/02/16 16:06:39, edited 1 time in total.

tunk
Posts: 649
Joined: 2017/02/22 15:08:17

Re: Installation process halts with black screen

Post by tunk » 2020/02/15 13:09:44

Did you verify the checksums?
And if you're using a memory stick, how did you create it:
https://wiki.centos.org/HowTos/InstallFromUSBkey

User avatar
TrevorH
Forum Moderator
Posts: 27687
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Installation process halts with black screen

Post by TrevorH » 2020/02/15 13:11:11

Try the "install in basic video" option off the Troubleshooting menu when you first boot up. It's likely that your video card it too new to be understood properly by the opensource nouveau video driver. You could also try appending rd.driver.blacklist=nouveau to the kernel command line and see if that also helps.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

cockatiel
Posts: 4
Joined: 2020/02/15 03:37:49

Re: Installation process halts with black screen

Post by cockatiel » 2020/02/15 14:29:41

tunk wrote:
2020/02/15 13:09:44
Did you verify the checksums?
And if you're using a memory stick, how did you create it:
https://wiki.centos.org/HowTos/InstallFromUSBkey
Thank you for your reply.

I didn't verify the checksums. But the usb memory stick that i used works well when i install CentOS 7.7 on another PC.

I used Wind 32 Disk Imager to make booting usb.

cockatiel
Posts: 4
Joined: 2020/02/15 03:37:49

Re: Installation process halts with black screen

Post by cockatiel » 2020/02/15 14:44:37

TrevorH wrote:
2020/02/15 13:11:11
Try the "install in basic video" option off the Troubleshooting menu when you first boot up. It's likely that your video card it too new to be understood properly by the opensource nouveau video driver. You could also try appending rd.driver.blacklist=nouveau to the kernel command line and see if that also helps.
Thank you for your reply.

I tried "install in basic video" and appending "rd.driver.blacklist=nouveau". But both of them didn't work..

User avatar
TrevorH
Forum Moderator
Posts: 27687
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Installation process halts with black screen

Post by TrevorH » 2020/02/15 18:14:21

I didn't verify the checksums. But the usb memory stick that i used works well when i install CentOS 7.7 on another PC.
But that doesn't tell you if your download was corrupt and nor does it tell you if someone has tampered with it before you got it. Always check a file's integrity before you try to use it.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

desertcat
Posts: 693
Joined: 2014/08/07 02:17:29
Location: Tucson, AZ

Re: Installation process halts with black screen

Post by desertcat » 2020/02/15 23:20:42

cockatiel wrote:
2020/02/15 14:29:41
tunk wrote:
2020/02/15 13:09:44
Did you verify the checksums?
And if you're using a memory stick, how did you create it:
https://wiki.centos.org/HowTos/InstallFromUSBkey
Thank you for your reply.

I didn't verify the checksums. But the usb memory stick that i used works well when i install CentOS 7.7 on another PC.

I used Wind 32 Disk Imager to make booting usb.
Why not try to create a NEW usb image on a NEW usb drive using the dd command and after you create make sure to check the checksum to make sure there is not a corrupted file. Before you say it, YES a GIANT PITA but that is one way to check to make sure the problem is NOT liked to the install media. If in doubt start from scratch.

cockatiel
Posts: 4
Joined: 2020/02/15 03:37:49

Re: [Solved] [I am an idiot] Installation process halts with black screen

Post by cockatiel » 2020/02/16 16:07:04

Thank you for everyone who replied for my question!

It is solved!

Post Reply

Return to “CentOS 7 - General Support”