Wifi mysteriously stopped working???

Issues related to configuring your network
justindwalker87
Posts: 24
Joined: 2020/02/05 17:00:47

Re: Wifi mysteriously stopped working???

Post by justindwalker87 » 2020/02/17 18:27:16

Not sure exactly how it was set up before, as it worked as a plug and play. I made sure the adapter works on the host system, and enabled the adapter in Virtual Box, but still no wifi adapter found in centos.

User avatar
TrevorH
Forum Moderator
Posts: 29407
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Wifi mysteriously stopped working???

Post by TrevorH » 2020/02/18 00:10:03

Your VMs won't have a wireless adapter. They depend on the host to do the wireless bit and virtualbox/vmware/whatever emulates a *wired* connection to your guests. They do not know about wifi and do not care.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

justindwalker87
Posts: 24
Joined: 2020/02/05 17:00:47

Re: Wifi mysteriously stopped working???

Post by justindwalker87 » 2020/02/20 18:33:45

TrevorH wrote:
2020/02/16 02:02:28
Is it actually showing as a wireless adapter in your virtualbox VM? As I say, normally you install a wireless adapter on the host operating system and then virtualbox gives the guest what appears to it to be a wired connection. Is that not how you had it set up before?
It is showing as a wireless adapter in the virtualbox application but not when I actually boot centos. The wireless adapter works on the host operating system and even ubuntu and suse just fine, just centos says "No wi-fi adapter found." Thanks

justindwalker87
Posts: 24
Joined: 2020/02/05 17:00:47

Re: Wifi mysteriously stopped working???

Post by justindwalker87 » 2020/02/20 18:36:00

Do I need to do something under network perhaps?

justindwalker87
Posts: 24
Joined: 2020/02/05 17:00:47

Re: Wifi mysteriously stopped working???

Post by justindwalker87 » 2020/02/20 22:11:36

TrevorH wrote:
2020/02/18 00:10:03
Your VMs won't have a wireless adapter. They depend on the host to do the wireless bit and virtualbox/vmware/whatever emulates a *wired* connection to your guests. They do not know about wifi and do not care.
Sorry didn't see this reply at first. I did notice that in Suse and Ubuntu it shows up as a wired ethernet connection, but like I said the host is very well connected, just don't know what steps to take to get CentOS connected to the internet.

User avatar
TrevorH
Forum Moderator
Posts: 29407
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Wifi mysteriously stopped working???

Post by TrevorH » 2020/02/21 02:14:47

Show the output from lspci -nn | grep -i net and also from ip l sh on the guest.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

justindwalker87
Posts: 24
Joined: 2020/02/05 17:00:47

Re: Wifi mysteriously stopped working???

Post by justindwalker87 » 2020/02/21 21:36:46

TrevorH wrote:
2020/02/21 02:14:47
Show the output from lspci -nn | grep -i net and also from ip l sh on the guest.
Annotation 2020-02-21 133441.png
Annotation 2020-02-21 133441.png (174.1 KiB) Viewed 404 times

User avatar
TrevorH
Forum Moderator
Posts: 29407
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Wifi mysteriously stopped working???

Post by TrevorH » 2020/02/21 22:36:15

Right, so as expected you do not have a wireless card inside the VM. An Intel 82540EM is a wired connection not a wireless one. It also shows that you have a device named enp0s3 which will be the interface in question. Now show the contents of /etc/sysconfig/network-scripts/ifcfg-enp0s3 - though you might just check it before you do so and make sure that it says "ONBOOT=yes" and not 'no' as that would explain why it's not active on boot.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

justindwalker87
Posts: 24
Joined: 2020/02/05 17:00:47

Re: Wifi mysteriously stopped working???

Post by justindwalker87 » 2020/02/21 22:45:43

Annotation 2020-02-21 144507.png
Annotation 2020-02-21 144507.png (109.97 KiB) Viewed 371 times

User avatar
TrevorH
Forum Moderator
Posts: 29407
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Wifi mysteriously stopped working???

Post by TrevorH » 2020/02/21 23:20:17

It's not something you run, it's a text file. Use less or vi or whatever your preferred editor is, or just cat.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - Networking Support”