cifs mount works on 6.8, but not on 6.5

Issues related to applications and software problems
Post Reply
sjprothero
Posts: 3
Joined: 2014/06/04 13:57:49

cifs mount works on 6.8, but not on 6.5

Post by sjprothero » 2019/12/22 15:29:05

Good Afternoon,

We have a new Windows-based storage system which is using DFS (Distributed File System) so the shares are not tied to individual servers; I used a server running CentOS 6.8 for testing and have things set up there in a satisfactory manner, I now need to replicate that mount on a Centos 6.5 server, but mostly just get "mount error(22): Invalid argument". We are desperate to get this working so that I can migrate 48TB data and then we can replace the 6.5 server with a shiny new 8.x one. Getting this working might just be my best Christmas present!

This is the entry in /etc/fstab from the working CentOS 6.8 system; <domain> being my domain, anonymised to protect the innocent:

//<domain>.com/shares/CAE01 /CAE01 cifs uid=630,gid=10101,file_mode=0664,dir_mode=0775,rw,suid,credentials=/etc/pass.txt 0 0

/etc/pass.txt contains username, password and domain, it is the same on both systems.

If I try this same set of options on the 6.5 server, I repeatedly get:

mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Which is about half a step better than saying "oops, it didn't work".

I've been playing with different options to see if anything changes; if I use an account (root) which I know to be locked out in AD, and a basic mount command

mount -t cifs -o rw,suid //<domain>.com/shares/CAE01 /CAE01

the error is "mount error(13): Permission denied" and the following is recorded from dmesg:

Status code returned 0xc0000234 NT_STATUS_ACCOUNT_LOCKED_OUT
CIFS VFS: Send error in SessSetup = -13
CIFS VFS: cifs_mount failed w/return code = -13

indicating that the authentication request is going to the AD servers (I think).

I have tried options which I don't think are relevant in my case, but I'm getting to the point of trying anything:

sec=ntlm, sec-ntlmv5 and sec=ntlmssp all give "mount error(95): Operation not supported" and dmesg gives "CIFS VFS: Server requires packet signing to be enabled in /proc/fs/cifs/SecurityFlags.", as expected. I've also tried vers=1.0 and other vers=.

The working server has cifs-utils-4.8.1-20.el6.x86_64, the 6.5 one has cifs-utils-4.8.1-19.el6.x86_64, but yum tells me that's as good as it gets.

Does anyone have any other suggestions please?

User avatar
TrevorH
Forum Moderator
Posts: 28095
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: cifs mount works on 6.8, but not on 6.5

Post by TrevorH » 2019/12/22 16:00:23

CentOS 6.5 (from Dec 2013) is over 6 years out of date and has not been supported since the release of 6.6 in October 2014. CentOS 6.8 is not suported either and that dates from "only" 2016.

The ONLY CentOS 6 version that is supported is 6.10 and that is the version you should be using. There is no support for older versions and any requests will be met with the answer "upgrade to 6.10 and retest".
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

sjprothero
Posts: 3
Joined: 2014/06/04 13:57:49

Re: cifs mount works on 6.8, but not on 6.5

Post by sjprothero » 2019/12/22 17:32:48

I know that it's old and out of support, unfortunately I don't have the budget for its replacement until next year, but I do still have to keep these old things creaking along until the end of Q1. I will investigate updating to 6.10, I was just hoping that someone might have seen something similar and perhaps have a more creative reply than "update".

Whoever
Posts: 1105
Joined: 2013/09/06 03:12:10

Re: cifs mount works on 6.8, but not on 6.5

Post by Whoever » 2019/12/23 05:07:23

sjprothero wrote:
2019/12/22 17:32:48
I know that it's old and out of support, unfortunately I don't have the budget for its replacement until next year, but I do still have to keep these old things creaking along until the end of Q1. I will investigate updating to 6.10, I was just hoping that someone might have seen something similar and perhaps have a more creative reply than "update".
Updating to CentOS 6.10 is as simple as running "yum update" as root.

sjprothero
Posts: 3
Joined: 2014/06/04 13:57:49

Re: cifs mount works on 6.8, but not on 6.5

Post by sjprothero » 2019/12/23 09:47:28

Thanks, I know it's a simple command to update, but my issue is not what you have to do, but when it can be done for a cluster that's in use most of the time, over night and weekends included - the Christmas break just means that the engineers will queue up more jobs.

Since there is no other way around it, I will be planning the update in the new year.

Post Reply

Return to “CentOS 6 - Software Support”