CentOS 8 - gnome-software

Issues related to applications and software problems and general support
Post Reply
Posts: 11
Joined: 2018/12/05 01:48:15

CentOS 8 - gnome-software

Post by jcicerof » 2019/10/06 22:38:50

I installed new CentOS 8 Stream in a Virtualbox VM and now it is working fine but I tried to install some plugins using gnome-software and it is not working properly. No itens appear for any categories. I started gnome-software in verbose mode and I got this message:

Code: Select all

$ sudo killall gnome-software
$ gnome-software --verbose

.. several messages

22:12:45:0281 Gs  opened plugin /usr/lib64/gs-plugins-12/libgs_plugin_rewrite-resource.so: rewrite-resource
22:12:45:0281 Gs  Failed to load /usr/lib64/gs-plugins-12/libgs_plugin_rpm-ostree.so: failed to open plugin /usr/lib64/gs-plugins-12/libgs_plugin_rpm-ostree.so: libdnf.so.1: cannot open shared object file: No such file or directory
22:12:45:0281 Gs  opened plugin /usr/lib64/gs-plugins-12/libgs_plugin_shell-extensions.so: shell-extensions

.. several messages 

22:13:05:0523 Gs  Only 0 apps for popular list, hiding
22:13:05:0526 Gs  not handling error download-failed for action refine: failed to resolve package_ids: cannot update repo 'Stream-AppStream': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried; Last error: Status code: 404 for http://mirror.centos.org/$contentdir/$stream/AppStream/x86_64/os/repodata/repomd.xml
22:13:05:0526 Gs  emitting global finished

I am able to perform a dnf update so I presume the list of mirrors is fine.
Is there someone who knows why gnome-software is not working on CentOS 8?

Thanks in advance,
Screenshot from 2019-10-06 19-37-19.png
Screenshot from 2019-10-06 19-37-19.png (41.64 KiB) Viewed 13012 times

Posts: 11
Joined: 2018/12/05 01:48:15

[SOLVED] Re: CentOS 8 - gnome-software

Post by jcicerof » 2019/10/07 05:29:35

I was able to understand what happened. For some reason the files on /etc/yum.repos.d/CentOS-Stream*.repo the row starting with mirrorlist was commented and baseurl was uncommented.
I changed these files in order to have mirrorlist active and baseurl commented.

file: CentOS-Stream-AppStream.repo

Code: Select all

name=CentOS-Stream - AppStream
So I fixed all CentOS_Stream*.repo files and after that I cleaned the dnf cache:

Code: Select all

sudo dnf clean all
sudo rm -r /var/cache/dnf
sudo rm -r /var/cache/PackageKit

sudo dnf upgrade
sudo pkcon refresh
Now gnome-software open correctly on CentOS Stream.
Screenshot from 2019-10-07 02-26-10.png
Screenshot from 2019-10-07 02-26-10.png (66.89 KiB) Viewed 12968 times

Posts: 1
Joined: 2019/10/29 02:45:06

Re: CentOS 8 - gnome-software

Post by PeteInSC » 2019/10/29 02:50:05

Thanks for this solution. I had the exact same thing happen but it was with a different repo. I had two urls in one line.
I commented out the second URL.
Still was not working until I killed my cache.
I used these commands:
killall gnome-software
rm -rf ~/.cache/gnome-software

That fixed it for me.
Thanks again for posting your solution.
I hope this helps someone else!

Posts: 5
Joined: 2019/11/03 12:31:25

Re: CentOS 8 - gnome-software

Post by alex.theoto » 2019/11/09 12:59:41

I have a similar problem with gnome-software which I didn't find a solution yet and I want you ask you if you disabled the Centos8 repositories.
I disabled them because of duplicate packages and maybe the distro will not follow the rolling release mechanism.

Can you give me the output of

Code: Select all

dnf repolist --all
Thank you in advance.

Posts: 11
Joined: 2018/12/05 01:48:15

Re: CentOS 8 - gnome-software

Post by jcicerof » 2019/12/22 00:45:37

Hello Alex,

Sorry for long time to answer you. I am giving a time to CentOS 8 (and Red Hat 8). So far both appears to me as an beta version and I still keep CentOS 7 as my first option.

Regarding your question, this is the output for dnf: repolist --all

Code: Select all

repo id                                     repo name             status
AppStream                                   CentOS-8 - AppStream  enabled: 5,089
AppStream-source                            CentOS-8 - AppStream  disabled
BaseOS                                      CentOS-8 - Base       enabled: 2,843
BaseOS-source                               CentOS-8 - BaseOS Sou disabled
PowerTools                                  CentOS-8 - PowerTools enabled: 1,507
Stream-AppStream                            CentOS-Stream - AppSt enabled: 5,089
Stream-AppStream-source                     CentOS-Stream - AppSt disabled
Stream-BaseOS                               CentOS-Stream - Base  enabled: 2,843
Stream-BaseOS-source                        CentOS-Stream - BaseO disabled
Stream-PowerTools                           CentOS-Stream - Power disabled
Stream-base-debuginfo                       CentOS-Stream - Debug disabled
Stream-centosplus                           CentOS-Stream - Plus  disabled
Stream-centosplus-source                    CentOS-Stream - Plus  disabled
Stream-extras                               CentOS-Stream - Extra enabled:     3
Stream-extras-source                        CentOS-Stream - Extra disabled
base-debuginfo                              CentOS-8 - Debuginfo  disabled
c8-Stream-media-AppStream                   CentOS-Stream-AppStre disabled
c8-Stream-media-BaseOS                      CentOS-Stream-BaseOS  disabled
c8-media-AppStream                          CentOS-AppStream-8 -  disabled
c8-media-BaseOS                             CentOS-BaseOS-8 - Med disabled
centosplus                                  CentOS-8 - Plus       disabled
centosplus-source                           CentOS-8 - Plus Sourc disabled
cr                                          CentOS-8 - cr         disabled
*epel                                       Extra Packages for En enabled: 3,707
epel-debuginfo                              Extra Packages for En disabled
epel-playground                             Extra Packages for En disabled
epel-playground-debuginfo                   Extra Packages for En disabled
epel-playground-source                      Extra Packages for En disabled
epel-source                                 Extra Packages for En disabled
epel-testing                                Extra Packages for En disabled
epel-testing-debuginfo                      Extra Packages for En disabled
epel-testing-source                         Extra Packages for En disabled
extras                                      CentOS-8 - Extras     enabled:     3
extras-source                               CentOS-8 - Extras Sou disabled
fasttrack                                   CentOS-8 - fasttrack  disabled
rpmfusion-free-updates                      RPM Fusion for EL 8 - enabled:   163
rpmfusion-free-updates-debuginfo            RPM Fusion for EL 8 - disabled
rpmfusion-free-updates-source               RPM Fusion for EL 8 - disabled
rpmfusion-free-updates-testing              RPM Fusion for EL 8 - disabled
rpmfusion-free-updates-testing-debuginfo    RPM Fusion for EL 8 - disabled
rpmfusion-free-updates-testing-source       RPM Fusion for EL 8 - disabled
rpmfusion-nonfree-updates                   RPM Fusion for EL 8 - enabled:    51
rpmfusion-nonfree-updates-debuginfo         RPM Fusion for EL 8 - disabled
rpmfusion-nonfree-updates-source            RPM Fusion for EL 8 - disabled
rpmfusion-nonfree-updates-testing           RPM Fusion for EL 8 - disabled
rpmfusion-nonfree-updates-testing-debuginfo RPM Fusion for EL 8 - disabled
rpmfusion-nonfree-updates-testing-source    RPM Fusion for EL 8 - disabled
Hope this help you,

Posts: 1
Joined: 2019/12/27 10:29:25

Re: CentOS 8 - gnome-software

Post by devendra » 2019/12/27 12:27:35

The problem seems to that pkcon does not understand streams (I used CentOS Stream version). The problem arises for CentOS_Stream* files, which have the following:

mirrorlist=http://mirrorlist.centos.org/?release=$ ... fra=$infra

That $stream should be replaced by the value of:

$ cat /etc/dnf/vars/stream

I don't know what the value of $releasever is. Hardcoding s/$stream/8-stream/ worked for me (not ideal).

Post Reply