Bad Magic Number in super-block while trying to open /dev/sda4

General support questions
Post Reply
Posts: 1
Joined: 2019/05/19 18:18:55

Bad Magic Number in super-block while trying to open /dev/sda4

Post by theproguy » 2019/05/19 18:26:45

hi i have this issue, and tried to my fullest extent.
but couldn't achieve.
i need help in booting my system, (error: mounting /sysroot)
i have attached the error files.

i thought the might me a broken error in super blocks, so tried doing that but i got bad Magic Number error:
I loVe linux
hope solving this issue makes me love linux much more

Thank you in Advance
ind2ex.jpg (101.23 KiB) Viewed 767 times

User avatar
Forum Moderator
Posts: 29147
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Bad Magic Number in super-block while trying to open /dev/sda4

Post by TrevorH » 2019/05/19 18:39:03

Your partition does not contain a filesystem. The last line of your screenshot tells you that it's actually an LVM PV which will be part of an LVM VG that will contain LVM LVs.

Before you continue, if you interrupt the boot process when you see the grub menu you should be able to select an older kernel from the list. Do that and see if the problem is specific to the current kernel (did you just run `yum update`?).

If the error occurs on more than one kernel then you may need to fsck things. If it doesn't then it's more likely to be a common problem that happens sometimes where either the initramfs file for that kernel did not get created or it's missing the line from grub.cfg to point to it. In both cases, the easiest thing to do is to run yum reinstall kernel-3.10.0-957.12.2.el7.x86_64 - the kernel name I used there is the very latest one currently available and if you do not have it installed now then you might just yum update kernel to install it and try booting that one.

Do you have free space on your /boot partition? That's a good candidate for the cause of a missing initramfs file.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - General Support”