Yum error when installing xen

General support questions
Post Reply
moore
Posts: 2
Joined: 2018/12/12 05:44:31

Yum error when installing xen

Post by moore » 2018/12/12 06:03:30

After getting my installation completed via #yum install centos-release-xen, I further stated to install xen via

#yum install xen

,but here is the error:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror01.idc.hinet.net
* extras: mirror01.idc.hinet.net
* updates: mirror01.idc.hinet.net
base | 3.6 kB 00:00:00
http://mirror.centos.org/centos/7/virt/ ... repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below wiki article

https://wiki.centos.org/yum-errors

If above article doesn't help to resolve this issue please use https://bugs.centos.org/.



One of the configured repositories failed (CentOS-7 - xen),
and yum doesn't have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:

1. Contact the upstream for the repository and get them to fix the problem.

2. Reconfigure the baseurl/etc. for the repository, to point to a working
upstream. This is most often useful if you are using a newer
distribution release than is supported by the repository (and the
packages for the previous distribution release still work).

3. Run the command with the repository temporarily disabled
yum --disablerepo=centos-virt-xen-46 ...

4. Disable the repository permanently, so yum won't use it by default. Yum
will then just ignore the repository until you permanently enable it
again or use --enablerepo for temporary usage:

yum-config-manager --disable centos-virt-xen-46
or
subscription-manager repos --disable=centos-virt-xen-46

5. Configure the failing repository to be skipped, if it is unavailable.
Note that yum will try to contact the repo. when it runs most commands,
so will have to try and fail each time (and thus. yum will be be much
slower). If it is a very temporary problem though, this is often a nice
compromise:

yum-config-manager --save --setopt=centos-virt-xen-46.skip_if_unavailable=true

failure: repodata/repomd.xml from centos-virt-xen-46: [Errno 256] No more mirrors to try.
http://mirror.centos.org/centos/7/virt/ ... repomd.xml: [Errno 14] HTTP Error 404 - Not Found



I tried other mirrors but could not make it work. I'm pretty sure that it worked with the same repo last week. Is there something wrong or I missed?

Thanks!

User avatar
avij
Retired Moderator
Posts: 3042
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Yum error when installing xen

Post by avij » 2018/12/12 08:33:35

Xen 4.6 was dropped because it is EOL. The centos-release-xen package is in the process of being updated to point to the newer version, but in the meantime you can do yum remove centos-release-xen and then yum install centos-release-xen-48 to start using a newer version.

moore
Posts: 2
Joined: 2018/12/12 05:44:31

Re: Yum error when installing xen

Post by moore » 2018/12/17 02:09:10

Hi avij,

It does work, thank you!

huanito
Posts: 2
Joined: 2018/10/12 22:11:59

Re: Yum error when installing xen

Post by huanito » 2018/12/29 23:13:22

I just got the same error on fresh install of xen. Your fix worked. Thanks.

Post Reply

Return to “CentOS 7 - General Support”