EFI error?

General support questions
Post Reply
joe.rella@gmail.com
Posts: 2
Joined: 2018/12/03 20:28:16

EFI error?

Post by joe.rella@gmail.com » 2018/12/03 20:38:44

I am trying to add a gui to my centos 7.5 install. I used this command:

yum groupinstall "GNOME Desktop" "Graphical Administration Tools"

The system does a bunch of stuff, but eventually errors out with the following message:

Transaction check error:
file /boot/efi/EFI/centos from install of fwupdate-efi-12-5.el7.centos.x86_64 conflicts with file from package grub2-common-1:2.02-0.65.el7.centos.2.noarch


After googling, I tried this:

dnf erase fwupdate-efi

Which results in:

No match for argument: fwupdate-efi
Error: No packages marked for removal


Any suggestions?

User avatar
avij
Retired Moderator
Posts: 3046
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: EFI error?

Post by avij » 2018/12/03 20:42:47

I'm not absolutely sure if this helps, but this is still probably worth trying. Try upgrading to the just released CentOS 7.6.1810 first. yum clean all and then yum update and reboot. Then try your original yum command again.

joe.rella@gmail.com
Posts: 2
Joined: 2018/12/03 20:28:16

Re: EFI error?

Post by joe.rella@gmail.com » 2018/12/03 21:04:34

Yes, that did the trick. GNOME installing now.

Thank you!

User avatar
avij
Retired Moderator
Posts: 3046
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: EFI error?

Post by avij » 2018/12/03 21:12:57

If you don't get a GUI after you install those packages, you may need to run systemctl set-default graphical.target and systemctl isolate graphical.target afterwards.

iochy
Posts: 1
Joined: 2018/12/10 06:04:03

Re: EFI error?

Post by iochy » 2018/12/10 06:07:54

Hello I have this error by doing "yum update"
Total 2.5 MB/s | 660 MB 04:23
Running transaction check
Running transaction test


Transaction check error:
file /boot/efi/EFI/centos from install of fwupdate-efi-12-5.el7.centos.x86_64 conflicts with file from package grub2-common-1:2.02-0.65.el7.centos.2.noarch

Résumé des erreurs
-------------

[root@lenovo460 ~]#
The proposed solution does not work, an idea?
Thank you

inxs
Posts: 1
Joined: 2019/03/19 00:21:51

Re: EFI error?

Post by inxs » 2019/03/19 00:33:08

Found the solution in the Bugzilla/Redhat forum by jcastran

*** Updating grub2-common will workaround this issue allowing customers to install Server with GUI or fwupdate-efi as required ***

# yum update grub2-common
# rpm -q grub2-common
grub2-common-2.02-0.76.el7.noarch
# yum install fwupdate-efi


This got me past the grub2 error.

Post Reply

Return to “CentOS 7 - General Support”