owncloud update problem

Issues related to applications and software problems
Post Reply
muppy
Posts: 7
Joined: 2016/09/07 13:21:05

owncloud update problem

Post by muppy » 2018/11/19 10:30:50

Good morning,
I have a system with CentOS7. I wish to update owncloud from version 9.1.5.2 to the latest version.
I run the following commands

Code: Select all

rpm --import https://download.owncloud.org/download/repositories/production/CentOS_7/repodata/repomd.xml.key
wget http://download.owncloud.org/download/repositories/production/CentOS_7/ce:stable.repo -O /etc/yum.repos.d/ce:stable.repo
yum clean all
yum install owncloud-files
after the last command, i got the following error, and don't know how to fix it. Could you please help me ?
Cheers

Code: Select all

Loaded plugins: fastestmirror, langpacks, product-id, search-disabled-repos,
              : subscription-manager
This system is not registered with an entitlement server. You can use subscripti                       on-manager to register.
Loading mirror speeds from cached hostfile
 * base: mirror.init7.net
 * epel: ftp.linux.org.tr
 * extras: centos.mirroraustria.at
 * remi-safe: rpms.remirepo.net
 * updates: mirror.init7.net
Resolving Dependencies
--> Running transaction check
---> Package owncloud.noarch 0:9.1.5-1.el7 will be obsoleted
--> Processing Dependency: owncloud = 9.1.5-1.el7 for package: owncloud-mysql-9.                       1.5-1.el7.noarch
--> Processing Dependency: owncloud = 9.1.5-1.el7 for package: owncloud-httpd-9.                       1.5-1.el7.noarch
---> Package owncloud-files.noarch 0:10.0.10-1.1 will be obsoleting
--> Finished Dependency Resolution
Error: Package: owncloud-httpd-9.1.5-1.el7.noarch (@epel)
           Requires: owncloud = 9.1.5-1.el7
           Removing: owncloud-9.1.5-1.el7.noarch (@epel)
               owncloud = 9.1.5-1.el7
           Obsoleted By: owncloud-files-10.0.10-1.1.noarch (ce_10.0)
               Not found
Error: Package: owncloud-mysql-9.1.5-1.el7.noarch (@epel)
           Requires: owncloud = 9.1.5-1.el7
           Removing: owncloud-9.1.5-1.el7.noarch (@epel)
               owncloud = 9.1.5-1.el7
           Obsoleted By: owncloud-files-10.0.10-1.1.noarch (ce_10.0)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

User avatar
TrevorH
Forum Moderator
Posts: 27440
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: owncloud update problem

Post by TrevorH » 2018/11/19 12:49:18

You have some additional packages installed from the EPEL repo that require the older owncloud. You might check in epel-testing to see if there are newer ones, otherwise you need to either remove them or wait until there are newer ones available.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

muppy
Posts: 7
Joined: 2016/09/07 13:21:05

Re: owncloud update problem

Post by muppy » 2018/11/19 20:52:29

thank you for your reply!
Could you help me to identify such additional packages which requires old owncloud version ?
thank you
Andrea

User avatar
TrevorH
Forum Moderator
Posts: 27440
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: owncloud update problem

Post by TrevorH » 2018/11/19 23:52:50

They're listed in your yum output:

Error: Package: owncloud-httpd-9.1.5-1.el7.noarch (@epel)
Error: Package: owncloud-mysql-9.1.5-1.el7.noarch (@epel)
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

muppy
Posts: 7
Joined: 2016/09/07 13:21:05

Re: owncloud update problem

Post by muppy » 2018/11/25 12:29:27

Hello,
such packages belongs to owncloud, which i want to update...So, i do not understand how to perform the upgrade. Could you please help me further ?
Best regards,
Andrea

chemal
Posts: 619
Joined: 2013/12/08 19:44:49

Re: owncloud update problem

Post by chemal » 2018/11/25 18:59:19

The official owncloud rpm is a joke, not an update for what epel has. On the other hand, epel will not offer oc 10, because the PHP from base is now too old and epel doesn't make packages that depend on external repos or software collections.

muppy
Posts: 7
Joined: 2016/09/07 13:21:05

Re: owncloud update problem

Post by muppy » 2018/11/26 15:01:27

Ok, now the situation is more clear. Could you please suggest also a solution ? It is not clear to me how to upgrade OC.
Thank you
Andrea

chemal
Posts: 619
Joined: 2013/12/08 19:44:49

Re: owncloud update problem

Post by chemal » 2018/11/26 20:36:45

I don't have an upgrade plan for you. Perhaps this helps:

https://doc.owncloud.org/server/10.0/ad ... grade.html

I have recently done a fresh install of oc 10 on C7. I'm using a separate VM for this in which I installed remi's php stuff in single-version mode to get 7.1 and then oc 10 from the tarball (as per their recommendation and in lack of rpms with any prospects or use). I plan to do updates/upgrades of oc manually (see link above) and updates of php are supplied by remi.

Post Reply

Return to “CentOS 7 - Software Support”