[SOLVED] Dual monitor problem.

Issues related to hardware problems
Post Reply
FranekW
Posts: 36
Joined: 2017/05/11 21:19:21

[SOLVED] Dual monitor problem.

Post by FranekW » 2017/05/15 17:52:05

Hello,

I have 24'' and 19'' connected to NVidia GTX 275 on CentOS 7. I have a little problem with these two monitors. When I reboot or power on computer, all BIOS messages appear correctly on 24'' which is my main monitor. Windows 10 also detects monitors correctly. For some reason, CentOS 7 GNOME detects the monitor in opposite order, such that 19'' is 1 and the main monitor 24'' is 2!

Consequently, by default, the 24'' is detected as secondary monitor and the 19'' as primary. I have swapped screens in settings and the desktop appears correctly on the 24'' one but when I login after reboot or when I power on the computer, I have a login prompt on the small monitor.

Is there any way possible to change settings in order for 24'' to be 1?
Last edited by FranekW on 2017/05/16 23:29:54, edited 2 times in total.

tunk
Posts: 1105
Joined: 2017/02/22 15:08:17

Re: Dual monitory problem.

Post by tunk » 2017/05/16 13:03:47

Could you try to switch the two cables?

owl102
Posts: 407
Joined: 2014/06/10 19:13:41

Re: Dual monitory problem.

Post by owl102 » 2017/05/16 15:28:59

FranekW wrote:I have a login prompt on the small monitor.
The monitor settings done by Gnome are only associated with your login session. So if you want GDM to use the same settings, you need to copy ~/.config/monitors.xml to /var/lib/gdm/.config/ (as root), e.g.:

Code: Select all

cp ~franek/.config/monitors.xml /var/lib/gdm/.config/
German speaking forum for Fedora and CentOS: https://www.fedoraforum.de/

FranekW
Posts: 36
Joined: 2017/05/11 21:19:21

Re: Dual monitor problem.

Post by FranekW » 2017/05/16 23:29:40

Hi,

Many thanks for the answers :)
tunk wrote:Could you try to switch the two cables?
This was actually the first thing I tried. I thought I had sorted it out but after I had rebooted compter everything like BIOS messages and then linux boot menu was displayed on the small monitor!
owl102 wrote:The monitor settings done by Gnome are only associated with your login session. So if you want GDM to use the same settings, you need to copy ~/.config/monitors.xml to /var/lib/gdm/.config/ (as root), e.g.:

Code: Select all

cp ~franek/.config/monitors.xml /var/lib/gdm/.config/
It works now. Reallly thanks for this :D

EDIT.
There's one more thing. I have CentOS 7 installed at work as well and tried the same thing which did not work. I had to change both owner and group to `gdm`:

Code: Select all

sudo chown gdm:gdm /var/lib/gdb/.config/monitors.xml

Post Reply