Package errors during update

General support questions
Post Reply
c0mpression
Posts: 2
Joined: 2016/10/24 19:29:10

Package errors during update

Post by c0mpression » 2016/10/24 19:35:23

I'm having some errors when I try and update.

Code: Select all

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.es.its.nyu.edu
 * epel: mirrors.mit.edu
 * extras: mirror.clarkson.edu
 * updates: mirror.cs.vt.edu
Resolving Dependencies
--> Running transaction check
---> Package nettle.i686 0:2.7.1-4.el7 will be updated
---> Package nettle.x86_64 0:2.7.1-4.el7 will be updated
--> Processing Dependency: libhogweed.so.2()(64bit) for package: gnutls-3.3.8-14.el7_2.x86_64
--> Processing Dependency: libnettle.so.4()(64bit) for package: gnutls-3.3.8-14.el7_2.x86_64
---> Package nettle.i686 0:3.2-2.el6 will be an update
--> Processing Dependency: libgmp.so.3 for package: nettle-3.2-2.el6.i686
---> Package nettle.x86_64 0:3.2-2.el6 will be an update
--> Processing Dependency: libgmp.so.3()(64bit) for package: nettle-3.2-2.el6.x86_64
--> Finished Dependency Resolution
Error: Package: gnutls-3.3.8-14.el7_2.x86_64 (@updates)
           Requires: libhogweed.so.2()(64bit)
           Removing: nettle-2.7.1-4.el7.x86_64 (@anaconda)
               libhogweed.so.2()(64bit)
           Updated By: nettle-3.2-2.el6.x86_64 (epel)
              ~libhogweed.so.4()(64bit)
Error: Package: nettle-3.2-2.el6.i686 (epel)
           Requires: libgmp.so.3
Error: Package: gnutls-3.3.8-14.el7_2.x86_64 (@updates)
           Requires: libnettle.so.4()(64bit)
           Removing: nettle-2.7.1-4.el7.x86_64 (@anaconda)
               libnettle.so.4()(64bit)
           Updated By: nettle-3.2-2.el6.x86_64 (epel)
              ~libnettle.so.6()(64bit)
Error: Package: nettle-3.2-2.el6.x86_64 (epel)
           Requires: libgmp.so.3()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
I've tried running

Code: Select all

yum --skip-broken update
which seemed to update some things, although it seems like the problem packages are
(nettle-3.2-2.el6.i686 from epel
nettle-3.2-2.el6.x86_64 from epel). I'm not sure how to fix this, though. I've also run

Code: Select all

yum clean all
.

This is my first time running a linux server (or any server), so I'm not sure how to fix thing or where to look! I've googled a bit but nothings coming up that seems to fix this for me.

User avatar
TrevorH
Forum Moderator
Posts: 31306
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Package errors during update

Post by TrevorH » 2016/10/24 19:43:23

You've installed the wrong version of EPEL on your CentOS 7 machine. Run yum remove epel-release then yum --enablerepo=extras install epel-release then yum clean all and then try again.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

c0mpression
Posts: 2
Joined: 2016/10/24 19:29:10

Re: Package errors during update

Post by c0mpression » 2016/10/24 20:17:39

Great - thanks!

Post Reply

Return to “CentOS 7 - General Support”