PowerPC BE 7.0 b1511 on PowerMac G5 11,2

Issues related to hardware problems
Post Reply
Posts: 1
Joined: 2016/09/21 23:40:04

PowerPC BE 7.0 b1511 on PowerMac G5 11,2

Post by SmokinJoe » 2016/09/22 00:35:24

Hi All,

I hope to find the PPC guru's out there that can help me get CentOS7 running on my machine.

I assume the correct version of CentOS7 1511 PowerPC is Big Edian and not the LE version

I have tried to boot both the Everything ISO and NetInstall ISO

My PowerPC firmware will not detect the CD as bootable and I have tried burning the CD/DVD on the local PowerMac(Mac OS X 10.5.8) with the sourceforge program BURN as well as on my MBP running Mac OS X 10.11 using BURN there as well. When I download the .ISO should I be able to double click on the .ISO and have Mac OS X mount the disk with no errors? I seem to ONLY be able to mount the NetInstall cleanly, FYI.

The machine is a dual processor 2.0GHz PowerPC G5, 8 GIGs of DDR2 RAM, 160 Gig intel 320 SSD running Boot ROM Version 5.2.7fl

I can boot Ubuntu 14.04 32 bit and I can get to the partition spot but cancel out as I do not want to wreck my Mac OS X install with ubuntu. LOL

I can boot into OpenFirmware O+F+Option+Command at boot up b4 the chime. Here is what I have discovered so far:

if I have issues I can do a reset-all to get the OF to a default state.(has not helped the issue)

key in :
boot cd:\images\netboot\ppc64.img

results :
0 > boot cd:\images\netboot\ppc64.img load-size=2acecdd adler32=68ebab23

Loading ELF

CLAIM failed
0 >

boot cd:\boot\grub\powerpc-ieee1275\core.elf
takes me to the boot menu with a black screen where I can pick "Install CentOS AltArch 7 (64-bit kernel)" and I pick that

If I wait too long the fans kick up to 100% like something has crashed

after a few seconds I get this screen and assume it means I have a crash and waiting forever will not boot Linux

found display : /pci@0,f0000000/NVDA,Parent@0/NVDA,Display-B@1, opening... done
copying OF device tree...
Building dt strings...
Building dt structure...
Device tree strings 0x0000000005d20000 -> 0x0000000005d21770
Device tree struct 0x0000000005d30000 -> 0x0000000005d40000
Calling quiesce...

erasing fff04000 of Sharp Q47 part
flashing fff04000 of Sharp Q47 part
swapping blocks
DO-QUIESCE finishedreturning from prom_init

nothing but fans from here on out no matter how long I wait. I have tried to boot with USB thumb drives, using my MacBook Pro and unetbootin to create the image, I have tried using DD, I have tried to figure out the OpenFirmware to tell it to boot the second partition on my PowerMac and I have tried using a firewire disk with the CentOS on it from a DD.

Is there something else I should be doing to try to get my PowerMac G5 to boot CentOS7 1511? Is there a way to boot my Ubuntu 14.04 CD/DVD and then launch the CentOS boot files? Normally Ubuntu uses yaboot so it that possible to boot with the Ubuntu disk and load/launch the CentOS install.

I am sure I downloaded and used the 32 bit image as I originally downloaded ubuntu for my 32 bit Mac Mini G4.
http://cdimage.ubuntu.com/lubuntu/relea ... y/release/

PPCBootError.jpg (146.26 KiB) Viewed 3363 times

Posts: 776
Joined: 2013/12/08 19:44:49

Re: PowerPC BE 7.0 b1511 on PowerMac G5 11,2

Post by chemal » 2016/09/22 18:18:47

C7 ppc64 requires a POWER7 or later CPU, iirc. The PPC970 in your G5 is not supported. I guess the whole thing is unsupported, starting from the way it boots.

Post Reply