xrdp - pop-up - authentication is required to set the network proxy

General support questions
Post Reply
Timbo
Posts: 7
Joined: 2016/05/05 04:22:01

xrdp - pop-up - authentication is required to set the network proxy

Post by Timbo » 2016/05/06 00:18:18

Hi,

First-up, I'm fairly new to Linux so please be gentle :). I know enough to be dangerous (possibly, maybe not) - I'm kind of learning on the job so to speak and rely heavily on google to find my way around.

The issue I'm having at the moment is I've managed to setup a Centos7 server (it's a VM but I don't think that's too relevant) with XRDP working but when a non-root user logs in via Windows RDP client, it logs in fine but then there's a pop-up requesting a password:

'Authentication Required

Authentication is required to set the network proxy used for downloading software'

Before I posted this, I've done a fair bit of googling and from what I can tell it might be something to do with PackageKit and/or PolicyKit but none of the resolutions seem to be applicable to my situation (PackageKit doesn't appear to be running as a startup application, and I'm trying to get my head around a PolicyKit and what it does and how it might affect this all).

What I have noticed, is the password that it requires is for the account that was used to build the VM (which has sudo privs but otherwise is a non-root account). When using xrdp with root account, no pop-up appears at all.

It's not a massive issue - people can still connect and login - but I like to fix these sort of things if possible.

Any ideas?

Cheers,

Tim

Emma Taylor
Posts: 58
Joined: 2015/04/11 04:59:25
Location: United Kingdom

Re: xrdp - pop-up - authentication is required to set the network proxy

Post by Emma Taylor » 2016/05/09 06:31:47

You can stop the xrdp popup as below -

Code: Select all

service vncserver stop | service xrdp stop
Stopping xrdp: [  OK  ]
Stopping xrdp-sesman: [  OK  ]

Timbo
Posts: 7
Joined: 2016/05/05 04:22:01

Re: xrdp - pop-up - authentication is required to set the network proxy

Post by Timbo » 2016/05/10 00:41:03

Thanks for the reply Emma but if I stop the services, won't that just mean that people can't use xrdp to connect to the server?

Timbo
Posts: 7
Joined: 2016/05/05 04:22:01

Re: xrdp - pop-up - authentication is required to set the network proxy

Post by Timbo » 2016/05/11 04:58:16

I think I figured it out.

I found http://unix.stackexchange.com/questions ... or-message and although the mentioned PackageKit update applet wasn't running in startup, adding X-GNOME-Autostart-enabled=false did work.
However, /etc/xdg/autostart/gpk-update-icon.desktop does not exist - in Centos 7, the file is /etc/xdg/autostart/gnome-software-service.desktop.

I also found another link https://www.weblab360.com/User:xltran/A ... ion/CentOS which mentions adding PolicyKit files.

At the moment I'm using the option from the first link, although occasionally I get the 'some problem' error when trying to connect via Windows RDP client.
Once xrdp service is restarted, the pop-up doesn't return.

Cheers,

Tim

Post Reply

Return to “CentOS 7 - General Support”