Problem getting glx working on intel video

Issues related to hardware problems
Post Reply
jbeige
Posts: 4
Joined: 2015/06/16 16:18:49

Problem getting glx working on intel video

Post by jbeige » 2015/06/16 16:30:04

Hello! I hope I am posting this in the correct board, since it's related to video.. Maybe it should have gone in the software side though.

So here's my problem.. I have a CentOS 6 system that had an nvdia card in it and was running great.. The card started to die, so I removed it and switched to the onboard intel video (in an HP 8200 Elite SFF workstation). It's working in so far as I have gnome, and can do most normal things.. But I'm getting some graphical glitches and when investigating I found that glx doesn't seem to be working properly. Here's what I get when I run glxgears:

Code: Select all

# glxgears
Error: couldn't get an RGB, Double-buffered visual
And when I run glxinfo:

Code: Select all

# glxinfo
name of display: :0.0
Error: couldn't find RGB GLX visual or fbconfig
Here's some other info:

Code: Select all

# uname -a
Linux <redacted> 2.6.32-504.el6.x86_64 #1 SMP Wed Oct 15 04:27:16 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Code: Select all

# lspci -k
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
	Subsystem: Hewlett-Packard Company Device 1495
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
	Subsystem: Hewlett-Packard Company Device 1495
	Kernel driver in use: i915
	Kernel modules: i915
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
	Subsystem: Hewlett-Packard Company Device 1495
00:16.3 Serial controller: Intel Corporation 6 Series/C200 Series Chipset Family KT Controller (rev 04)
	Subsystem: Hewlett-Packard Company Device 1495
	Kernel driver in use: serial
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
	Subsystem: Hewlett-Packard Company Device 1495
	Kernel driver in use: e1000e
	Kernel modules: e1000e
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
	Subsystem: Hewlett-Packard Company Device 1495
	Kernel driver in use: ehci_hcd
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
	Subsystem: Hewlett-Packard Company Device 1495
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd-hda-intel
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b4)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1c.6 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 7 (rev b4)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1c.7 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 8 (rev b4)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
	Subsystem: Hewlett-Packard Company Device 1495
	Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a4)
00:1f.0 ISA bridge: Intel Corporation Q67 Express Chipset Family LPC Controller (rev 04)
	Subsystem: Hewlett-Packard Company Device 1495
	Kernel driver in use: lpc_ich
	Kernel modules: lpc_ich
00:1f.2 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller (rev 04)
	Subsystem: Hewlett-Packard Company Device 1495
	Kernel driver in use: ata_piix
	Kernel modules: ata_generic, pata_acpi, ata_piix
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
	Subsystem: Hewlett-Packard Company Device 1495
	Kernel driver in use: i801_smbus
	Kernel modules: i2c-i801
00:1f.5 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 2 port SATA IDE Controller (rev 04)
	Subsystem: Hewlett-Packard Company Device 1495
	Kernel driver in use: ata_piix
	Kernel modules: ata_generic, pata_acpi, ata_piix
02:00.0 Ethernet controller: D-Link System Inc DGE-560T PCI Express Gigabit Ethernet Adapter (rev 13)
	Subsystem: D-Link System Inc DGE-560T PCI Express Gigabit Ethernet Adapter
	Kernel driver in use: sky2
	Kernel modules: sky2

Code: Select all

# rpm -qa | grep -i intel
xorg-x11-drv-intel-2.99.916-1.el6.elrepo.x86_64

Code: Select all

# lsmod
Module                  Size  Used by
fuse                   79956  0 
autofs4                26609  3 
8021q                  25527  0 
garp                    7152  1 8021q
stp                     2218  1 garp
llc                     5578  2 garp,stp
cpufreq_ondemand       10544  4 
acpi_cpufreq            7763  1 
freq_table              4936  2 cpufreq_ondemand,acpi_cpufreq
mperf                   1557  1 acpi_cpufreq
ipv6                  334932  54 
vfat                   10584  1 
fat                    54992  1 vfat
vhost_net              30913  0 
macvtap                10231  1 vhost_net
macvlan                 9890  1 macvtap
tun                    16646  1 vhost_net
kvm                   337772  0 
uinput                  8120  0 
ppdev                   8537  0 
iTCO_wdt                7115  0 
iTCO_vendor_support     3056  1 iTCO_wdt
parport_pc             22658  0 
parport                36209  2 ppdev,parport_pc
tpm_infineon            8605  0 
microcode             112653  0 
sg                     29318  0 
serio_raw               4626  0 
i2c_i801               10783  0 
sky2                   48160  0 
e1000e                236624  0 
ptp                     9614  1 e1000e
pps_core               11106  1 ptp
lpc_ich                12995  0 
mfd_core                1895  1 lpc_ich
snd_hda_codec_hdmi     28922  1 
snd_hda_codec_realtek    43811  1 
snd_hda_intel          40530  1 
snd_hda_codec         179208  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               6780  1 snd_hda_codec
snd_seq                55727  0 
snd_seq_device          6500  1 snd_seq
snd_pcm                87790  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_timer              22443  2 snd_seq,snd_pcm
snd                    70953  11 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
soundcore               7958  1 snd
snd_page_alloc          8856  2 snd_hda_intel,snd_pcm
ext4                  378476  3 
jbd2                   93427  1 ext4
mbcache                 8193  1 ext4
sr_mod                 15049  0 
cdrom                  39085  1 sr_mod
sd_mod                 36998  4 
crc_t10dif              1305  1 sd_mod
wmi                     6287  0 
pata_acpi               3701  0 
ata_generic             3837  0 
ata_piix               24409  3 
i915                  820936  2 
drm_kms_helper         82994  1 i915
drm                   291252  3 i915,drm_kms_helper
i2c_algo_bit            5711  1 i915
i2c_core               29964  5 i2c_i801,i915,drm_kms_helper,drm,i2c_algo_bit
video                  20610  1 i915
output                  2409  1 video
dm_mirror              14384  0 
dm_region_hash         12085  1 dm_mirror
dm_log                  9930  2 dm_mirror,dm_region_hash
dm_mod                 95622  11 dm_mirror,dm_log

Code: Select all

# cat /var/log/Xorg.0.log
[   636.097] 
X.Org X Server 1.15.0
Release Date: 2013-12-27
[   636.097] X Protocol Version 11, Revision 0
[   636.097] Build Operating System: c6b8 2.6.32-220.el6.x86_64 
[   636.097] Current Operating System: Linux jdblinux.switch.com 2.6.32-504.el6.x86_64 #1 SMP Wed Oct 15 04:27:16 UTC 2014 x86_64
[   636.097] Kernel command line: ro root=/dev/mapper/vg_jdbtest-lv_root rd_NO_LUKS LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=128M rd_LVM_LV=vg_jdbtest/lv_swap rd_LVM_LV=vg_jdbtest/lv_root  KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rdblacklist=nouveau vga=791
[   636.097] Build Date: 18 October 2014  11:46:15AM
[   636.097] Build ID: xorg-x11-server 1.15.0-22.el6.centos 
[   636.097] Current version of pixman: 0.32.4
[   636.097] 	Before reporting problems, check https://wiki.centos.org/
	to make sure that you have the latest version.
[   636.097] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   636.097] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jun  8 11:58:26 2015
[   636.097] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   636.097] (==) No Layout section.  Using the first Screen section.
[   636.097] (==) No screen section available. Using defaults.
[   636.097] (**) |-->Screen "Default Screen Section" (0)
[   636.097] (**) |   |-->Monitor "<default monitor>"
[   636.097] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[   636.097] (==) Automatically adding devices
[   636.097] (==) Automatically enabling devices
[   636.097] (==) Not automatically adding GPU devices
[   636.097] (==) FontPath set to:
	catalogue:/etc/X11/fontpath.d,
	built-ins
[   636.097] (==) ModulePath set to "/usr/lib64/xorg/modules"
[   636.097] (II) The server relies on HAL to provide the list of input devices.
	If no devices become available, reconfigure HAL or disable AutoAddDevices.
[   636.097] (II) Loader magic: 0x822020
[   636.097] (II) Module ABI versions:
[   636.097] 	X.Org ANSI C Emulation: 0.4
[   636.097] 	X.Org Video Driver: 15.0
[   636.097] 	X.Org XInput driver : 20.0
[   636.097] 	X.Org Server Extension : 8.0
[   636.098] (--) PCI:*(0:0:2:0) 8086:0102:103c:1495 rev 9, Mem @ 0xfe000000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[   636.098] Initializing built-in extension Generic Event Extension
[   636.098] Initializing built-in extension SHAPE
[   636.098] Initializing built-in extension MIT-SHM
[   636.098] Initializing built-in extension XInputExtension
[   636.098] Initializing built-in extension XTEST
[   636.098] Initializing built-in extension BIG-REQUESTS
[   636.098] Initializing built-in extension SYNC
[   636.098] Initializing built-in extension XKEYBOARD
[   636.098] Initializing built-in extension XC-MISC
[   636.098] Initializing built-in extension SECURITY
[   636.098] Initializing built-in extension XINERAMA
[   636.098] Initializing built-in extension XFIXES
[   636.098] Initializing built-in extension RENDER
[   636.098] Initializing built-in extension RANDR
[   636.098] Initializing built-in extension COMPOSITE
[   636.098] Initializing built-in extension DAMAGE
[   636.098] Initializing built-in extension MIT-SCREEN-SAVER
[   636.098] Initializing built-in extension DOUBLE-BUFFER
[   636.098] Initializing built-in extension RECORD
[   636.098] Initializing built-in extension DPMS
[   636.098] Initializing built-in extension Present
[   636.098] Initializing built-in extension X-Resource
[   636.098] Initializing built-in extension XVideo
[   636.098] Initializing built-in extension XVideo-MotionCompensation
[   636.098] Initializing built-in extension SELinux
[   636.098] Initializing built-in extension XFree86-VidModeExtension
[   636.098] Initializing built-in extension XFree86-DGA
[   636.098] Initializing built-in extension XFree86-DRI
[   636.098] Initializing built-in extension DRI2
[   636.098] (II) LoadModule: "glx"
[   636.098] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   636.098] (II) Module glx: vendor="X.Org Foundation"
[   636.098] 	compiled for 1.10.6, module version = 1.0.0
[   636.098] 	ABI class: X.Org Server Extension, version 5.0
[   636.098] (EE) module ABI major version (5) doesn't match the server's version (8)
[   636.098] (II) UnloadModule: "glx"
[   636.098] (II) Unloading glx
[   636.098] (EE) Failed to load module "glx" (module requirement mismatch, 0)
[   636.098] (==) Matched intel as autoconfigured driver 0
[   636.098] (==) Matched modesetting as autoconfigured driver 1
[   636.098] (==) Matched fbdev as autoconfigured driver 2
[   636.098] (==) Matched vesa as autoconfigured driver 3
[   636.098] (==) Assigned the driver to the xf86ConfigLayout
[   636.098] (II) LoadModule: "intel"
[   636.098] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[   636.098] (II) Module intel: vendor="X.Org Foundation"
[   636.098] 	compiled for 1.15.0, module version = 2.99.916
[   636.098] 	Module class: X.Org Video Driver
[   636.098] 	ABI class: X.Org Video Driver, version 15.0
[   636.098] (II) LoadModule: "modesetting"
[   636.099] (WW) Warning, couldn't open module modesetting
[   636.099] (II) UnloadModule: "modesetting"
[   636.099] (II) Unloading modesetting
[   636.099] (EE) Failed to load module "modesetting" (module does not exist, 0)
[   636.099] (II) LoadModule: "fbdev"
[   636.099] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[   636.099] (II) Module fbdev: vendor="X.Org Foundation"
[   636.099] 	compiled for 1.15.0, module version = 0.4.3
[   636.099] 	Module class: X.Org Video Driver
[   636.099] 	ABI class: X.Org Video Driver, version 15.0
[   636.099] (II) LoadModule: "vesa"
[   636.099] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[   636.099] (II) Module vesa: vendor="X.Org Foundation"
[   636.099] 	compiled for 1.15.0, module version = 2.3.2
[   636.099] 	Module class: X.Org Video Driver
[   636.099] 	ABI class: X.Org Video Driver, version 15.0
[   636.099] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[   636.099] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[   636.099] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[   636.099] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[   636.099] (II) FBDEV: driver for framebuffer: fbdev
[   636.099] (II) VESA: driver for VESA chipsets: vesa
[   636.099] (++) using VT number 1

[   636.099] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20080730
[   636.100] (WW) Falling back to old probe method for fbdev
[   636.100] (II) Loading sub module "fbdevhw"
[   636.100] (II) LoadModule: "fbdevhw"
[   636.100] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[   636.100] (II) Module fbdevhw: vendor="X.Org Foundation"
[   636.100] 	compiled for 1.15.0, module version = 0.0.2
[   636.100] 	ABI class: X.Org Video Driver, version 15.0
[   636.100] (WW) Falling back to old probe method for vesa
[   636.100] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 2000
[   636.100] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx
[   636.100] (II) intel(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[   636.100] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[   636.100] (==) intel(0): RGB weight 888
[   636.100] (==) intel(0): Default visual is TrueColor
[   636.100] (II) intel(0): Output VGA1 has no monitor section
[   636.100] (II) intel(0): Enabled output VGA1
[   636.100] (II) intel(0): Output HDMI1 has no monitor section
[   636.100] (II) intel(0): Enabled output HDMI1
[   636.100] (II) intel(0): Output DP1 has no monitor section
[   636.100] (II) intel(0): Enabled output DP1
[   636.100] (--) intel(0): Using a maximum size of 64x64 for hardware cursors
[   636.100] (II) intel(0): Output VIRTUAL1 has no monitor section
[   636.100] (II) intel(0): Enabled output VIRTUAL1
[   636.100] (--) intel(0): Output HDMI1 using initial mode 1600x1200 on pipe 0
[   636.100] (==) intel(0): TearFree disabled
[   636.100] (==) intel(0): DPI set to (96, 96)
[   636.100] (II) Loading sub module "dri2"
[   636.100] (II) LoadModule: "dri2"
[   636.100] (II) Module "dri2" already built-in
[   636.100] (II) Loading sub module "present"
[   636.100] (II) LoadModule: "present"
[   636.101] (WW) Warning, couldn't open module present
[   636.101] (II) UnloadModule: "present"
[   636.101] (II) Unloading present
[   636.101] (EE) intel: Failed to load module "present" (module does not exist, 0)
[   636.101] (II) UnloadModule: "fbdev"
[   636.101] (II) Unloading fbdev
[   636.101] (II) UnloadSubModule: "fbdevhw"
[   636.101] (II) Unloading fbdevhw
[   636.101] (II) UnloadModule: "vesa"
[   636.101] (II) Unloading vesa
[   636.101] (==) Depth 24 pixmap format is 32 bpp
[   636.101] (II) intel(0): SNA initialized with Sandybridge (gen6, gt1) backend
[   636.101] (==) intel(0): Backing store enabled
[   636.101] (==) intel(0): Silken mouse enabled
[   636.101] (II) intel(0): HW Cursor enabled
[   636.101] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[   636.101] (==) intel(0): DPMS enabled
[   636.101] (II) intel(0): [DRI2] Setup complete
[   636.101] (II) intel(0): [DRI2]   DRI driver: i965
[   636.101] (II) intel(0): [DRI2]   VDPAU driver: i965
[   636.101] (II) intel(0): direct rendering: DRI2 enabled
[   636.101] (==) intel(0): display hotplug detection enabled
[   636.101] (--) RandR disabled
[   636.104] (II) SELinux: Disabled on system
[   636.107] (II) intel(0): switch to mode 1600x1200@60.0 on HDMI1 using pipe 0, position (0, 0), rotation normal, reflection none
[   636.125] (II) intel(0): Setting screen physical size to 423 x 317
[   636.154] (II) config/hal: Adding input device HDA Intel PCH Front Headphone
[   636.154] (II) LoadModule: "evdev"
[   636.155] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[   636.155] (II) Module evdev: vendor="X.Org Foundation"
[   636.155] 	compiled for 1.15.0, module version = 2.8.2
[   636.155] 	Module class: X.Org XInput Driver
[   636.155] 	ABI class: X.Org XInput driver, version 20.0
[   636.155] (II) Using input driver 'evdev' for 'HDA Intel PCH Front Headphone'
[   636.155] (**) HDA Intel PCH Front Headphone: always reports core events
[   636.155] (**) evdev: HDA Intel PCH Front Headphone: Device: "/dev/input/event4"
[   636.166] (--) evdev: HDA Intel PCH Front Headphone: Vendor 0 Product 0
[   636.166] (WW) evdev: HDA Intel PCH Front Headphone: Don't know how to use device
[   636.174] (EE) PreInit returned 8 for "HDA Intel PCH Front Headphone"
[   636.174] (II) UnloadModule: "evdev"
[   636.174] (EE) config/hal: NewInputDeviceRequest failed (8)
[   636.178] (II) config/hal: Adding input device Power Button
[   636.178] (II) Using input driver 'evdev' for 'Power Button'
[   636.178] (**) Power Button: always reports core events
[   636.178] (**) evdev: Power Button: Device: "/dev/input/event0"
[   636.186] (--) evdev: Power Button: Vendor 0 Product 0x1
[   636.186] (--) evdev: Power Button: Found keys
[   636.186] (II) evdev: Power Button: Configuring as keyboard
[   636.186] (**) Option "config_info" "hal:/org/freedesktop/Hal/devices/computer_logicaldev_input_0"
[   636.186] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[   636.186] (**) Option "xkb_rules" "evdev"
[   636.186] (**) Option "xkb_model" "pc105+inet"
[   636.186] (**) Option "xkb_layout" "us"
[   636.186] (WW) Option "xkb_variant" requires a string value
[   636.186] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[   636.208] (II) config/hal: Adding input device Power Button
[   636.208] (II) Using input driver 'evdev' for 'Power Button'
[   636.208] (**) Power Button: always reports core events
[   636.208] (**) evdev: Power Button: Device: "/dev/input/event1"
[   636.217] (--) evdev: Power Button: Vendor 0 Product 0x1
[   636.217] (--) evdev: Power Button: Found keys
[   636.217] (II) evdev: Power Button: Configuring as keyboard
[   636.217] (**) Option "config_info" "hal:/org/freedesktop/Hal/devices/computer_logicaldev_input"
[   636.217] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[   636.217] (**) Option "xkb_rules" "evdev"
[   636.217] (**) Option "xkb_model" "pc105+inet"
[   636.217] (**) Option "xkb_layout" "us"
[   636.217] (WW) Option "xkb_variant" requires a string value
[   636.217] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[   636.219] (II) config/hal: Adding input device Macintosh mouse button emulation
[   636.219] (II) Using input driver 'evdev' for 'Macintosh mouse button emulation'
[   636.219] (**) Macintosh mouse button emulation: always reports core events
[   636.219] (**) evdev: Macintosh mouse button emulation: Device: "/dev/input/event2"
[   636.225] (--) evdev: Macintosh mouse button emulation: Vendor 0x1 Product 0x1
[   636.225] (--) evdev: Macintosh mouse button emulation: Found 3 mouse buttons
[   636.225] (--) evdev: Macintosh mouse button emulation: Found relative axes
[   636.225] (--) evdev: Macintosh mouse button emulation: Found x and y relative axes
[   636.225] (II) evdev: Macintosh mouse button emulation: Configuring as mouse
[   636.226] (**) evdev: Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
[   636.226] (**) evdev: Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[   636.226] (**) Option "config_info" "hal:/org/freedesktop/Hal/devices/computer_logicaldev_input_1"
[   636.226] (II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE, id 8)
[   636.226] (II) evdev: Macintosh mouse button emulation: initialized for relative axes.
[   636.226] (**) Macintosh mouse button emulation: (accel) keeping acceleration scheme 1
[   636.226] (**) Macintosh mouse button emulation: (accel) acceleration profile 0
[   636.226] (**) Macintosh mouse button emulation: (accel) acceleration factor: 2.000
[   636.226] (**) Macintosh mouse button emulation: (accel) acceleration threshold: 4
[   636.231] (II) config/hal: Adding input device HDA Intel PCH HDMI/DP,pcm=3
[   636.231] (II) Using input driver 'evdev' for 'HDA Intel PCH HDMI/DP,pcm=3'
[   636.231] (**) HDA Intel PCH HDMI/DP,pcm=3: always reports core events
[   636.231] (**) evdev: HDA Intel PCH HDMI/DP,pcm=3: Device: "/dev/input/event3"
[   636.233] (--) evdev: HDA Intel PCH HDMI/DP,pcm=3: Vendor 0 Product 0
[   636.233] (WW) evdev: HDA Intel PCH HDMI/DP,pcm=3: Don't know how to use device
[   636.249] (EE) PreInit returned 8 for "HDA Intel PCH HDMI/DP,pcm=3"
[   636.249] (II) UnloadModule: "evdev"
[   636.249] (EE) config/hal: NewInputDeviceRequest failed (8)
[   636.249] AUDIT: Mon Jun  8 11:58:26 2015: 4043: client 1 connected from local host ( uid=0 gid=0 pid=4041 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   636.249] AUDIT: Mon Jun  8 11:58:26 2015: 4043: client 2 connected from local host ( uid=0 gid=0 pid=1665 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   636.250] AUDIT: Mon Jun  8 11:58:26 2015: 4043: client 2 disconnected
[   636.250] AUDIT: Mon Jun  8 11:58:26 2015: 4043: client 2 connected from local host ( uid=0 gid=0 pid=1665 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   636.290] (II) intel(0): EDID vendor "DEL", prod id 40993
[   636.290] (II) intel(0): Using EDID range info for horizontal sync
[   636.290] (II) intel(0): Using EDID range info for vertical refresh
[   636.290] (II) intel(0): Printing DDC gathered Modelines:
[   636.290] (II) intel(0): Modeline "1600x1200"x0.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz eP)
[   636.290] (II) intel(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[   636.290] (II) intel(0): Modeline "640x480"x0.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz e)
[   636.290] (II) intel(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[   636.290] (II) intel(0): Modeline "720x400"x0.0   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz e)
[   636.291] (II) intel(0): Modeline "1280x1024"x0.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz e)
[   636.291] (II) intel(0): Modeline "1024x768"x0.0   78.75  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.0 kHz e)
[   636.291] (II) intel(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[   636.291] (II) intel(0): Modeline "800x600"x0.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz e)
[   636.291] (II) intel(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz e)
[   636.291] (II) intel(0): Modeline "1152x864"x0.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz e)
[   636.291] AUDIT: Mon Jun  8 11:58:26 2015: 4043: client 2 disconnected
[   636.300] AUDIT: Mon Jun  8 11:58:26 2015: 4043: client 2 connected from local host ( uid=0 gid=0 pid=4053 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   636.300] AUDIT: Mon Jun  8 11:58:26 2015: 4043: client 2 disconnected
[   636.303] AUDIT: Mon Jun  8 11:58:26 2015: 4043: client 2 connected from local host ( uid=0 gid=0 pid=4055 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   636.305] AUDIT: Mon Jun  8 11:58:26 2015: 4043: client 2 disconnected
[   637.314] AUDIT: Mon Jun  8 11:58:27 2015: 4043: client 2 connected from local host ( uid=0 gid=0 pid=4064 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.316] AUDIT: Mon Jun  8 11:58:27 2015: 4043: client 3 connected from local host ( uid=0 gid=0 pid=4068 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.316] AUDIT: Mon Jun  8 11:58:27 2015: 4043: client 3 disconnected
[   637.349] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 3 connected from local host ( uid=42 gid=42 pid=4074 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.354] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 4 connected from local host ( uid=42 gid=42 pid=4077 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.360] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 5 connected from local host ( uid=42 gid=42 pid=4079 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.445] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 6 connected from local host ( uid=42 gid=42 pid=4083 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.446] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 7 connected from local host ( uid=42 gid=42 pid=4087 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.583] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 8 connected from local host ( uid=42 gid=42 pid=4093 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.584] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 8 disconnected
[   637.623] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 8 connected from local host ( uid=42 gid=42 pid=4079 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.624] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 9 connected from local host ( uid=42 gid=42 pid=4087 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.634] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 10 connected from local host ( uid=42 gid=42 pid=4098 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.640] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 11 connected from local host ( uid=42 gid=42 pid=4098 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.662] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 12 connected from local host ( uid=42 gid=42 pid=4102 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.667] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 13 connected from local host ( uid=42 gid=42 pid=4104 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.669] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 14 connected from local host ( uid=42 gid=42 pid=4103 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.673] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 15 connected from local host ( uid=42 gid=42 pid=4101 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.674] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 16 connected from local host ( uid=42 gid=42 pid=4105 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.679] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 17 connected from local host ( uid=42 gid=42 pid=4101 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.682] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 18 connected from local host ( uid=42 gid=42 pid=4104 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.682] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 20 connected from local host ( uid=42 gid=42 pid=4101 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.682] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 19 connected from local host ( uid=42 gid=42 pid=4102 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.682] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 21 connected from local host ( uid=42 gid=42 pid=4103 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.683] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 20 disconnected
[   637.690] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 20 connected from local host ( uid=42 gid=42 pid=4105 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.712] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 22 connected from local host ( uid=42 gid=42 pid=4087 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.712] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 22 disconnected
[   637.759] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 23 connected from local host ( uid=42 gid=42 pid=4121 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.767] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 24 connected from local host ( uid=42 gid=42 pid=4121 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   637.768] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 17 disconnected
[   637.769] AUDIT: Mon Jun  8 11:58:28 2015: 4043: client 15 disconnected
[   639.621] AUDIT: Mon Jun  8 11:58:30 2015: 4043: client 15 connected from local host ( uid=0 gid=0 pid=4041 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   641.742] AUDIT: Mon Jun  8 11:58:32 2015: 4043: client 2 disconnected
[   642.746] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 2 connected from local host ( uid=0 gid=0 pid=4141 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
[   642.747] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 6 disconnected
[   642.748] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 12 disconnected
[   642.748] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 16 disconnected
[   642.748] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 20 disconnected
[   642.749] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 19 disconnected
[   642.749] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 18 disconnected
[   642.749] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 13 disconnected
[   642.749] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 21 disconnected
[   642.749] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 11 disconnected
[   642.750] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 10 disconnected
[   642.750] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 14 disconnected
[   642.751] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 8 disconnected
[   642.752] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 5 disconnected
[   642.782] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 24 disconnected
[   642.782] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 23 disconnected
[   642.790] AUDIT: Mon Jun  8 11:58:33 2015: 4043: client 5 connected from local host ( uid=0 gid=0 pid=4149 )
  Auth name: MIT-MAGIC-COOKIE-1 ID: 105
(Note that those same AUDIT messages were appearing for a few hundred more lines that I removed)

Also possibly noteworthy is that I'm using synergy as a client to share my mouse and keyboard from a windows 7 system.

Thanks!

jbeige
Posts: 4
Joined: 2015/06/16 16:18:49

Re: Problem getting glx working on intel video

Post by jbeige » 2015/06/22 16:18:38

80 views and no comments.. Does anyone have any suggestions?

Thanks!

aks
Posts: 3054
Joined: 2014/09/20 11:22:14

Re: Problem getting glx working on intel video

Post by aks » 2015/06/22 18:55:00

Um, the GLX driver is not loaded?
What are you trying to do? 3-D graphics?

jbeige
Posts: 4
Joined: 2015/06/16 16:18:49

Re: Problem getting glx working on intel video

Post by jbeige » 2015/06/22 18:59:22

Yeah, I want to be able to do at least some basic things that use 3D.. I can't run Steam without glx it seems (I don't want to play any games on it, just use it to add codes for games into my library).. Also, GIMP seems to have some glitchyness, which I assume is related to these drivers.. I've had a few other programs not cooperate either, but I can't remember which at the moment.

From everything I've read, glx support should work out of the box with intel drivers, so I assume my problem has something to do with the fact that I was running nvidia drivers (and card) for a while, and something is messed up after removing them..

chemal
Posts: 713
Joined: 2013/12/08 19:44:49

Re: Problem getting glx working on intel video

Post by chemal » 2015/06/22 19:15:25

You used Nvidia's driver with their installer? Then you got what you deserve: a broken system.

Code: Select all

[   636.098] (II) LoadModule: "glx"
[   636.098] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   636.098] (II) Module glx: vendor="X.Org Foundation"
[   636.098]    compiled for 1.10.6, module version = 1.0.0
[   636.098]    ABI class: X.Org Server Extension, version 5.0
[   636.098] (EE) module ABI major version (5) doesn't match the server's version (8)
[   636.098] (II) UnloadModule: "glx"
[   636.098] (II) Unloading glx
[   636.098] (EE) Failed to load module "glx" (module requirement mismatch, 0)
Maybe something like "yum reinstall xorg-x11-server-Xorg mesa-libGL" will rectify things.

jbeige
Posts: 4
Joined: 2015/06/16 16:18:49

Re: Problem getting glx working on intel video

Post by jbeige » 2015/06/22 19:30:28

Thank you chemal!
chemal wrote:You used Nvidia's driver with their installer? Then you got what you deserve: a broken system.

Code: Select all

[   636.098] (II) LoadModule: "glx"
[   636.098] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   636.098] (II) Module glx: vendor="X.Org Foundation"
[   636.098]    compiled for 1.10.6, module version = 1.0.0
[   636.098]    ABI class: X.Org Server Extension, version 5.0
[   636.098] (EE) module ABI major version (5) doesn't match the server's version (8)
[   636.098] (II) UnloadModule: "glx"
[   636.098] (II) Unloading glx
[   636.098] (EE) Failed to load module "glx" (module requirement mismatch, 0)
Maybe something like "yum reinstall xorg-x11-server-Xorg mesa-libGL" will rectify things.
That did it! I figured I needed to reinstall something, but I wasn't sure which packages.

Post Reply

Return to “CentOS 6 - Hardware Support”