[SOLVED] wifi adapter not working

Issues related to configuring your network
Post Reply
async
Posts: 6
Joined: 2014/12/13 13:30:44

[SOLVED] wifi adapter not working

Post by async » 2014/12/13 13:38:43

Hi,

Just made a fresh install of Cent OS v7 on my old HP Pavilion dv5 - 1210ep.

From installation point of view, everything went OK. Anyway, it seems that WiFi adapter is not automatically detected.

According to wiki.centos.org (wireless),
" The Atheros AR5007EG (AR242x 802.11 abg) card is a special case. Using lspci will show it as AR5006EG or AR242x 802.11abg and the drivers are not yet in the main MadWifi releases. See the wiki page about the card for information about getting and installing its drivers. "

[root@localhost /]# lspci | grep -i Wireless
08:00.0 Ethernet controller: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)

I was following the procedures to install Madwifi but I'm stuck here:

[root@localhost madwifi-hal-0.10.5.6-r4126-20100324]# make
Checking requirements... ok.
Checking kernel configuration... FAILED
Only kernel versions 2.4.x and above are supported.
You have 3.10.0-123.13.1.el7.x86_64.
make: *** [configcheck] Error 1

Can you please help how to proceed?

Thanks in advance!
Last edited by async on 2014/12/13 14:37:04, edited 1 time in total.

User avatar
TrevorH
Forum Moderator
Posts: 30872
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: wifi adapter not working

Post by TrevorH » 2014/12/13 14:02:34

The ELRepo project has a kmod-ath5k package for CentOS 7. I suggest that you download the rpm for that and transfer it to your system via usb stick etc and then install it from there with yum localinstall /path/to/kmod-ath5k...rpm and see if that helps. I think that wiki page is probably very out of date.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

async
Posts: 6
Joined: 2014/12/13 13:30:44

Re: wifi adapter not working

Post by async » 2014/12/13 14:23:20

Hi Trevor

Thanks for your feedback.

OK, i installed rpm as you can see below:

Done.
Verifying : kmod-ath5k-0.0-3.el7.elrepo.x86_64 1/1
Installed:
kmod-ath5k.x86_64 0:0.0-3.el7.elrepo
Complete!

can you please point what are next steps after installing this package? or anywhere I can see and follow the instructions?

Thanks!

User avatar
TrevorH
Forum Moderator
Posts: 30872
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: wifi adapter not working

Post by TrevorH » 2014/12/13 14:26:44

I'd reboot and see if you then get a network connection available to configure. Opening a command prompt and running ifconfig -a might show you any adapters that are present but not yet configured (if ifconfig is installed - it no longer is by default on many installs).
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

async
Posts: 6
Joined: 2014/12/13 13:30:44

Re: [SOLVED] wifi adapter not working

Post by async » 2014/12/13 14:37:48

Trevor,

it worked. after reboot i can now see wireless networks.
It seems everything is working ok now.

Thanks a lot!
Cheers!

Post Reply

Return to “CentOS 7 - Networking Support”