> Internal error: Could not resolve keysym XF86AudioMicMut

Issues related to applications and software problems
Post Reply
sergey_b
Posts: 2
Joined: 2014/11/19 14:28:34

> Internal error: Could not resolve keysym XF86AudioMicMut

Post by sergey_b » 2014/11/19 15:42:47

Hi, i'm new in Centos.

I use:

Code: Select all

[root@sip-dialer-2 lpshennikov]# uname -a
Linux sip-dialer-2 2.6.32-504.1.3.el6.x86_64 #1 SMP Tue Nov 11 17:57:25 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
[root@sip-dialer-2 lpshennikov]# cat /etc/redhat-release 
CentOS release 6.6 (Final)
When i start Xvfb, i see this message:

Code: Select all

The XKEYBOARD keymap compiler (xkbcomp) reports:
> Internal error:   Could not resolve keysym XF86AudioMicMute
all log:

Code: Select all

Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension SECURITY
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension Present
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension SELinux
Initializing built-in extension GLX
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Internal error:   Could not resolve keysym XF86AudioMicMute
Errors from xkbcomp are not fatal to the X server
May somebody help me to resolve this problem?

aks
Posts: 3008
Joined: 2014/09/20 11:22:14

Re: > Internal error: Could not resolve keysym XF86AudioMi

Post by aks » 2014/11/19 17:31:53

Do you have an Mic mute button on your keyboard? I think all it's saying is that the particular keyboard layouyt you've chosen has a keycode for XF86AudioMicMute, which it doesn't understand.

sergey_b
Posts: 2
Joined: 2014/11/19 14:28:34

Re: > Internal error: Could not resolve keysym XF86AudioMi

Post by sergey_b » 2014/11/20 06:47:29

aks wrote:Do you have an Mic mute button on your keyboard? I think all it's saying is that the particular keyboard layouyt you've chosen has a keycode for XF86AudioMicMute, which it doesn't understand.
it's virtual server on virtual box.
i don't have any keyboard on this system.

how i can change a keycode on my system?

oromux
Posts: 6
Joined: 2014/12/05 19:56:15

Re: > Internal error: Could not resolve keysym XF86AudioMi

Post by oromux » 2014/12/07 01:13:47

Hi,

i have that same error and until now i can't solve this.
Please anyone?

Thank you.

edammer
Posts: 1
Joined: 2014/12/16 00:18:08

Re: > Internal error: Could not resolve keysym XF86AudioMi

Post by edammer » 2014/12/16 00:30:03

I started getting this exact keyboard-related error in CentOS 6.6 after adding in a Radeon R9 graphics card--which still allowed me to enter into xwindows, until I did the GUI aticonfig and created a multi (dual) screen configuration in x-windows, which requires a restart to implement. After logout, startx only works as root--booting into the multiscreen setup as configured! Changing the setting back, however, did not fix the problem. Only way was to sudo chmod 777 /tmp/ . Perhaps this will shed some light on the problem--

Ideas why this should be necessary?

-edammer
---------------------------------------
cheese, soy beans, its all the same

User avatar
TrevorH
Forum Moderator
Posts: 29171
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: > Internal error: Could not resolve keysym XF86AudioMi

Post by TrevorH » 2014/12/16 11:38:43

/tmp should be chmod 1777 not 777 and it should have been that way to begin with.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

saosandr
Posts: 1
Joined: 2016/02/23 08:29:25

Re: > Internal error: Could not resolve keysym XF86AudioMi

Post by saosandr » 2016/02/23 08:43:00

type in command line # nano /usr/share/X11/xkb/symbols/inet
press and hold CTRL+W and type XF86AudioMicMute
bypass this line using #
# key <FK20> { [ XF86AudioMicMute ] };
press and hold CTRL+X
type y to confirm save and press CTRL+X to exit
reboot system and done!
PS. your mic mute button not running more, but your system running, if you want fix it, I don´t know what!!!

avitko0813
Posts: 1
Joined: 2016/08/31 14:27:08

Re: > Internal error: Could not resolve keysym XF86AudioMicMut

Post by avitko0813 » 2016/08/31 14:31:08

The post by saosandr fixed my issue. Commenting out "key <FK20> { [ XF86AudioMicMute ] };" in /usr/share/X11/xkb/inet made this error go away.

Post Reply

Return to “CentOS 6 - Software Support”