Any GUI package manager in C6 ?

Issues related to applications and software problems
Post Reply
User avatar
bluegroper
Posts: 245
Joined: 2005/09/07 23:04:21
Location: .au

Any GUI package manager in C6 ?

Post by bluegroper » 2011/11/17 11:57:27

Hi forum Does CentOS-6 have any gui package manager like this one from C5 ?
http://www.centos.org/docs/5/html/Deployment_Guide-en-US/ch-graphical-rpm.html
Sure I can use the cli, but for a fresh install the gui choices are a useful checklist to work thru.
TIA's for tips and clues.

PS. I'm using KDE rather than gnome.

hawaiian717
Posts: 178
Joined: 2009/01/30 19:58:25
Location: California

Re: Any GUI package manager in C6 ?

Post by hawaiian717 » 2011/11/17 21:33:32

There is gpk-application which is the GNOME Package Manager. Not sure if it gets installed if you are running KDE though.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: Any GUI package manager in C6 ?

Post by pschaff » 2011/11/18 18:27:39

KDE puts gpk-application on the menu under "Applications / Administration / Add/Remove Software". What got installed depends on what option you picked. If not present[code]yum install gnome-packagekit[/code]or[code]yum groupinstall "Graphical Administration Tools"[/code]

There's also "yumex" from EPEL but I can't say I'd recommend either. I've tried them along with various other GUI interfaces for package management, but always end up back on the command line with yum and friends.

biztux
Posts: 1
Joined: 2014/06/13 09:55:12

Re: Any GUI package manager in C6 ?

Post by biztux » 2014/06/13 10:17:58

This worked for me (logged in as root):
# yum install gnome-packagekit gnome-packagekit-extra

After installation of gnome-packagekit and gnome-packagekit-extra finishes:
# cd /usr/share/applications/

Edit the gpk-application.desktop file using vi, nano or some other text editor and comment out the NotShowIn line as shown below:
Icon=system-software-install
Exec=gpk-application
Terminal=false
Type=Application
Categories=GNOME;GTK;System;Settings;
#NotShowIn=KDE;
StartupNotify=true

X-Desktop-File-Install-Version=0.15

Logout, then login again and click Menu Button, Administration, Add/Remove Software.
Image

stanasa
Posts: 2
Joined: 2014/10/09 14:59:32

Re: Any GUI package manager in C6 ?

Post by stanasa » 2014/10/09 15:02:53

Biztux,

Thanks so much for your reply! It worked for both CentoOS 7 and RHEL 6.5. I wonder why they would put a random line to hide it in KDE?

Post Reply

Return to “CentOS 6 - Software Support”