Problem in Installing wps kingsoft office

Issues related to applications and software problems
Post Reply
prashkotak@gmail.com
Posts: 2
Joined: 2014/03/16 03:00:56

Problem in Installing wps kingsoft office

Post by prashkotak@gmail.com » 2014/03/16 08:52:50

Has any one install ,wps kingsoft office on centos, WHen in am installing
kingsoft-office-9.1.0.4244-0.1.a12p3.i686.rpm , from official site http://wps-community.org/download.html

I am getting lib dependencies error is dependencies:libstdc++.so.6(GLIBCXX_3.4.14) is needed by kingsoft-office
I TRY LOT DOWNLOAD LIB FROM VARIOUS SITE BUT STILL GET SAME ERROR

I need to replace the Microsoft office and is excatly same as Ms office ,

drk
Posts: 405
Joined: 2014/01/30 20:38:28

Re: Problem in Installing wps kingsoft office

Post by drk » 2014/03/16 19:12:43

Libreoffice doesn't work for you?
I am getting lib dependencies error is dependencies:libstdc++.so.6(GLIBCXX_3.4.14) is needed by kingsoft-office
This:

Code: Select all

$ yum provides "*GLIBCXX_3.4*"|less
shows:
libstdc++-4.4.7-4.el6.i686 : GNU Standard C++ Library
Other : libstdc++.so.6(GLIBCXX_3.4.13)
so WPS has revisioned themselves out of a standard CentOS6 install.

prashkotak@gmail.com
Posts: 2
Joined: 2014/03/16 03:00:56

Re: Problem in Installing wps kingsoft office

Post by prashkotak@gmail.com » 2014/03/17 08:39:43

I tried out liber office, and other office tools l
But wps kingsoft is the best to replace the Ms office ..
In other software the file and format get changed if files created on msoffice .
Also i checked it is working fine on fedora 20 i tried yesterday ,,

User avatar
TrevorH
Forum Moderator
Posts: 29171
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Problem in Installing wps kingsoft office

Post by TrevorH » 2014/03/17 08:58:24

You need to report this problem to the people who provide the software. They've built it to rely on a glibc version that CentOS 6 does not and will not ever have.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

drk
Posts: 405
Joined: 2014/01/30 20:38:28

Re: Problem in Installing wps kingsoft office

Post by drk » 2014/03/17 21:13:55

prashkotak@gmail.com wrote:Also i checked it is working fine on fedora 20 i tried yesterday ,,
Fedora 20 is a long way away from CentOS 6 :P

You may be able to futz something together by finding a compatible libstdc++.so.6 and using LD_LIBRARY_PATH to grab it instead of the system one. Do not replace the system libstdc++.so.6 with your alternate.

ohw0571
Posts: 127
Joined: 2008/10/05 12:24:17

Re: Problem in Installing wps kingsoft office

Post by ohw0571 » 2014/03/18 11:02:27

You might want to have a look at this wps forum thread:

http://wps-community.org/forum/viewtopic.php?f=4&t=374

Regards
Oliver

marco76
Posts: 6
Joined: 2014/08/16 22:42:26

Re: Problem in Installing wps kingsoft office

Post by marco76 » 2014/08/21 08:49:51

ohw0571 wrote:You might want to have a look at this wps forum thread:

http://wps-community.org/forum/viewtopic.php?f=4&t=374

Regards
Oliver
I followed the link above and the steps, provided by Jackxin Chan » Tue Feb 25, 2014 7:12 am
Here is what I've done:

KingSoft Office - Solving: libstdc++.so.6(GLIBCXX_3.4.14)(64bit) error

#Download Kingsoft Office (now called WPS Office)
wget http://kdl.cc.ksosoft.com/wps-community ... 5.i686.rpm

#Install WPS Office with no dependencies (We will add them later on)
sudo rpm -ivh --nodeps wps-office-9.1.0.4751-1.a15.i686.rpm

#Get the required versions of libstdc++ and libfreetype from the links below:
http://rpm.pbone.net/index.php3/stat/4/ ... 6.rpm.html
http://rpm.pbone.net/index.php3/stat/4/ ... 6.rpm.html

#Unpack both rpm files
rpm2cpio freetype-2.4.8-4.fc17.i686.rpm | cpio -idmv
rpm2cpio libstdc++-4.7.0-5.fc17.i686.rpm | cpio -idmv

#The RPM contents that we want are:
#For freetype-2.4.8-4.fc17.i686.rpm :
libfreetype.so.6.8.0
libfreetype.so.6
#For libstdc++-4.7.0-5.fc17.i686.rpm :
libstdc++.so.6.0.17
libstdc++.so.6

#Now copy these libs to the following location
sudo cp lib* /opt/kingsoft/wps-office/office6/

That’s it.

Enjoy, ;)
MS

Post Reply

Return to “CentOS 6 - Software Support”