Automount Messages and mount failure

General support questions including new installations
Post Reply
wfouly
Posts: 16
Joined: 2014/02/19 18:47:51

Automount Messages and mount failure

Post by wfouly » 2014/02/19 19:31:41

Hello all
I met a problem on my server , some programs can't run and i checked the file /var/log/messages
And i got that errors :

Code: Select all

Feb 19 10:28:57 localhost automount[3277]: create_udp_client:107: hostname lookup failed: Unknown host
Feb 19 10:28:57 localhost automount[3277]: create_tcp_client:347: hostname lookup failed: Unknown host
Feb 19 10:28:57 localhost automount[3277]: get_exports: lookup(hosts): exports lookup failed for ****
Feb 19 10:28:57 localhost automount[3277]: key "****" not found in map source(s).
Feb 19 10:28:57 localhost automount[3277]: key "****" not found in map source(s).
I am open to all suggestions as to where to look or how to correct this/these problems.
Thanks For Your Efforts.

User avatar
avij
Retired Moderator
Posts: 3046
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Automount Messages and mount failure

Post by avij » 2014/02/19 21:09:50

Perhaps the name servers mentioned in your /etc/resolv.conf are not reachable?

wfouly
Posts: 16
Joined: 2014/02/19 18:47:51

Re: Automount Messages and mount failure

Post by wfouly » 2014/02/20 06:09:34

avij wrote:Perhaps the name servers mentioned in your /etc/resolv.conf are not reachable?
Thank you avij for you replay anyway this is my /etc/resolv.conf :

Code: Select all

nameserver 4.2.2.4
nameserver 8.8.8.8
search localhost
So what can i do or change.?

User avatar
avij
Retired Moderator
Posts: 3046
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Automount Messages and mount failure

Post by avij » 2014/02/20 12:26:27

I assume the *** in "exports lookup failed for ****" was some sort of a server name. Was that a fully qualified domain name, such as "fileserver.mycompany.com", or something "internal" such as "fileserver.intra" or just plain "fileserver"?

If it was a fully qualified domain name, see if the name servers you have configured recognise the name:

dig @4.2.2.4 fileserver.mycompany.com
and
dig @8.8.8.8 fileserver.mycompany.com

Those commands should show the IP address of the server. If you don't have dig, try installing the bind-utils package first.

It is also possible that you should be using some other name server than those you listed, such as some nameserver on your own local area network. This is especially probable if the server you tried to reach was named something like "fileserver.intra". In case the server name was just "fileserver", chances are that the server name should be found from /etc/hosts (if it's not there, try adding it with the appropriate IP address).

wfouly
Posts: 16
Joined: 2014/02/19 18:47:51

Re: Automount Messages and mount failure

Post by wfouly » 2014/02/20 13:02:27

avij wrote:I assume the *** in "exports lookup failed for ****" was some sort of a server name. Was that a fully qualified domain name, such as "fileserver.mycompany.com", or something "internal" such as "fileserver.intra" or just plain "fileserver"?

If it was a fully qualified domain name, see if the name servers you have configured recognise the name:

dig @4.2.2.4 fileserver.mycompany.com
and
dig @8.8.8.8 fileserver.mycompany.com

Those commands should show the IP address of the server. If you don't have dig, try installing the bind-utils package first.

It is also possible that you should be using some other name server than those you listed, such as some nameserver on your own local area network. This is especially probable if the server you tried to reach was named something like "fileserver.intra". In case the server name was just "fileserver", chances are that the server name should be found from /etc/hosts (if it's not there, try adding it with the appropriate IP address).
Thank you avij for you replay
Anyway this is my full error of the file /var/log/messages

Code: Select all

Feb 19 10:28:57 localhost automount[3277]: create_udp_client:107: hostname lookup failed: Unknown host
Feb 19 10:28:57 localhost automount[3277]: create_tcp_client:347: hostname lookup failed: Unknown host
Feb 19 10:28:57 localhost automount[3277]: get_exports: lookup(hosts): exports lookup failed for camfrogbot.conf
Feb 19 10:28:57 localhost automount[3277]: key "camfrogbot.conf" not found in map source(s).
Feb 19 10:28:57 localhost automount[3277]: key "camfrogbot.conf" not found in map source(s).
I tried to install bind-utils

Code: Select all

yum install bind-utils
Output

Code: Select all

Package 30:bind-utils-9.3.6-20.P1.el5_8.6.i386 already installed and latest version
Nothing to do
I checked the /etc/hosts :

Code: Select all

cat /etc/hosts
Output

Code: Select all

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1		localhost.localdomain localhost
::1		localhost6.localdomain6 localhost6
And my hostname :
Output

Code: Select all

localhost
NOTE: I don't have a domain name because i don't need it.
My server IP : 190.4.25.4
I think the problem back to autofs.
what can i do or change.?

User avatar
avij
Retired Moderator
Posts: 3046
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Automount Messages and mount failure

Post by avij » 2014/02/20 15:52:01

"camfrogbot.conf" sounds like a file name, not a server name. Perhaps there's something wrong in your automount configuration. Please show the contents of /etc/auto.master, and the content of any files referenced in the master file.

I hope you have read the Even-better method from the CentOS wiki for some background about autofs.

wfouly
Posts: 16
Joined: 2014/02/19 18:47:51

Re: Automount Messages and mount failure

Post by wfouly » 2014/02/20 16:02:43

avij wrote:"camfrogbot.conf" sounds like a file name, not a server name. Perhaps there's something wrong in your automount configuration. Please show the contents of /etc/auto.master, and the content of any files referenced in the master file.

I hope you have read the Even-better method from the CentOS wiki for some background about autofs.
I checked the file /var/log/messages NOW

Code: Select all

Feb 20 17:58:15 localhost automount[21892]: lookup_read_master: lookup(nisplus): couldn't locate nis+ table auto.master
Th output for command cat /etc/auto.master

Code: Select all

#
# $Id: auto.master,v 1.4 2005/01/04 14:36:54 raven Exp $
#
# Sample auto.master file
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# For details of the format look at autofs(5).
#
/misc	/etc/auto.misc
#
# NOTE: mounts done from a hosts map will be mounted with the
#	"nosuid" and "nodev" options unless the "suid" and "dev"
#	options are explicitly given.
#
/net	-hosts
#
# Include central master map if it can be found using
# nsswitch sources.
#
# Note that if there are entries for /net or /misc (as
# above) in the included master map any keys that are the
# same will not be seen as the first read key seen takes
# precedence.
#
+auto.master

User avatar
avij
Retired Moderator
Posts: 3046
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Automount Messages and mount failure

Post by avij » 2014/02/20 16:48:22

What do you have in /etc/auto.misc ?

I'm wondering where it got the "camfrogbot.conf" name.

wfouly
Posts: 16
Joined: 2014/02/19 18:47:51

Re: Automount Messages and mount failure

Post by wfouly » 2014/02/20 17:44:04

Code: Select all

 cat /etc/auto.misc
The output

Code: Select all

#
# $Id: auto.misc,v 1.2 2003/09/29 08:22:35 raven Exp $
#
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# Details may be found in the autofs(5) manpage

cd		-fstype=iso9660,ro,nosuid,nodev	:/dev/cdrom

# the following entries are samples to pique your imagination
#linux		-ro,soft,intr		ftp.example.org:/pub/linux
#boot		-fstype=ext2		:/dev/hda1
#floppy		-fstype=auto		:/dev/fd0
#floppy		-fstype=ext2		:/dev/fd0
#e2floppy	-fstype=ext2		:/dev/fd0
#jaz		-fstype=ext2		:/dev/sdc1
#removable	-fstype=ext2		:/dev/hdd

User avatar
avij
Retired Moderator
Posts: 3046
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Automount Messages and mount failure

Post by avij » 2014/02/22 16:12:23

Do you even need automount? Do you have a file server somewhere else that you would like to mount on your server? Your configuration does not mention the existence of such a server.

If you don't need automount, try "service autofs stop" and "chkconfig autofs off" to disable automount. If you ever need them again, "chkconfig autofs on" and "service autofs start" will restore the situation.

Post Reply

Return to “CentOS 5 - General Support”