Connection refused on port 25?

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
apnu
Posts: 8
Joined: 2005/05/19 17:33:29

Connection refused on port 25?

Post by apnu » 2005/05/31 21:19:44

Sorry for the stupid newbie question.

I have Postfix running as the MTA, with iptables and SELinux off (just for the moment). I can telnet to localhost on port 25, but I cannot telnet from another host to port 25 and see the Postfix banner. I have mynetworks = host, and myorigin set as well. What am I missing?

apnu
Posts: 8
Joined: 2005/05/19 17:33:29

Re: Connection refused on port 25?

Post by apnu » 2005/06/01 13:56:56

I found the answer to my question. I missed setting the inet_interfaces parameter to 'localhost, $myhostname, ' that fixed the problem.

I knew it was something stupid that I was over looking.

shogun1234
Posts: 10
Joined: 2005/03/10 01:02:45

Connection refused on port 25?

Post by shogun1234 » 2005/06/12 11:00:58

[quote]
apnu wrote:
I found the answer to my question. I missed setting the inet_interfaces parameter to 'localhost, $myhostname, ' that fixed the problem.

I knew it was something stupid that I was over looking.[/quote]
hi, i also encounter the same problem currently. but seemly it results from different causes. i try to
[code]telnet localhost 25[/code]
in the localhost machine, of which the iptables set to (via command iptables -n -L )
[code]
...
ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 state NEW tcp dpt:25
...
[/code]
but it hangs at the screen
[code]
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
[/code]
after pressing 'enter' immdieately.
further, i'm sure i had sasl running background as ( ps -ef | grep saslauthd )
[code]
root 2480 1 0 18:40 ? 00:00:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
root 2482 2480 0 18:40 ? 00:00:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
root 2483 2480 0 18:40 ? 00:00:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
root 2484 2480 0 18:40 ? 00:00:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
root 2485 2480 0 18:40 ? 00:00:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
[/code]
as well as
[code]
...
# SASL SMTP
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, check_relay_domains
...
[/code]
in main.cf (/etc/postfix).
btw, i use centos 4.0. postfix-2.1.5-4.2.RHEL4.
where do i need to correct in order to let clients be able to use smtp ( and send/receive mail).
i appreciate any suggestion, sincerely.

ixeous
Posts: 113
Joined: 2005/07/07 13:01:59

Re: Connection refused on port 25?

Post by ixeous » 2005/07/18 19:45:00

modify the inet_interfaces = parameter in the main.cf file and restart postfix. I usually set it to inet_interfaces = all, but can use one of the other settings as well.

Post Reply

Return to “CentOS 4 - Server Support”