[SOLVED] Timezone weirdness after performing yum update

General support questions
Post Reply
snowweb
Posts: 25
Joined: 2012/08/06 04:26:14

[SOLVED] Timezone weirdness after performing yum update

Post by snowweb » 2013/02/18 12:56:06

I performed yum update earlier and afterwards noticed that the server time got changed!

I then performed the following. Notice that the very last command (date) showed a different date to that which I accepted as being correct a few seconds earlier above it!

[code]
[root@mail ~]# tzselect
Please identify a location so that time zone rules can be set correctly.
Please select a continent or ocean.
1) Africa
2) Americas
3) Antarctica
4) Arctic Ocean
5) Asia
6) Atlantic Ocean
7) Australia
8) Europe
9) Indian Ocean
10) Pacific Ocean
11) none - I want to specify the time zone using the Posix TZ format.
#? 5
Please select a country.
1) Afghanistan 18) Israel 35) Palestine
2) Armenia 19) Japan 36) Philippines
3) Azerbaijan 20) Jordan 37) Qatar
4) Bahrain 21) Kazakhstan 38) Russia
5) Bangladesh 22) Korea (North) 39) Saudi Arabia
6) Bhutan 23) Korea (South) 40) Singapore
7) Brunei 24) Kuwait 41) Sri Lanka
8) Cambodia 25) Kyrgyzstan 42) Syria
9) China 26) Laos 43) Taiwan
10) Cyprus 27) Lebanon 44) Tajikistan
11) East Timor 28) Macau 45) Thailand
12) Georgia 29) Malaysia 46) Turkmenistan
13) Hong Kong 30) Mongolia 47) United Arab Emirates
14) India 31) Myanmar (Burma) 48) Uzbekistan
15) Indonesia 32) Nepal 49) Vietnam
16) Iran 33) Oman 50) Yemen
17) Iraq 34) Pakistan
#? 36

The following information has been given:

Philippines

Therefore TZ='Asia/Manila' will be used.
Local time is now: Mon Feb 18 20:28:43 PHT 2013.
Universal Time is now: Mon Feb 18 12:28:43 UTC 2013.
Is the above information OK?
1) Yes
2) No
#? 1

You can make this change permanent for yourself by appending the line
TZ='Asia/Manila'; export TZ
to the file '.profile' in your home directory; then log out and log in again.

Here is that TZ value again, this time on standard output so that you
can use the /usr/bin/tzselect command in shell scripts:
Asia/Manila
[/code]

[code]
[root@mail ~]# date
Mon Feb 18 05:29:57 MST 2013
[/code]
Any ideas please?

User avatar
TrevorH
Forum Moderator
Posts: 30158
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

[SOLVED] Timezone weirdness after performing yum update

Post by TrevorH » 2013/02/18 14:07:11

Is /etc/localtime a symlink to a file in /usr/share/zoneinfo? It shouldn't be, rm the symlink and copy the correct file to /etc/localtime. What happens if the file is a symlink is that an updated package copies what it thinks is the correct file and splats over the top of the one you've pointed to, overwriting it with the wrong file. You'll need to `yum reinstall tzdata` after correcting the symlink to get the correct file in place and then probably recopy it to /etc/localtime. Also review the /etc/sysconfig/clock file and make sure that it now contains the correct name of the zone file you really want it to use.

snowweb
Posts: 25
Joined: 2012/08/06 04:26:14

Re: [SOLVED] Timezone weirdness after performing yum update

Post by snowweb » 2013/02/18 17:02:27

Perfect! Worked a treat.

Cheers Trevor.

Post Reply

Return to “CentOS 6 - General Support”