[SOLVED] PHP 5.3.2 /usr/bin/ld: cannot find -lltdl ?

Issues related to software problems.
Post Reply
p4guru
Posts: 6
Joined: 2010/07/11 15:56:22

[SOLVED] PHP 5.3.2 /usr/bin/ld: cannot find -lltdl ?

Post by p4guru » 2010/07/11 16:02:11

Hi guys playing with centos 5.5 64bit with percona mysql 5.1.47 rel 11.1 and PHP 5.3.2 but compiling PHP with these options

[quote]./configure --with-apxs2=/usr/sbin/apxs --enable-bcmath --enable-calendar --enable-exif --enable-ftp --enable-gd-native-ttf --enable-libxml --with-libxml-dir=/usr --enable-magic-quotes --enable-mbstring --with-bz2 --with-curlwrappers --with-freetype-dir=/usr --with-gd --with-gettext --with-imap-ssl=/usr --with-jpeg-dir=/usr --with-kerberos --with-mcrypt --with-mysql --with-mysqli=/usr/bin/mysql_config --with-openssl=/usr --with-openssl-dir=/usr --with-png-dir=/usr --with-xmlrpc --with-zlib --with-libdir=lib64[/quote]

give me this error

[quote]lmysqlclient -lz -lcrypt -lnsl -lm -lrt -lmygcc -lxml2 -lz -lm -lcrypt -lxml2 -lz -lm -lxml2 -lz -lm -lxml2 -lz -lm -lcrypt -o libphp5.la /usr/bin/ld: cannot find -lltdl collect2: ld returned 1 exit status make: *** [libphp5.la] Error 1[/quote]


Tried basic configure

[quote]./configure --with-apxs2=/usr/sbin/apxs --with-mysql --with-mysqli=/usr/bin/mysql_config --with-zlib --with-libdir=lib64[/quote]

and get

[quote]dl -lnsl -lxml2 -lz -lm -lxml2 -lz -lm -lmysqlclient -lz -lcrypt -lnsl -lm -lrt -lmygcc -lxml2 -lz -lm -lcrypt -lxml2 -lz -lm -lxml2 -lz -lm -lxml2 -lz -lm -lcrypt -o sapi/cli/php Generating phar.php Generating phar.phar PEAR package PHP_Archive not installed: generated phar will require PHP's phar extension be enabled. clicommand.inc directorygraphiterator.inc pharcommand.inc directorytreeiterator.inc invertedregexiterator.inc phar.inc Build complete. Don't forget to run 'make test'.[/quote]


any ideas thanks

User avatar
TrevorH
Forum Moderator
Posts: 28865
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: PHP 5.3.2 /usr/bin/ld: cannot find -lltdl ?

Post by TrevorH » 2010/07/11 20:22:27

yum install libtool-ltdl-devel

p4guru
Posts: 6
Joined: 2010/07/11 15:56:22

Re: PHP 5.3.2 /usr/bin/ld: cannot find -lltdl ?

Post by p4guru » 2010/07/11 20:53:41

thanks that was it!

had a few other errors on the way so had to run

[quote]yum install pcre-devel *libXpm* libtool-ltdl-devel[/quote]

User avatar
AlanBartlett
Forum Moderator
Posts: 9324
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

[SOLVED] PHP 5.3.2 /usr/bin/ld: cannot find -lltdl ?

Post by AlanBartlett » 2010/07/12 14:04:24

For posterity, this thread is marked [SOLVED].

Post Reply

Return to “CentOS 5 - Software Support”