Error Snort 2.7.0.1 Installation

Issues related to software problems.
Post Reply
gsato
Posts: 1
Joined: 2007/08/13 16:42:20
Location: Sao Paulo

Error Snort 2.7.0.1 Installation

Post by gsato » 2007/08/13 17:04:05

I'm trying install the Snort 2.7.0.1, but there is an error:

[root@net01 snort-2.7.0.1]#./configure --with-mysql
ERROR! Libpcap library/headers (libpcap.a (or .so)/pcap.h)
not found, go get it from http://www.tcpdump.org
or use the --with-libpcap-* options, if you have it installed
in unusual place. Also check if your libpcap depends on another
shared library that may be installed in an unusual place

I download the libpcap (libpcap-0.9.7.tar.tar) and I'm trying install this rpm too, but there is this error:

[root@net01 libpcap-0.9.7]#./configure
configure: error: Your operating system's lex is insufficient to compile
libpcap. flex is a lex replacement that has many advantages, including
being able to compile libpcap. For more information, see
http://www.gnu.org/software/flex/flex.html .

Anybody now how can I solve this problem?
My environment is:
CentOS 5
MySQL (mysql-server-5.0.22-2.1)
Apache (httpd-2.2.3-6.el5.centos.1)
PHP (php-5.1.6-12.el5)

Thanks,
Gabriela

foxb
Posts: 1927
Joined: 2006/04/20 19:03:33
Location: Montreal/QC

Error Snort 2.7.0.1 Installation

Post by foxb » 2007/08/14 12:45:02

libpcap is already included in CentOS.....

Do not forget -devel package

[code]
yum install libpcap libpcap-devel
[/code]

Post Reply

Return to “CentOS 5 - Software Support”