[RESOLVED] reboot hangs at "Restarting system" console msg - no warm reset!

General support questions
cpaff
Posts: 4
Joined: 2011/08/25 16:48:41

[RESOLVED] reboot hangs at "Restarting system" console msg - no warm reset!

Post by cpaff » 2011/08/25 17:33:50

Odd - this newly installed system doesn't reset the hardware when reboot requested. "reboot" or "init 6" shut CentOS
down properly and echo messages on console, ending with:
"Restarting system"
It hangs infinitely at this point, where I expect the system to do a warm reset.
At this point, a Ctrl-Alt-Del does nothing. The only recourse is to hold power button 5 seconds
to shut off and then press again to power on. Very inconvenient for remote administration.

I looked at BIOS and can't find anything relevant. Power settings tried: 'Last State' and 'Power ON' when restored.

Any ideas?

Charley


Fresh and updated CentOS 6.0 installed.
Dell Precision T1600 workstation w/ Intel Xeon and integrated video.

Basic system information.
[code]
== BEGIN uname -rmi ==
2.6.32-71.29.1.el6.x86_64 x86_64 x86_64
== END uname -rmi ==

== BEGIN rpm -qa \*-release\* ==
centos-release-6-0.el6.centos.5.x86_64
== END rpm -qa \*-release\* ==

== BEGIN cat /etc/redhat-release ==
CentOS Linux release 6.0 (Final)
== END cat /etc/redhat-release ==

== BEGIN getenforce ==
Disabled
== END getenforce ==

== BEGIN free -m ==
total used free shared buffers cached
Mem: 15831 683 15147 0 30 194
-/+ buffers/cache: 458 15373
Swap: 7999 0 7999
== END free -m ==

[/code]

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

[RESOLVED] reboot hangs at "Restarting system" console msg -

Post by gerald_clark » 2011/08/25 18:16:11

This sounds like an acpi problem.
Is acpi turned off in your BIOS or in a boot option?
Does the BIOS need updating?

User avatar
TrevorH
Forum Moderator
Posts: 28865
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: reboot hangs at "Restarting system" console msg - no warm reset!

Post by TrevorH » 2011/08/25 18:48:17

There are some kernel parameters which can be used to bypass problems like this: reboot=warm|cold|bios|smp|triple|kbd|acpi|efi|pci|force

/* reboot=b[ios] | s[mp] | t[riple] | k[bd] | e[fi] [, [w]arm | [c]old] | p[ci]
warm Don't set the cold reboot flag
cold Set the cold reboot flag
bios Reboot by jumping through the BIOS (only for X86_32)
smp Reboot by executing reset on BSP or other CPU (only for X86_32)
triple Force a triple fault (init)
kbd Use the keyboard controller. cold reset (default)
acpi Use the RESET_REG in the FADT
efi Use efi reset_system runtime service
pci Use the so-called "PCI reset register", CF9
force Avoid anything that could hang.
*/

Default is warm I think.

cpaff
Posts: 4
Joined: 2011/08/25 16:48:41

Re: reboot hangs at "Restarting system" console msg - no warm reset!

Post by cpaff » 2011/08/25 23:20:34

I tried appending reboot=cold (also tried triple, hard and warm) to the kernel line in grub.conf.
No change on next attempted reboot.

User avatar
TrevorH
Forum Moderator
Posts: 28865
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: reboot hangs at "Restarting system" console msg - no warm reset!

Post by TrevorH » 2011/08/25 23:37:52

Did you try force?

Latest BIOS for the t1600 is A01 dated April this year. There's no list of what was changed.

Might be worth reporting to Dell since I suspect a Precision t1600 is an expensive machine and they might actually support it :-)

simonl
Posts: 2
Joined: 2011/09/16 13:37:14

Re: reboot hangs at "Restarting system" console msg - no warm reset!

Post by simonl » 2011/09/19 11:25:47

Hello,

Did you get any further with this?

I'm not a CentOS user but I registered to post the following, in case my experience is relevant to you.

I have a new Precision T1600, BIOS revision A05, AMD FirePro2270 video.
I've installed Scientific Linux 6.0. It's based on Linux from the same Upstream Vendor, so is very similar.

I suffer from exactly the same issue. I tried reboot=force. I checked the BIOS. No difference.

Like you I'm running the updated kernel, 2.6.32-71.29.1.el6.x86_64, but had the same problem with the original, 2.6.32-71.el6.x86_64.

After a bit of experimentation I've found that the problem does not occur with the 32-bit kernel. I don't want to run 32-bit but I thought I'd let you know in case it's the same with CentOS. Just might be of help.

FYI Scientific Linux have released kernel 2.6.32-131 for SL 6.0 (& 6.1). I can't get it to boot successfully on the T1600.
You might need to be careful if CentOS also release this kernel version.

Regards

Simon

cpaff
Posts: 4
Joined: 2011/08/25 16:48:41

Re: reboot hangs at "Restarting system" console msg - no warm reset!

Post by cpaff » 2011/09/19 20:51:38

Try "reboot=p" in grub.conf kernel line.

cpaff
Posts: 4
Joined: 2011/08/25 16:48:41

Re: [RESOLVED] reboot hangs at "Restarting system" console msg - no warm reset!

Post by cpaff » 2011/09/19 22:14:33

As noted below, the kernel parameter "reboot" can be set to deal with disparate systems.
This Dell Precision T1600 workstation running 64-bit CentOS 6 can now reboot with the "reboot=p" option.
I discovered this by first setting it broadly with "reboot=a,e,p,t" after figuring out that they can be
strung together. After booting with these parameter active, you can verify the parameter with "cat /proc/cmdline".


[quote]
TrevorH wrote:
There are some kernel parameters which can be used to bypass problems like this: reboot=warm|cold|bios|smp|triple|kbd|acpi|efi|pci|force

/* reboot=b[ios] | s[mp] | t[riple] | k[bd] | e[fi] [, [w]arm | [c]old] | p[ci]
warm Don't set the cold reboot flag
cold Set the cold reboot flag
bios Reboot by jumping through the BIOS (only for X86_32)
smp Reboot by executing reset on BSP or other CPU (only for X86_32)
triple Force a triple fault (init)
kbd Use the keyboard controller. cold reset (default)
acpi Use the RESET_REG in the FADT
efi Use efi reset_system runtime service
pci Use the so-called "PCI reset register", CF9
force Avoid anything that could hang.
*/

Default is warm I think.[/quote]

simonl
Posts: 2
Joined: 2011/09/16 13:37:14

Re: [RESOLVED] reboot hangs at "Restarting system" console msg - no warm reset!

Post by simonl » 2011/09/22 16:38:36

Thanks for pointing me at that.

Don't know why I didn't read what TrevorH had written a bit more carefully.
So thanks to you too TrevorH.

Now, on to the next issue...

Simon

User avatar
AlanBartlett
Forum Moderator
Posts: 9324
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: [RESOLVED] reboot hangs at "Restarting system" console msg - no warm reset!

Post by AlanBartlett » 2011/09/23 01:18:54

Thank you for reporting back.

For posterity (and on your behalf) this thread is marked [RESOLVED].

Post Reply

Return to “CentOS 6 - General Support”