Monitor not detect

Issues related to hardware problems
almondon
Posts: 15
Joined: 2023/03/01 03:02:37

Re: Monitor not detect

Post by almondon » 2023/05/08 01:41:26

Thanks @jlehtone

yes, I have some sort of screen and have access to keyboard, I think I do not need ssh.

Just by trying to install kmod-nvidia in el7 I receive error as I explained in previous comment.

User avatar
jlehtone
Posts: 4550
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Monitor not detect

Post by jlehtone » 2023/05/08 07:11:29

almondon wrote:
2023/05/08 01:37:31
I tried as root and I received this:
Error: nvidia-x11-drv conflicts with ocl-icd-2.2.12-1.el7.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
The ocl-icd is from EPEL and provides:

Code: Select all

repoquery --provides ocl-icd
libOpenCL.so.1()(64bit)
libOpenCL.so.1(OPENCL_1.0)(64bit)
libOpenCL.so.1(OPENCL_1.1)(64bit)
libOpenCL.so.1(OPENCL_1.2)(64bit)
libOpenCL.so.1(OPENCL_2.0)(64bit)
libOpenCL.so.1(OPENCL_2.1)(64bit)
libOpenCL.so.1(OPENCL_2.2)(64bit)
ocl-icd = 2.2.12-1.el7
ocl-icd(x86-64) = 2.2.12-1.el7
The nvidia-x11-drv-libs from ELRepo provides (among other things):

Code: Select all

libOpenCL.so.1
libOpenCL.so.1(OPENCL_1.0)
libOpenCL.so.1(OPENCL_1.1)
libOpenCL.so.1(OPENCL_1.2)
libOpenCL.so.1(OPENCL_2.0)
libOpenCL.so.1(OPENCL_2.1)
libOpenCL.so.1(OPENCL_2.2)
libOpenCL.so.1(OPENCL_3.0)
Two packages provide the same feature. Only one can be installed.


Uninstall the ocl-icd (and pay attention to what goes with it). Then install the NVidia drivers.

almondon
Posts: 15
Joined: 2023/03/01 03:02:37

Re: Monitor not detect

Post by almondon » 2023/05/09 08:49:29

Thanks for your reply,

yes, I think removing elrepo might be risky.
(Also, I'm not sure if after removing elrepo I can work with nvidia-detect and then 'yum install kmod-nvidia')

I tried before and I think the following packages would be removed:
sudo yum remove ocl-icd

Loaded plugins: fastestmirror, langpacks
Resolving Dependencies
--> Running transaction check
---> Package ocl-icd.x86_64 0:2.2.12-1.el7 will be erased
--> Processing Dependency: libOpenCL.so.1()(64bit) for package: ffmpeg-3.4.12-1.el7.x86_64
--> Processing Dependency: libOpenCL.so.1()(64bit) for package: ffmpeg-libs-3.4.12-1.el7.x86_64
--> Processing Dependency: libOpenCL.so.1(OPENCL_1.0)(64bit) for package: ffmpeg-3.4.12-1.el7.x86_64
--> Processing Dependency: libOpenCL.so.1(OPENCL_1.0)(64bit) for package: ffmpeg-libs-3.4.12-1.el7.x86_64
--> Running transaction check
---> Package ffmpeg.x86_64 0:3.4.12-1.el7 will be erased
---> Package ffmpeg-libs.x86_64 0:3.4.12-1.el7 will be erased
--> Processing Dependency: ffmpeg-libs(x86-64) = 3.4.12-1.el7 for package: libavdevice-3.4.12-1.el7.x86_64
--> Processing Dependency: ffmpeg-libs(x86-64) = 3.4.12-1.el7 for package: ffmpeg-devel-3.4.12-1.el7.x86_64
--> Processing Dependency: libavcodec.so.57()(64bit) for package: libavdevice-3.4.12-1.el7.x86_64
--> Processing Dependency: libavcodec.so.57()(64bit) for package: 1:vlc-core-3.0.18-1.el7.x86_64
--> Processing Dependency: libavcodec.so.57()(64bit) for package: ffmpeg-devel-3.4.12-1.el7.x86_64
--> Processing Dependency: libavcodec.so.57(LIBAVCODEC_57)(64bit) for package: libavdevice-3.4.12-1.el7.x86_64
--> Processing Dependency: libavcodec.so.57(LIBAVCODEC_57)(64bit) for package: 1:vlc-core-3.0.18-1.el7.x86_64
--> Processing Dependency: libavfilter.so.6()(64bit) for package: libavdevice-3.4.12-1.el7.x86_64
--> Processing Dependency: libavfilter.so.6()(64bit) for package: ffmpeg-devel-3.4.12-1.el7.x86_64
--> Processing Dependency: libavfilter.so.6(LIBAVFILTER_6)(64bit) for package: libavdevice-3.4.12-1.el7.x86_64
--> Processing Dependency: libavformat.so.57()(64bit) for package: libavdevice-3.4.12-1.el7.x86_64
--> Processing Dependency: libavformat.so.57()(64bit) for package: 1:vlc-core-3.0.18-1.el7.x86_64
--> Processing Dependency: libavformat.so.57()(64bit) for package: ffmpeg-devel-3.4.12-1.el7.x86_64
--> Processing Dependency: libavformat.so.57(LIBAVFORMAT_57)(64bit) for package: libavdevice-3.4.12-1.el7.x86_64
--> Processing Dependency: libavformat.so.57(LIBAVFORMAT_57)(64bit) for package: 1:vlc-core-3.0.18-1.el7.x86_64
--> Processing Dependency: libavresample.so.3()(64bit) for package: ffmpeg-devel-3.4.12-1.el7.x86_64
--> Processing Dependency: libavutil.so.55()(64bit) for package: libavdevice-3.4.12-1.el7.x86_64
--> Processing Dependency: libavutil.so.55()(64bit) for package: 1:vlc-core-3.0.18-1.el7.x86_64
--> Processing Dependency: libavutil.so.55()(64bit) for package: ffmpeg-devel-3.4.12-1.el7.x86_64
--> Processing Dependency: libavutil.so.55(LIBAVUTIL_55)(64bit) for package: libavdevice-3.4.12-1.el7.x86_64
--> Processing Dependency: libavutil.so.55(LIBAVUTIL_55)(64bit) for package: 1:vlc-core-3.0.18-1.el7.x86_64
--> Processing Dependency: libpostproc.so.54()(64bit) for package: ffmpeg-devel-3.4.12-1.el7.x86_64
--> Processing Dependency: libpostproc.so.54()(64bit) for package: 1:vlc-core-3.0.18-1.el7.x86_64
--> Processing Dependency: libpostproc.so.54(LIBPOSTPROC_54)(64bit) for package: 1:vlc-core-3.0.18-1.el7.x86_64
--> Processing Dependency: libswresample.so.2()(64bit) for package: ffmpeg-devel-3.4.12-1.el7.x86_64
--> Processing Dependency: libswscale.so.4()(64bit) for package: ffmpeg-devel-3.4.12-1.el7.x86_64
--> Processing Dependency: libswscale.so.4()(64bit) for package: 1:vlc-core-3.0.18-1.el7.x86_64
--> Processing Dependency: libswscale.so.4(LIBSWSCALE_4)(64bit) for package: 1:vlc-core-3.0.18-1.el7.x86_64
--> Running transaction check
---> Package ffmpeg-devel.x86_64 0:3.4.12-1.el7 will be erased
---> Package libavdevice.x86_64 0:3.4.12-1.el7 will be erased
---> Package vlc-core.x86_64 1:3.0.18-1.el7 will be erased
--> Processing Dependency: libvlccore.so.9()(64bit) for package: 1:vlc-3.0.18-1.el7.x86_64
--> Processing Dependency: vlc-core(x86-64) = 1:3.0.18-1.el7 for package: 1:vlc-3.0.18-1.el7.x86_64
--> Running transaction check
---> Package vlc.x86_64 1:3.0.18-1.el7 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Removing:
ocl-icd x86_64 2.2.12-1.el7 @epel 140 k
Removing for dependencies:
ffmpeg x86_64 3.4.12-1.el7 @rpmfusion-free-updates 2.2 M
ffmpeg-devel x86_64 3.4.12-1.el7 @rpmfusion-free-updates 8.6 M
ffmpeg-libs x86_64 3.4.12-1.el7 @rpmfusion-free-updates 17 M
libavdevice x86_64 3.4.12-1.el7 @rpmfusion-free-updates 161 k
vlc x86_64 1:3.0.18-1.el7 @rpmfusion-free-updates 4.5 M
vlc-core x86_64 1:3.0.18-1.el7 @rpmfusion-free-updates 50 M

Transaction Summary

Cheers

User avatar
jlehtone
Posts: 4550
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Monitor not detect

Post by jlehtone » 2023/05/09 12:56:55

almondon wrote:
2023/05/09 08:49:29
================================================================================
Package Arch Version Repository Size
================================================================================
Removing:
ocl-icd x86_64 2.2.12-1.el7 @epel 140 k
Removing for dependencies:
ffmpeg x86_64 3.4.12-1.el7 @rpmfusion-free-updates 2.2 M
ffmpeg-devel x86_64 3.4.12-1.el7 @rpmfusion-free-updates 8.6 M
ffmpeg-libs x86_64 3.4.12-1.el7 @rpmfusion-free-updates 17 M
libavdevice x86_64 3.4.12-1.el7 @rpmfusion-free-updates 161 k
vlc x86_64 1:3.0.18-1.el7 @rpmfusion-free-updates 4.5 M
vlc-core x86_64 1:3.0.18-1.el7 @rpmfusion-free-updates 50 M
Oh yes. Both ELRepo and RPMFusion do actually provide NVidia drivers. I have always used ELRepo version.

You have installed VLC from RPMFusion. It needs something. At the time of installation
that something was available only in EPEL package ocl-icd, so you now have that
and it blocks the installation of NVidia driver.

Your system can live a moment without VLC and ffmpeg.
The sudo yum remove ocl-icd is thus ok. You can sudo yum install vlc later.

When you do have removed the ocl-icd, you can:
sudo yum install kmod-nvidia
and after that install the VLC back.

almondon
Posts: 15
Joined: 2023/03/01 03:02:37

Re: Monitor not detect

Post by almondon » 2023/05/10 07:24:25

Thanks @jlehtone for your message and the explanations.
I will try to remove it and will try to
sudo yum install kmod-nvidia

and will try to report the process here.

Cheers

almondon
Posts: 15
Joined: 2023/03/01 03:02:37

Re: Monitor not detect

Post by almondon » 2023/05/11 02:02:08

Thanks @TrevorH @jlehtone for your helps.
I removed ocl-icd and installed kmod-nvidia successfully.
Now I have monitor with full resolution on my pc.

Just I have several kernels and I think make the boot drive full.
Can I remove them and keep only the last one or the last 2 one.

Cheers

User avatar
jlehtone
Posts: 4550
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Monitor not detect

Post by jlehtone » 2023/05/11 08:36:05

almondon wrote:
2023/05/11 02:02:08
Can I remove them and keep only the last one or the last 2 one.
Yes. Package 'yum-utils' has utility 'package-cleanup' that can be used:

Code: Select all

sudo package-cleanup --oldkernels
It does actually call yum, so you get to [y/N] what it would remove.

See man package-cleanup for what else it can do.

almondon
Posts: 15
Joined: 2023/03/01 03:02:37

Re: Monitor not detect

Post by almondon » 2023/05/15 01:47:57

Thanks @jlehtone for your helps and sorry always for being late.

Cheers

almondon
Posts: 15
Joined: 2023/03/01 03:02:37

Re: Monitor not detect

Post by almondon » 2024/01/16 08:17:39

Thanks @TrevorH @jlehtone for your helps.
Now I installed Alma9.3, I think I have the same problem,

the results from lspci -nn | grep -i vga
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GA102 [GeForce RTX 3080 12GB] [10de:220a] (rev a1)

and the results from nvidia-detect
is nothing,

Do you think if I can resolve the problem.

All The Best

User avatar
jlehtone
Posts: 4550
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Monitor not detect

Post by jlehtone » 2024/01/17 09:43:40

almondon wrote:
2024/01/16 08:17:39
Now I installed Alma9.3, I think I have the same problem,

and the results from nvidia-detect
is nothing,
See viewtopic.php?p=337598#p337598

Post Reply