New Install No Ethernet

Issues related to configuring your network
Post Reply
barnmichael
Posts: 1
Joined: 2020/12/12 01:36:47

New Install No Ethernet

Post by barnmichael » 2020/12/12 01:42:27

New install of CentOS-7 minimal install on new computer. Went well, but no Ethernet. tried nmtui to set up network. No Ethernet device listed. Good light on switch, blinking yellow light on computer. Tried 'ip a' and it only shows the loopback. Tried lspci and got "command not found".

So, how do I get networking working on CentOS-7?

Thanks,
Michael

User avatar
TrevorH
Forum Moderator
Posts: 30337
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: New Install No Ethernet

Post by TrevorH » 2020/12/12 02:58:42

Start with lspci -nn | grep -i net to get the PCI vendor/device ids and then check with grep -i $vendor /lib/modules/$(uname -r)/modules.* | grep -i $deviceid (substitute using your vendor/device ids before you run that) to see if there is a module that supports it already in the supplied kernel. Probably not since it would be listed if there was. If not then you probably want to check the ELRepo yum repo and see if they offer a kmod package that supports your card.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

chrismjh
Posts: 30
Joined: 2015/12/08 03:50:24

Re: New Install No Ethernet

Post by chrismjh » 2021/03/01 15:17:31

Same Problem - I have a relatively new Dell laptop, and ifconfig does not list any adapters. I followed what you said Trevor and matched the device:id and have --

Code: Select all

00:1f.6 0200: 8086:0d4c 
I checked online ElRepo for a match here : http://elrepo.org/tiki/DeviceIDs

There are no matches for "8086:0d4c" . Should I just move to CentOS 8?

User avatar
TrevorH
Forum Moderator
Posts: 30337
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: New Install No Ethernet

Post by TrevorH » 2021/03/01 15:36:29

That adapter is supported on CentOS 8 but that only lives for the rest of this year. I think that if you download and manually install kmod-e1000e from elrepo that should support it. Make sure you also install their elrepo-release package so you get future updates.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

chrismjh
Posts: 30
Joined: 2015/12/08 03:50:24

Re: New Install No Ethernet

Post by chrismjh » 2021/03/01 15:43:24

Awesome thanks

chrismjh
Posts: 30
Joined: 2015/12/08 03:50:24

Re: New Install No Ethernet

Post by chrismjh » 2021/03/01 18:46:24

The error i'm getting while installing the kmod rpm is
failed dependencies : kernel >= 3.10.0-1127.19.1.el7 is needed by kmod-e1000e-3.8.4-3.el7_9.elrepo.x86_64
Am downloading the latest cent 7 dvd iso hopefully will resolve, or I could download those 20-25 kernel rpms manually?

User avatar
TrevorH
Forum Moderator
Posts: 30337
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: New Install No Ethernet

Post by TrevorH » 2021/03/01 19:37:36

What's the current output from rpm -q kernel ?
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

chrismjh
Posts: 30
Joined: 2015/12/08 03:50:24

Re: New Install No Ethernet

Post by chrismjh » 2021/03/01 19:51:32

kernel-3.10.0.1127.el7.x86_64

Maybe my sudo password is wrong

User avatar
TrevorH
Forum Moderator
Posts: 30337
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: New Install No Ethernet

Post by TrevorH » 2021/03/01 21:12:11

No, you've installed an old version of CentOS 7 (7.8) not the latest 7.9. The kmod you downloaded is for 7.9 so you have two choices, either update the system to 7.9 using a 3.10.0-1160* series kernel so that the kmod you have already downloaded works or download the older kmod-e1000e which is

kmod-e1000e.x86_64 3.8.4-2.el7_8.elrepo elrepo

That's http://elrepo.org/linux/elrepo/el7/x86_ ... x86_64.rpm

Once you have a network connection, make sure that you have elrepo-release installed and the elrepo repo enabled and then run yum update to get to the current versions of everything.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

chrismjh
Posts: 30
Joined: 2015/12/08 03:50:24

Re: New Install No Ethernet

Post by chrismjh » 2021/03/01 21:16:55

Yeah I tried the 7.8 kmod, same error, there is one more older one to try, Gonna download latest kernel and go with 7.9, these updates come quick, thank you

Post Reply

Return to “CentOS 7 - Networking Support”