why is there no glibc-debuginfo-2.17-260.el7_6.6.x86_64.rpm ???

Issues related to applications and software problems
Post Reply
leon_n
Posts: 2
Joined: 2019/07/09 11:03:31

why is there no glibc-debuginfo-2.17-260.el7_6.6.x86_64.rpm ???

Post by leon_n » 2019/07/09 11:15:09

I am trying to use GDB version 4.8.5 (CentOS ) to debug,the error is :

missing seperate ,use debuginfo-install glibc-2.17-260.el7_6.6.x86_64


but there is only 6.5 updated on 2019-05-09 :
[ ] glibc-debuginfo-common-2.17-260.el7_6.5.x86_64.rpm 2019-05-09 15:04 9.5M
[ ] glibc-debuginfo-2.17-260.el7_6.5.x86_64.rpm 2019-05-09 15:04 9.5M

what should I do?
if there is no glibc-debuginfo-2.17-260.el7_6.6.x86_64.rpm ,why does GDB want me to debuginfo-install???
I am so confused. :?: :?: :?: :?:
hoping your answer.thang you ! :D :D :D :D

User avatar
TrevorH
Forum Moderator
Posts: 30366
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: why is there no glibc-debuginfo-2.17-260.el7_6.6.x86_64.rpm ???

Post by TrevorH » 2019/07/09 15:48:54

I've asked for this to be checked out.

Update: packages have been pushed but won't be available until tomorrow as there is an overnight job that rebuilds the repo metadata out of hours.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

leon_n
Posts: 2
Joined: 2019/07/09 11:03:31

Re: why is there no glibc-debuginfo-2.17-260.el7_6.6.x86_64.rpm ???

Post by leon_n » 2019/07/11 03:55:33

TrevorH wrote:
2019/07/09 15:48:54
I've asked for this to be checked out.

Update: packages have been pushed but won't be available until tomorrow as there is an overnight job that rebuilds the repo metadata out of hours.
perfect!
thanks so much! :D :D :D

LViejo
Posts: 1
Joined: 2020/08/28 11:08:44

Re: why is there no glibc-debuginfo-2.17-260.el7_6.6.x86_64.rpm ???

Post by LViejo » 2020/08/28 11:43:03

Although I'm running under CentOS 8.2 I am replying to a report of what appears to be the same problem reported by leon_n » 2019/07/09 07:15:09 under CentOS 7. I am seeing the [seemingly] same problem when debugging a program built under Qt Creator:
(gdb) run
Starting program: /home/jsiler/devel/STS/NewStation/src/build-NewDemo-Desktop_Qt_5_15_0_GCC_64bit-Debug/NewDemo
Missing separate debuginfos, use: yum debuginfo-install glibc-2.28-101.el8.x86_64
$ sudo dnf debuginfo-install glibc
enabling epel-modular-debuginfo repository
enabling epel-debuginfo repository
Last metadata expiration check: 0:30:49 ago on Fri 28 Aug 2020 06:45:06 AM EDT.
Could not find debuginfo package for the following installed packages: glibc-2.28-101.el8.x86_64
Could not find debugsource package for the following installed packages: glibc-2.28-101.el8.x86_64
Dependencies resolved.
Nothing to do.
Complete!
$ sudo dnf list|grep debug|grep glibc
$
Is this a regression problem?

lsb_release output:
LSB Version: :core-4.1-amd64:core-4.1-noarch:cxx-4.1-amd64:cxx-4.1-noarch:desktop-4.1-amd64:desktop-4.1-noarch:languages-4.1-amd64:languages-4.1-noarch:printing-4.1-amd64:printing-4.1-noarch
Distributor ID: CentOS
Description: CentOS Linux release 8.2.2004 (Core)
Release: 8.2.2004
Codename: Core
"About Qt Creator":
Qt Creator 4.13.0
Based on Qt 5.15.0 (GCC 5.3.1 20160406 (Red Hat 5.3.1-6), 64 bit)

Built on Aug 25 2020 10:11:25

From revision fff3b41833
Thanks,

Jim [LViejo]

User avatar
TrevorH
Forum Moderator
Posts: 30366
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: why is there no glibc-debuginfo-2.17-260.el7_6.6.x86_64.rpm ???

Post by TrevorH » 2020/08/28 15:43:04

For problems like this the best thing is just to go straight to bugs.centos.org and raise a ticket.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Emtec
Posts: 1
Joined: 2020/12/27 17:46:43

Re: why is there no glibc-debuginfo-2.17-260.el7_6.6.x86_64.rpm ???

Post by Emtec » 2020/12/27 17:49:26

Another problems with packages:

Code: Select all

Could not find debuginfo package for the following installed packages: libgcc-8.3.1-5.1.el8.x86_64, libstdc++-8.3.1-5.1.el8.x86_64, mysql-libs-8.0.21-1.module_el8.2.0+493+63b41e36.x86_64, openssl-libs-1:1.1.1g-11.el8.x86_64, zlib-1.2.11-16.el8_2.x86_64

Code: Select all

uname -a
Linux ns3172361.ip-51-210-32.eu 4.18.0-240.1.1.el8_3.x86_64 #1 SMP Thu Nov 19 17:20:08 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

User avatar
TrevorH
Forum Moderator
Posts: 30366
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: why is there no glibc-debuginfo-2.17-260.el7_6.6.x86_64.rpm ???

Post by TrevorH » 2020/12/28 13:03:02

Please see my post directly before yours...
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - Software Support”