OS Installation via shared network port on HPE Server

General support questions
Post Reply
Venga
Posts: 2
Joined: 2020/07/01 12:07:53

OS Installation via shared network port on HPE Server

Post by Venga » 2020/07/01 13:01:30

Hi,

We have HPE DL380 server, and we trying to install CentOS 7.6 version through ILO Shared Network port option as a virtual media.

During network card drivers installation level we loss connection ILO interface and OS installation is failed.

Do we have a chance to customize the OS.iso file that prevents installation of network card drivers?

Or do you have any other suggestions?

Thank you very much.

User avatar
TrevorH
Forum Moderator
Posts: 29444
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: OS Installation via shared network port on HPE Server

Post by TrevorH » 2020/07/01 15:36:08

I believe this is a problem with using the shared port. It's _either_ usable for the iLO OR it's usable by the o/s, not both.

It's _possible_ but not definite that segmenting the traffic by using VLAN settings might help but really the best solution is to use the dedicated iLO port.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Venga
Posts: 2
Joined: 2020/07/01 12:07:53

Re: OS Installation via shared network port on HPE Server

Post by Venga » 2020/07/02 05:52:29

Hello Trevor,

Thank you for the answer.

But we have to use a shared network.

How can I configure the CentOS installation file without the network adapter driver in it?

Can you help with this?

Or are there links to the subject you can share?

Thank you.

User avatar
jlehtone
Posts: 3033
Joined: 2007/12/11 08:17:33
Location: Finland

Re: OS Installation via shared network port on HPE Server

Post by jlehtone » 2020/07/02 08:10:18

HPE wrote:Shared network port LOM
This NIC normally handles server network traffic, and it can be configured to handle iLO network traffic at the same time via a common RJ-45 connector.
From what I gather, there is some sort of multiplexer/switch so that both the OS and iLO are wired to the same physical ethernet connector. Each has unique MAC.
Not sure whether OS can connect to iLO directly (without plugging cable&switch to the port). I guess not.

In other words, what the OS does should have no effect on the iLO.
HPE wrote:If the shared network port is enabled, user cannot modify the link state or duplex options. When using shared network port configurations, these settings must be managed in the operating system.
This could be an explanation: activation of OS NIC revamps link/duplex so that iLO drops out?


Does the server have more than one NIC? If so, then the installer kernel should be told (via command line options) to use the other NIC and not bring up the shared one.
I'm quite sure that there are options to configure network, for example to set IP manually or to say which interface(s) to use.

Venga wrote:
2020/07/01 13:01:30
we trying to install CentOS 7.6 version
CentOS 7 is currently 7.8.2003. The 7.6 ceased to exist last Summer.

Post Reply

Return to “CentOS 7 - General Support”