Icewm Light-weight Desktop Environment for CentOS Altarch 7.8.2003 on i386

Issues related to applications and software problems
Post Reply
Len E.
Posts: 20
Joined: 2014/10/11 00:04:37

Icewm Light-weight Desktop Environment for CentOS Altarch 7.8.2003 on i386

Post by Len E. » 2020/06/14 23:17:16

The icewm desktop environment has evolved over the years from
being simply an alternate window manager for larger environments
like Gnome and KDE to an independent light-weight environment
on its own. This transition became evident with release 1.4.3
which is used on current Debian-based and Ubuntu-based distros.

The current CentOS 7 release is 1.3.8 and in particular lacks the
shutdown and reboot options in addition to a normal logout when
exiting the environment. In looking for a newer environment
for CentOS 7, the available alternatives were limited:
Fedora 30 using the same release as CentOS 7
Fedora 31 used version 1.6.2
Fedora 32 and CentOS 8 both use version 1.6.5

After running into problems with the 2-step build (rpm -ivh --nomd5,
rpmbuiild -bb icewm.spec) for version 1.6.5, success was achieved
with the Fedora 31 version, icewm-1.6.2-1.fc31.src.rpm.
*********************************************************************************
A huge assistance to creating the icewm-1.6.2 32-bit package was
the Springdale Linux repository,
http://springdale.math.ias.edu/data/pui ... ted/7/i386

It had all the required dependency packages required in 32-bit form.
(The package list is attached as Icewmfc31.txt)
The command sudo yum --nogpgcheck localinstall cmake3*.rpm
jsoncpp*.rpm libuv*.rpm rhash*.rpm installed the 8 packages
directly with no additional dependencies required.

The icewm binary packages in the list were all generated with
the 2-step build of the icewm .src.rpm.
******************************************************************************
A bug was encountered in the sudo rpmbuild -bb icewm.spec step.
It kept failing with the error message
/usr/include/fribidi/fribidi-types.h:31:21 Fatal error:
<config.h>: no such file

It turns out that the process looks in the directory /usr/include
for modules such as inttypes.h and stdint.h, but the config.h
file was resident in /usr/include/valgrind.
By copying config.h into the /usr/include directory, the problem
was solved.
**************************************************************************
Once the Icewm version 1.6.2 package is installed, 2 other steps
are required to ensure seamless, independent behaviour of the desktop:

-The icewm startup file is located in /usr/share/icewm.
Polkit authentication is enabled by installing the following statement
immediately after the #!/bin/bash line in the file:
/usr/libexec/polkit-gnome-authentication-agent-1 &

-For proper shutdown and reboot execution, the following 2 statements
should be inserted in the /etc/sudoers file immediately after the other
wheel-related statements and before any user-related statements:
%wheel ALL=(ALL) NOPASSWD: /sbin/shutdown -h 0
%wheel ALL=(ALL) NOPASSWD: /sbin/reboot

(The assumption is that the user is a member of the wheel group).
***********************************************************************************
Icewm now represents a truly light-weight alternative desktop for
32-bit implementations, as an additional choice to the e16 desktop
which has been described in past posts on this forum.

Len E.
Attachments
Icewmfc31.txt
(583 Bytes) Downloaded 9 times

Len E.
Posts: 20
Joined: 2014/10/11 00:04:37

Icewm Light-weight Desktop Environment for CentOS Altarch 7.8.2003 on i386

Post by Len E. » 2020/06/28 00:34:30

I encountered a problem with one of the application menu entries
on Icewm, specifically the Utility ----> Core -------> Files program,
the nautilus file manager. The program wouldn't start from the menu.

In trying to diagnose the problem, from the terminal, in /usr/bin,
I entered icewm-menu-fdo, which invokes the program which
normally updates the menu when new packages are installed or
existing packages are removed. The program outputs to the screen
the contents of the resultant menu.

The menu entry for nautilus was
prog "Files" org.gnome.Nautilus icewm-menu-fdo "/usr/share//applications/org.gnome.Nautilus.desktop"

I believed the double slash between usr and share might be the cause of the problem,
but I had no idea how to fix it, because it's automatically generate by icewm-menu-fdo.

The entry did appear across 2 lines on the screen, so I thought I could shorten it
simply by renaming the .desktop file to simply nautilus.desktop.
I did that, and reran icewm-menu-fdo.

The screen now showed
prog "Files" org.gnome.Nautilus icewm-menu-fdo "usr/share//applications/nautilus.desktop"

The line was shorter and occupied only one line, but still had the double slash.

But the menu entry now works !!! (Who really knows why).

Len E.

bonedome
Posts: 166
Joined: 2017/04/22 08:11:04

Re: Icewm Light-weight Desktop Environment for CentOS Altarch 7.8.2003 on i386

Post by bonedome » 2020/06/28 11:24:40

Hello
not sure if this is related but on fluxbox window manager you need to run nautilus with this command

Code: Select all

nautilus --no-desktop --browser
as nautilus (for some reason) takes over running the desktop.

Post Reply

Return to “CentOS 7 - Software Support”