Can't install Remmina on centos 8

Issues related to applications and software problems and general support
Post Reply
Liran
Posts: 21
Joined: 2014/06/05 09:10:28

Can't install Remmina on centos 8

Post by Liran » 2020/05/22 07:31:24

following https://remmina.org/how-to-install-remmina/

Option1

Code: Select all

[liran@localhost ~]$ sudo dnf copr enable hubbitus/remmina-next
[sudo] password for liran: 
Updating Subscription Management repositories.
Unable to read consumer identity
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.

You are about to enable a Copr repository. Please note that this
repository is not part of the main distribution, and quality may vary.

The Fedora Project does not exercise any power over the contents of
this repository beyond the rules outlined in the Copr FAQ at
<https://docs.pagure.org/copr.copr/user_documentation.html#what-i-can-build-in-copr>,
and packages are not held to any quality or security level.

Please do not file bug reports about these packages in Fedora
Bugzilla. In case of problems, contact the owner of this repository.

Do you really want to enable copr.fedorainfracloud.org/hubbitus/remmina-next? [y/N]: y
Error: This repository does not have any builds yet so you cannot enable it now
Error: This repository does not have any builds yet so you cannot enable it now

Option2
Not relevant (Centos 7)

Option3

Code: Select all

[liran@localhost ~]$ remmina
bash: remmina: command not found...
Install package 'remmina' to provide command 'remmina'? [N/y] y


 * Waiting in queue... 
 * Loading list of packages.... Failed to install packages: Could not depsolve transaction; 1 problem detected:
 Problem: conflicting requests
  - nothing provides libgcrypt.so.11()(64bit) needed by remmina-1.4.1-1.el7.x86_64
  - nothing provides libgcrypt.so.11(GCRYPT_1.2)(64bit) needed by remmina-1.4.1-1.el7.x86_64
BUT....

Code: Select all

[liran@localhost ~]$ sudo yum install libgcrypt
Updating Subscription Management repositories.
Unable to read consumer identity
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
CentOS-8 - AppStream                                                                                                                                                               5.7 kB/s | 4.3 kB     00:00    
CentOS-8 - Base                                                                                                                                                                    7.8 kB/s | 3.9 kB     00:00    
CentOS-8 - Extras                                                                                                                                                                  2.5 kB/s | 1.5 kB     00:00    
CentOS-8 - PowerTools                                                                                                                                                               19 kB/s | 4.3 kB     00:00    
Docker CE Stable - x86_64                                                                                                                                                          8.0 kB/s | 3.5 kB     00:00    
ELRepo.org Community Enterprise Linux Repository - el8                                                                                                                             4.1 kB/s | 2.9 kB     00:00    
Extra Packages for Enterprise Linux Modular 8 - x86_64                                                                                                                              36 kB/s |  34 kB     00:00    
Extra Packages for Enterprise Linux 8 - x86_64                                                                                                                                      15 kB/s |  17 kB     00:01    
google-chrome                                                                                                                                                                      7.6 kB/s | 1.3 kB     00:00    
Remi's Modular repository for Enterprise Linux 8 - x86_64                                                                                                                          9.2 kB/s | 3.5 kB     00:00    
Safe Remi's RPM repository for Enterprise Linux 8 - x86_64                                                                                                                         8.4 kB/s | 3.0 kB     00:00    b
Package libgcrypt-1.8.3-4.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Is it possible to change remmina to call the installed libgcrypt?

any other ssh manager to use on centos 8?

BTW: flatpak and snap didn't work either

User avatar
TrevorH
Forum Moderator
Posts: 28833
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Can't install Remmina on centos 8

Post by TrevorH » 2020/05/22 08:11:01

You can't use CentOS 7 packages on CentOS 8. If you want to use the el7 version for something then you need to grab the SRPM and rebuild that using mock.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

gerry666uk
Posts: 38
Joined: 2020/02/10 19:06:06

Re: Can't install Remmina on centos 8

Post by gerry666uk » 2020/05/22 19:06:10

I don't think Remmina exists in the official RHEL8 (CentOS 8) repos.
Can you clarify what you want to use it for?

tkuraku
Posts: 4
Joined: 2020/05/12 13:57:57

Re: Can't install Remmina on centos 8

Post by tkuraku » 2020/05/23 17:10:44

Remmina is going to be built in EPEL. https://bugzilla.redhat.com/show_bug.cgi?id=1766280 there are some dependency problems hat have to be sorted out before the maintainer can build it. As far as I can tell eventually it will be in EPEL, but it isn't clear what the time line is.

Liran
Posts: 21
Joined: 2014/06/05 09:10:28

Re: Can't install Remmina on centos 8

Post by Liran » 2020/05/23 18:29:00

Thanks for your reply.
I have used it on Centos 7 as a connection manager. It's like using mRemoteNG or MobaXterm on windows.
I guess I'll wait for the EPEL release :)

Post Reply

Return to “CentOS 8 - General Support”