unexpected YUM error whilst updating my dev system

Issues related to applications and software problems
Post Reply
aegersz
Posts: 86
Joined: 2016/04/04 07:42:58

unexpected YUM error whilst updating my dev system

Post by aegersz » 2020/03/13 19:32:16

Code: Select all

Error: Package: php-symfony4-common-4.1.13-1.el6.remi.noarch (remi)
           Requires: php(language) >= 7.1.3
           Removing: php-common-5.6.40-13.el6.remi.i686 (@remi-php56)
               php(language) = 5.6.40
           Updated By: php-common-5.6.40-18.el6.remi.i686 (remi-php56)
               php(language) = 5.6.40
           Available: php-common-5.6.40-17.el6.remi.i686 (remi-php56)
               php(language) = 5.6.40
Error: Package: php-twig2-2.12.5-1.el6.remi.noarch (remi)
           Requires: php(language) >= 7.0
           Removing: php-common-5.6.40-13.el6.remi.i686 (@remi-php56)
               php(language) = 5.6.40
           Updated By: php-common-5.6.40-18.el6.remi.i686 (remi-php56)
               php(language) = 5.6.40
           Available: php-common-5.6.40-17.el6.remi.i686 (remi-php56)
               php(language) = 5.6.40
Error: Package: php-williamdes-mariadb-mysql-kbs-1.2.10-1.el6.remi.noarch (remi)
           Requires: php(language) >= 7.1
           Removing: php-common-5.6.40-13.el6.remi.i686 (@remi-php56)
               php(language) = 5.6.40
           Updated By: php-common-5.6.40-18.el6.remi.i686 (remi-php56)
               php(language) = 5.6.40
           Available: php-common-5.6.40-17.el6.remi.i686 (remi-php56)
               php(language) = 5.6.40
Error: Package: php-phpmyadmin-sql-parser5-5.2.0-1.el6.remi.noarch (remi)
           Requires: php(language) >= 7.1
           Removing: php-common-5.6.40-13.el6.remi.i686 (@remi-php56)
               php(language) = 5.6.40
           Updated By: php-common-5.6.40-18.el6.remi.i686 (remi-php56)
               php(language) = 5.6.40
           Available: php-common-5.6.40-17.el6.remi.i686 (remi-php56)
               php(language) = 5.6.40
Error: Package: phpMyAdmin-5.0.1-2.el6.remi.noarch (remi)
           Requires: php(language) >= 7.1.3
           Removing: php-common-5.6.40-13.el6.remi.i686 (@remi-php56)
               php(language) = 5.6.40
           Updated By: php-common-5.6.40-18.el6.remi.i686 (remi-php56)
               php(language) = 5.6.40
           Available: php-common-5.6.40-17.el6.remi.i686 (remi-php56)
               php(language) = 5.6.40
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Last edited by aegersz on 2020/03/13 21:00:52, edited 1 time in total.

aegersz
Posts: 86
Joined: 2016/04/04 07:42:58

Re: unexpected error whilst updating my dev system

Post by aegersz » 2020/03/13 20:27:42

But my othere systems don't have it installed. Here is another excerpt:

Code: Select all

---> Package php-symfony4-common.noarch 0:4.1.13-1.el6.remi will be installed
--> Processing Dependency: php(language) >= 7.1.3 for package: php-symfony4-common-4.1.13-1.el6.remi.noarch
---> Package php-symfony4-filesystem.noarch 0:4.1.13-1.el6.remi will be installed
---> Package php-twig2.noarch 0:2.12.5-1.el6.remi will be installed
--> Processing Dependency: php(language) >= 7.0 for package: php-twig2-2.12.5-1.el6.remi.noarch
---> Package php-williamdes-mariadb-mysql-kbs.noarch 0:1.2.10-1.el6.remi will be installed
--> Processing Dependency: php(language) >= 7.1 for package: php-williamdes-mariadb-mysql-kbs-1.2.10-1.el6.remi.noarch
---> Package phpMyAdmin.noarch 0:5.0.1-2.el6.remi will be an update
--> Processing Dependency: php(language) >= 7.1.3 for package: phpMyAdmin-5.0.1-2.el6.remi.noarch
--> Finished Dependency Resolution

aegersz
Posts: 86
Joined: 2016/04/04 07:42:58

Re: unexpected error whilst updating my dev system

Post by aegersz » 2020/03/13 20:55:27

I had to "yum update --exclude=phpMyAdmin" to get around this but i can't figure out why my dev and live systems are out of sync as far as phpMyAdmin goes

aegersz
Posts: 86
Joined: 2016/04/04 07:42:58

Re: unexpected YUM error whilst updating my dev system

Post by aegersz » 2020/03/13 21:56:59

found the issue and set "enabled=0" in the first repo config block in remi.repo:

Code: Select all

[remi]
name=Remi's RPM repository for Enterprise Linux 6 - $basearch
mirrorlist=http://rpms.famillecollet.com/enterprise/6/remi/mirror
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi

Post Reply

Return to “CentOS 6 - Software Support”