[SOLVED]Re: Booting problem: mount: you must specify the filesystem type

General support questions
pvanthony
Posts: 25
Joined: 2013/09/07 14:14:34

[SOLVED]Re: Booting problem: mount: you must specify the filesystem type

Post by pvanthony » 2020/01/13 14:13:11

Hi,
This is a centos 6 server with software raid1 drives. One of the drives has smart errors, so we needed to change the hard drive /dev/sdb.
We shutdown the server. Replaced /dev/sdb with a new drive and booted the server.

The grub shows up and starts to boot. Then the error happens. "mount: you must specify the filesystem type".

Next we removed the new drive and just booted with /dev/sda. We got the grub and it started to boot but got the same error, "mount: you must specify the filesystem type".

After that we put back the original hard drive and boot the server up and this time it booted up fine.

We reinstalled grub on both hard drives just to be sure. But that did not solve the problem.
Did some searching and google listed some pages saying dracut was the problem but no solution.

How can we solve this problem? Really need help with this. Hope someone can give some pointers and hints.
Last edited by pvanthony on 2020/01/21 15:40:49, edited 2 times in total.

User avatar
KernelOops
Posts: 278
Joined: 2013/12/18 15:04:03
Location: xfs file system

Re: Booting problem: mount: you must specify the filesystem type

Post by KernelOops » 2020/01/13 16:04:18

If only the failing drive contains the /boot partition, then you won't be able to boot.

In software raid situations, I always place a raid1 /boot partition on all drives, so they are all bootable no matter what.
--
I love my computer - all my friends live there.
--

User avatar
TrevorH
Forum Moderator
Posts: 29113
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Booting problem: mount: you must specify the filesystem type

Post by TrevorH » 2020/01/13 16:10:40

You haven't given enough information for anyone to be able to help you. Post the output from fdisk -lu on all drives, the contents of /etc/fstab, the grub.cfg stanza for the current kernel, the output from the commands pvs, vgs and lvs.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

pvanthony
Posts: 25
Joined: 2013/09/07 14:14:34

Re: Booting problem: mount: you must specify the filesystem type

Post by pvanthony » 2020/01/13 16:37:59

TrevorH wrote:
2020/01/13 16:10:40
You haven't given enough information for anyone to be able to help you. Post the output from fdisk -lu on all drives, the contents of /etc/fstab, the grub.cfg stanza for the current kernel, the output from the commands pvs, vgs and lvs.
My bad. Here's the information. Let me know if more is needed.

Code: Select all

---------- fstab ------------------
/dev/md2		/backup			ext4	defaults	1 1
/dev/md1		/ 			ext4 	defaults,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 1 1
/dev/md0		/boot 			ext3 	defaults	1 2
/dev/sda2		swap			swap	defaults	0 0
/dev/sdb2		swap			swap	defaults	0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
------- end fstab ----------------

Code: Select all

------- fdisk -lu /dev/sda ----------------
# fdisk -lu /dev/sda

Disk /dev/sda: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x7d6a3838

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63      433751      216844+  fd  Linux raid autodetect
Partition 1 does not end on cylinder boundary.
Partition 1 does not start on physical sector boundary.
/dev/sda2          433752    16466623     8016436   82  Linux swap / Solaris
/dev/sda3        16466624  3907024063  1945278720   fd  Linux raid autodetect

------- end fdisk -lu /dev/sda ----------

Code: Select all

------- fdisk -lu /dev/sdb ----------------
# fdisk -lu /dev/sdb

Disk /dev/sdb: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x120a7cda

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          63      433751      216844+  fd  Linux raid autodetect
Partition 1 does not end on cylinder boundary.
Partition 1 does not start on physical sector boundary.
/dev/sdb2          433752    16466623     8016436   82  Linux swap / Solaris
/dev/sdb3        16466624  3907024063  1945278720   fd  Linux raid autodetect


------- end fdisk -lu /dev/sdb ----------

Code: Select all

--------- grub.conf ---------------------
default=0
timeout=15

title CentOS (2.6.32-754.24.3.el6.x86_64)
root (hd0,0)
kernel /vmlinuz-2.6.32-754.24.3.el6.x86_64 ro root=/dev/md1 rd_NO_LUKS crashkernel=auto SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us
rd_NO_LVM rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16
KEYBOARDTYPE=pc KEYTABLE=us crashkernel=auto rdshell
initrd /initramfs-2.6.32-754.24.3.el6.x86_64.img

--------- end grub.conf ----------------
This looks very embarrassing. I think the problem is /dev/sda1 partition boot flag is not set. Is my assumption correct?
If yes, how do I set the boot flag now? Is it too late?

Thank you for replying and offering to help. I do appreciate it very much.

User avatar
TrevorH
Forum Moderator
Posts: 29113
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Booting problem: mount: you must specify the filesystem type

Post by TrevorH » 2020/01/13 17:36:37

/dev/sdb2 swap swap defaults 0 0
If you're trying to remove /dev/sdb then you will need to stop the system from using that swap area (swapoff /dev/sdb2) and comment it out of fstab. I suspect that's the error you hit that caused the problem.

Incidentally that would have stopped your system from functioning if the drive had failed too. You have 2 swap areas, one on each disk but they are separate so loss of either will most likely kill your system. You'd be better off RAIDing those too.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

pvanthony
Posts: 25
Joined: 2013/09/07 14:14:34

Re: Booting problem: mount: you must specify the filesystem type

Post by pvanthony » 2020/01/16 11:56:14

TrevorH wrote:
2020/01/13 17:36:37
/dev/sdb2 swap swap defaults 0 0
If you're trying to remove /dev/sdb then you will need to stop the system from using that swap area (swapoff /dev/sdb2) and comment it out of fstab. I suspect that's the error you hit that caused the problem.

Incidentally that would have stopped your system from functioning if the drive had failed too. You have 2 swap areas, one on each disk but they are separate so loss of either will most likely kill your system. You'd be better off RAIDing those too.
I took a while to reply because I just had access to the server and tried the recommended. Unfortunately it still does not work.

Did the following.
1. Stop swap on /dev/sdb
2. comment out the swap partition in /etc/fstab.

Any other suggestions I can try?

pvanthony
Posts: 25
Joined: 2013/09/07 14:14:34

Re: Booting problem: mount: you must specify the filesystem type

Post by pvanthony » 2020/01/16 12:05:28

Took a picture of the problem.
858109942_148230.jpg
858109942_148230.jpg (135.41 KiB) Viewed 385 times

pvanthony
Posts: 25
Joined: 2013/09/07 14:14:34

Re: Booting problem: mount: you must specify the filesystem type

Post by pvanthony » 2020/01/16 12:08:55

Tried with rdshell in grub. Then it says that it cannot find the root. Some how it does not seem to mount the root. I am guessing. Here is the photo with the rdshell.
857423056_185886.jpg
857423056_185886.jpg (130.88 KiB) Viewed 385 times

User avatar
TrevorH
Forum Moderator
Posts: 29113
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Booting problem: mount: you must specify the filesystem type

Post by TrevorH » 2020/01/16 15:53:46

And that particular kernel boots ok normally?
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

pvanthony
Posts: 25
Joined: 2013/09/07 14:14:34

Re: Booting problem: mount: you must specify the filesystem type

Post by pvanthony » 2020/01/16 16:10:48

TrevorH wrote:
2020/01/16 15:53:46
And that particular kernel boots ok normally?
With /dev/sda and /dev/sdb in the server, the kernel boots ok and the server is working fine.

I remove /dev/sdb, the grub comes up, starts the kernel. When it needs to go to the root to continue, then we get the error.

Very strange. When I do "cat /proc/mdstat" all looks good.

Thank you for continuing to help. I do appreciate it very much.

Post Reply

Return to “CentOS 6 - General Support”