Mellanox network card help

Issues related to configuring your network
Post Reply
Posts: 4
Joined: 2019/09/08 19:41:31

Mellanox network card help

Post by willraasch » 2019/09/19 16:32:37

So I am trying to set up my first 10-gigabit network between my main computer (Windows 10) and my centos 7 server box. My main computer's Mellanox connectx2 card worked right out of the box when I plugged it in however on the server box I see on boot up it says something about Mellanox but then does not get internet when plugged into my switch. I was wondering how I would even start to troubleshoot this? any help would be appreciated

the cards I got these cards ( ... 12&sr=8-16)

Posts: 1
Joined: 2019/09/21 16:54:40

Re: Mellanox network card help

Post by mindcloud » 2019/09/21 17:31:31

I ran in to this recently on the same card and you would need to install the Mellanox drivers, but as I discovered to my dismay. Mellanox does not support that card on recent drivers and the old ones do not work on the newer kernels/centos versions.

See ... sw_drivers the last time those were supported was driver version 3.4- which only supports centos 7.3. I had to switch to an intel 10GB card.

Posts: 692
Joined: 2013/12/08 19:44:49

Re: Mellanox network card help

Post by chemal » 2019/09/21 18:16:12

willraasch wrote:
2019/09/19 16:32:37
on boot up it says something about Mellanox
Do you mind telling what it says?

Posts: 64
Joined: 2019/07/29 16:15:14

Re: Mellanox network card help

Post by alpha754293 » 2019/09/30 19:23:02

I'm not sure about the older cards, but for me, with my Mellanox ConnectX-4 cards, the three things that I would look for are:

First, does the card "POST" when your computer starts up? On my Mellanox ConnectX-4 cards, there is the FlexBoot BIOS that will show up on POST that will allow network booting with that card, so that's one way for me to see and verify that the cards are in good, working, operational order.

Second, the next thing that I would check would be to see if the card was detected by the operating system. In CentOS, what I would run (in a terminal, as root:

Code: Select all

# lspci | grep Mellanox
and it should show you the device ID and also some basic information about the kind of Mellanox card that you have installed.

If it doesn't come up, then it's either a hardware or as someone else as already mentioned, a software/driver issue.

And last but not least, the third thing that I would check would be to make sure that the driver/module started up correctly as well. In CentOS 7 for my system, after I do the initial installation, I have to, again as root, run:

Code: Select all

# yum -y groupinstall 'Infiniband Support'
and also

Code: Select all

# yum -y install rdma opensm ... 
(and a bunch others that I can't remember off the top of my head) in order to get my card working.

So you can try that.

Post Reply

Return to “CentOS 7 - Networking Support”