Can't access SAMBA shares from Mac Mojave

Issues related to configuring your network
Post Reply
Posts: 15
Joined: 2019/03/18 01:43:35

Can't access SAMBA shares from Mac Mojave

Post by johnwmcc » 2019/03/18 02:10:56

i've just set up a new CentOS 7.6 server on a VMware ESXi 6.5 virtual machine, in order to run Plex.

I've added Samba v4, opened assorted ports recommended in a post on setting up Samba 4 specifically on CentOS.

I've added a Samba user to match my own Linux username.

I've tried to share my home folder, and another folder with subfolders to which I want to add media (music, films, TV shows and photos) for Plex to serve. I can't access them remotely to add files.

The folders to be shared have owner john:users, directory permissions 775 and default file permissions 664 (I think - I can't add files at the moment).

I've created one test text file with permissions 777.

I'm using MacOS Mojave to try to access the shares and copy files to them. I can connect to the server via Finder/Go/Connect to Server and inputting the IP address, then using Connect As... to enter my Linus username and pw.

I can see the shared folders, but can't open ones with a subfolder, and I can't see the text file in my home folder /home/john.

What's stopping this access? Is it SELinux? If so, how do I correct that?

If it isn't that, what else might it be?

I looked at the article on Understanding Samba 4, and couldn't understand it, especially the firewall rules editing iptables.

CentOS has the firewalld and firewall-cmd method of setting firewall rules. But I've a suspicion that isn't the problem - I've opened what I believe (from an article about setting up Samba specifically on CentOS) are the relevant tcp and udp ports - quite a lot of them!

Please help. i've been banging my head all evening on this, and don't understand what's causing the problem.


It seems that SE (Secure) Linux is enabled by default.

Rather than turn it off completely, I found a command in another forum that enables R/W access for all Samba shares. That solved THAT problem.

Post Reply

Return to “CentOS 7 - Networking Support”