CentOS 7 can't continue installation

General support questions
Post Reply
Posts: 1
Joined: 2015/01/27 22:35:33

CentOS 7 can't continue installation

Post by dimmy » 2015/01/28 00:44:42

I'll preface this by admitting to being a brand newcomer to Linux in general. Suffice to say I'm finally trying to dual boot because of school. I've spent the last day or so overcoming different obstacles, but now I seem to have hit a wall. I've tried researching this problem and the only solutions I've found seem to solved within a previous Linux OS the user had. I found two threads on this forum about this same problem but neither seemed to yield any results. I'll link them anyway.

viewtopic.php?f=47&t=48035&p=204187&hil ... ce#p204187

viewtopic.php?f=47&t=48444&p=205878&hil ... mg#p205878

I'm installing from a 16GB PNY flash drive with a CentOS 7 DVD.iso mounted via Win32 Image Writer. When I boot to the flash drive, I select Troubleshooting>Install CentOS 7 Basic Graphics (or something to this effect). I choose this option because the main "Install CentOS 7" option leads me to a black screen with just my mouse, and the "Basic Graphics" option was a workaround I found online.

At this point the installer opens, I choose my language, timezone, etc. When I get to partitioning my drive (3TB Western Digital WD30EZRX-OOS), I setup a 2MB biosboot partition, a 24GB swap partition, and a 30GB root partition. At this point I hit "Done" and I'm told there are errors that need to fixed. The error given is "sdc may not have enough space for grub2 to embed core.img when using the xfs filesystem on partition".

If I hit "Done" again and go back to the main page "Begin Installation" is grayed out, preventing me from continue even if I wanted to.

I've tried changing the filesystems and device types, which just makes the error change accordingly. I've also tried making the root partition as large as 100GB, to no avail.

I'd appreciate any help on this topic.


Posts: 4
Joined: 2015/01/25 10:02:49

Re: CentOS 7 can't continue installation

Post by padoauk » 2015/02/01 17:32:02


I am not quite sure about your situation. Why don't you try the default disk partition for your start ?
In order to become familiar to linux (CentOS) installation, it is a good idea to try VirtualBox on your first OS (I guess it is Windows).

Posts: 5
Joined: 2015/02/02 01:54:16

Re: CentOS 7 can't continue installation

Post by deretsigernu » 2015/02/02 14:32:30

I have no idea if what I'm about to write to you could be the case, but I've done dual boot with other OSes added to Windows and I'm not an expert either, so I thought I would offer some help, one newb to another. Windows is usually on the first few drives/volumes/partitions and so I have to make an extended partition that is logical. Then when I am in the partitioning phase of the install, I set up the /boot partition for the linux OS to be 500 MB, not 2 MB. I don't use /biosboot, it's never come up as an issue for me. I don't know what the difference it, maybe you need it in your case, but if I can remember back to when I first set up a dual boot years back, there was no /biosboot, just /boot. With UEFI, I think that complicated things for a lot of people. So far, even with a new computer, I haven't had to face down that obstacle. Don't know if you want to try the method I just offered. Good luck.

Posts: 732
Joined: 2013/12/08 19:44:49

Re: CentOS 7 can't continue installation

Post by chemal » 2015/02/02 17:43:24

You are missing a /boot partition (~500 MB). A small biosboot partition (~1 MB) is also required to boot from a gpt disk with a legacy bios. In short: you should at least have a look at what the installer sets up with automatic partitioning before trying to be smarter.

Post Reply

Return to “CentOS 7 - General Support”