Installing Paraview 4.1

Issues related to software problems.
Post Reply
roshan320
Posts: 3
Joined: 2014/02/27 16:44:49

Installing Paraview 4.1

Post by roshan320 » 2014/02/27 16:48:20

Hello,
I have Centos 5.2 and I want to install Praview 4.1 on it. So when I downloaded rpm package, I found that there are lot of depedencies. So I downloaded source package to install manually. While doing Cmake in it I got error messages:
"-- The C compiler identification is GNU 4.1.2
-- The CXX compiler identification is GNU 4.1.2
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at CMakeLists.txt:36 (message):
ParaView requires an out of source Build. Please create a separate binary
directory and run CMake there.
"

Please let me know how to solve this issue.

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Installing Paraview 4.1

Post by gerald_clark » 2014/02/27 17:03:09

5.2 is really old and insecure. You should yum update to the current 5.10 support level.
You should be using yum to install your packages so that dependencies are resolved.

roshan320
Posts: 3
Joined: 2014/02/27 16:44:49

Re: Installing Paraview 4.1

Post by roshan320 » 2014/02/27 17:51:49

Thanks for your reply.
I tried with "yum update" but I am getting depedencies missing
"
--> Finished Dependency Resolution
Error: Missing Dependency: libibumad.so.1()(64bit) is needed by package mpitests_mvapich_intel
Error: Missing Dependency: libmlx4 = 1.0-1.ofed1.4.mlnx8 is needed by package libmlx4-devel
Error: Missing Dependency: libsdp = 1.1.99-1.ofed1.4.mlnx8 is needed by package libsdp-devel
Error: Missing Dependency: libibumad.so.1()(64bit) is needed by package mpitests_mvapich_pgi
Error: Missing Dependency: libibumad.so.1()(64bit) is needed by package mvapich_gcc
Error: Missing Dependency: libibumad.so.1()(64bit) is needed by package mpitests_mvapich_gcc
Error: Missing Dependency: libibumad.so.1(IBUMAD_1.0)(64bit) is needed by package mvapich_gcc
"
Please let me know how to solve this one

roshan320
Posts: 3
Joined: 2014/02/27 16:44:49

Re: Installing Paraview 4.1

Post by roshan320 » 2014/03/05 16:11:42

Bounce..!!

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Installing Paraview 4.1

Post by gerald_clark » 2014/03/05 17:01:52

We need the complete yum command entered as well as the full output.
Snippets are not helpful.

drk
Posts: 405
Joined: 2014/01/30 20:38:28

Re: Installing Paraview 4.1

Post by drk » 2014/03/05 20:08:59

roshan320 wrote:Thanks for your reply.
I tried with "yum update" but I am getting depedencies missing
"
--> Finished Dependency Resolution
Error: Missing Dependency: libibumad.so.1()(64bit) is needed by package mpitests_mvapich_intel
Error: Missing Dependency: libmlx4 = 1.0-1.ofed1.4.mlnx8 is needed by package libmlx4-devel
Error: Missing Dependency: libsdp = 1.1.99-1.ofed1.4.mlnx8 is needed by package libsdp-devel
Error: Missing Dependency: libibumad.so.1()(64bit) is needed by package mpitests_mvapich_pgi
Error: Missing Dependency: libibumad.so.1()(64bit) is needed by package mvapich_gcc
Error: Missing Dependency: libibumad.so.1()(64bit) is needed by package mpitests_mvapich_gcc
Error: Missing Dependency: libibumad.so.1(IBUMAD_1.0)(64bit) is needed by package mvapich_gcc
"
Please let me know how to solve this one
For a CentOS 5.x update that goes up in revision(s) I usually like to do it in steps like:

Code: Select all

    $ su -
    # yum update "yum*" "rpm*"
    # yum update "glibc*" "mkinitrd*"
    # yum update "kernel*"
    # yum update

chemal
Posts: 697
Joined: 2013/12/08 19:44:49

Re: Installing Paraview 4.1

Post by chemal » 2014/03/06 23:50:06

roshan320 wrote: Error: Missing Dependency: libmlx4 = 1.0-1.ofed1.4.mlnx8 is needed by package libmlx4-devel
Error: Missing Dependency: libsdp = 1.1.99-1.ofed1.4.mlnx8 is needed by package libsdp-devel
You have replaced various packages relating to infiniband with third party stuff, most likely an OFED stack from Mellanox. You cannot update your system simply with 'yum update'.

As to paraview: they have binary tarballs. Try that.

Post Reply

Return to “CentOS 5 - Software Support”