Oracle Patch 4198954

Installation and support for Oracle DB on CentOS.
Post Reply
Posts: 11
Joined: 2006/02/19 00:07:43
Location: Fairbanks, Alaska

Oracle Patch 4198954

Post by fxars » 2006/09/19 02:21:55

I'm trying to apply patch Oracle patch 4198954 to CentOS 4.3.

This consists of applying two rpm's supplied by Oracle:


When I run
sudo rpm -ihv compat-oracle-rhel4-1.0-5.i386.rpm
per the README.txt supplied the patch zip file, I get:

error: Failed dependencies:
openmotif21 is needed by compat-oracle-rhel4-1.0-5.i386
Suggested resolutions:

I've tried
sudo yum install openmotif21-
which got me a "no match for argument"

and variations, including plain
sudo yum install openmotif21

In that case, I simply got 404 errors from all the mirrors.

I've also tried downloading some OpenMotif rpm's from but that didn't work.

Anyway, I know that Motif Windows Manager is required for some variations of Oracle iAS (Application Server) so I figure someone else must have run into this problem.

Any hints?
=== Al

Posts: 37
Joined: 2006/02/14 19:45:02
Location: Cordoba, Argentina

Oracle Patch 4198954

Post by mariano » 2006/09/19 03:18:45

Hi, I could not replicate your error. Try with "openmotif21.i386"

# yum list openmotif21
Setting up repositories
Reading repository metadata in from local files
Available Packages
openmotif21.i386 2.1.30-11.RHEL4.6 base
# yum install openmotif21.i386
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for openmotif21 to pack into transaction set.
openmotif21-2.1.30-11.RHE 100% |=========================| 6.4 kB 00:00
---> Package openmotif21.i386 0:2.1.30-11.RHEL4.6 set to be updated
--> Running transaction check

Dependencies Resolved

Package Arch Version Repository Size
openmotif21 i386 2.1.30-11.RHEL4.6 base 991 k

Transaction Summary
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)
Total download size: 991 k
Is this ok [y/N]: y
Downloading Packages:
(1/1): openmotif21-2.1.30 100% |=========================| 991 kB 00:18
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: openmotif21 ######################### [1/1]

Installed: openmotif21.i386 0:2.1.30-11.RHEL4.6

Good luck.

Posts: 11
Joined: 2006/02/19 00:07:43
Location: Fairbanks, Alaska

Re: Oracle Patch 4198954

Post by fxars » 2006/09/20 01:02:56

Tried it on another machine in a different network. Looks like a firewall problem.

=== Al

Posts: 1
Joined: 2007/12/26 04:00:09

Re: Oracle Patch 4198954

Post by calmbluesea » 2007/12/26 04:07:42


Can i get all the patches needed for installing oracle in RHEL AS4---
I do not have CSI for me to download them from

please if anyone can help me then do it---
Patch lists are follows

Thank you in advance for your help

you can mail me those patches

Posts: 1015
Joined: 2006/06/10 18:27:44
Location: 32 4′N 34 47′E

Re: Oracle Patch 4198954

Post by yyagol » 2007/12/27 06:10:48

CSI cost my company $15,000 ,you don't expect someone to give you his CSI do you ?
If you are using the free edition you can install the latest version and migrate the DB ,
the documentation on that is very good .


[code]Patchset 3948480
Product Oracle Database Family
Platform or Language Click for more information about this option
Last Updated 13-DEC-2004
Size 313M (328533371 bytes)[/code]
will not fit in email

Post Reply

Return to “CentOS 4 - Oracle Installation and Support”