Can't make multicast work

Issues related to configuring your network
Post Reply
Posts: 3
Joined: 2010/12/10 17:10:36

Can't make multicast work

Post by jitterFreak » 2010/12/14 17:28:53

I have an application in which several hosts on a LAN communicate with one another by UDP broadcasts. I would like to change it to use multicasting, because of administrative policies at some sites that discourage or forbid the use of IP broadcasting on the LAN. I have found a number of different example programs on the web, but I can't get any of them to work on my development net.

Here's one example:

This program forks off a child process, and then attempts to send mulitcast packets from the parent to the child. The host responds to pings on the multicast address when the program is running, and it stops responding to pings when I kill the program, but the child process never seems to receive any packets. I don't know how to determine whether the problem is that the parent is not sending them, that the child is not recieving them, or something else.

I've been trying IPv4 multicast addresses in the range, and port numbers > 1024. I've tried running as root, and I've tried running as an ordinary user. I have tried compiling other demo programs that I've found on the web, all with more or less the same result. I've also tried running the sender and the receiver on different hosts (more like my intended application anyway) and still, the same result.

Here is what getinfo says about my development box:

Anybody got any ideas?

Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Can't make multicast work

Post by gerald_clark » 2010/12/14 18:17:05

Do not Double post.

Posts: 3
Joined: 2010/12/10 17:10:36

Re: Can't make multicast work

Post by jitterFreak » 2010/12/14 20:46:44

Sorry, I accidentally posted to the wrong forum (CentOS 4 Networking instead of CentOS 5.) I did not think anybody would be offended if I re-posted my question to the correct forum.

User avatar
Forum Moderator
Posts: 9327
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk

Re: Can't make multicast work

Post by AlanBartlett » 2010/12/14 22:37:19

== BEGIN uname -rmi ==
2.6.9-89.0.20.EL i686 i386
== END uname -rmi ==

== BEGIN rpm -q centos-release ==
== END rpm -q centos-release ==

== BEGIN cat /etc/redhat-release ==
CentOS release 4.8 (Final)
== END cat /etc/redhat-release ==
You are running [i]CentOS 4[/i] not [i]CentOS 5[/i].

So this [b][i]is[/i][/b] the correct forum.

Post Reply

Return to “CentOS 4 - Networking Support”