patchset on CentOS 5.1 32-bit?

Installation and support for Oracle DB on CentOS.
Post Reply
Posts: 7
Joined: 2007/12/31 14:28:35

patchset on CentOS 5.1 32-bit?

Post by slvjerome » 2008/04/17 19:27:12

When I execute the runInstaller for the patchset it gives me:

Checking operating system version: must be redhat-3, SuSE-9, SuSE-10, redhat-4, redhat-5, UnitedLinux-1.0, asianux-1, asianux-2 or asianux-3
Failed <<<<

I already had set /etc/redhat-release to:

Which can be used to get past this similar error with the Database installer. Oracle must've changed the way they determine the OS with the patchset installer.

Has anyone gotten past this message with the patchset?

I also tried setting it to:

But got same error.

Posts: 3
Joined: 2007/12/11 09:15:42

Re: patchset on CentOS 5.1 32-bit?

Post by unficyp » 2008/04/21 09:05:06

Try finding the file oraparams.ini (or similar) and comment out the line which lists the recommended os versions

Posts: 21
Joined: 2006/10/06 17:08:13

patchset on CentOS 5.1 32-bit?

Post by john27 » 2008/04/22 09:06:29

What needs editing is these files:


In those files you will put this:

Red Hat Enterprise Linux Server release 5 (Tikanga)
Kernel \r on an \m

"Tikanga" is for 5.0 only If your running 5.1 you need to substitute the name for it. The same applys to also CentOS version 4, you substitute the appropriate line.

After your Oracle DB or Oracle App is installed change them back.


Hope this post isn't to late. Maybe it will help others.

Posts: 1
Joined: 2008/05/23 11:06:16

Re: patchset on CentOS 5.1 32-bit?

Post by hagin » 2008/05/23 11:09:28

an other way to resolve this is to use the switch


when starting the installer

Hope that helps (others to) :-)

Post Reply

Return to “CentOS 5 - Oracle Installation and Support”