DNS issue

Support for webhosts that use CentOS
Post Reply
yeoheric
Posts: 44
Joined: 2005/04/15 04:25:08

DNS issue

Post by yeoheric » 2008/03/11 04:44:35

Hi,

I have several servers behind a Firewall that also acts as my DNS server.

I setup a domain (abc.com) and www.abc.com works well. However when I put in abc.com, it goes to the firewall's web page.

Below are the contents of the abc.com.zone file (where 100.1.2.146 is the forewall/DNS and 10.1.2.153 is the public IP of the webserver):

$TTL 86400
@ IN SOA ns.abc.com. admin.abc.com. (
20080312001 ; Serial
7200 ; Refresh after 2 hours
3600 ; Retry after 1 hour
604800 ; Expire after 1 week
86400) ; Minium TTL of 1 day
IN NS ns.abc.com.
IN NS ns2.abc.com.
IN MX 50 mail.abc.com.
IN TXT "v=spf1 mx -all"
A 100.1.2.3
#localhost A 127.0.0.1 #<-------Original
localhost A 100.1.2.153 #<-------Added
www A 100.1.2.153
ns A 100.1.2.146
ns2 A 100.1.2.89
mail A 100.1.2.146

I remarked the original localhost line and added a new line as above and of course restarted named.

I added it abt say 2 hours ago and it still goes to the firewall's web page.

Did I left out anything?

Thank you.

Eric

foxb
Posts: 1927
Joined: 2006/04/20 19:03:33
Location: Montreal/QC

Re: DNS issue

Post by foxb » 2008/03/15 01:23:03

Did you setup

www.abc.com in apache? (Just guessing virual host)

Update:

Are you using NAT? If no it should work. Otherwise you need to play wit prerouting (If I remember correctly) or create inside view on DNS.

Post Reply

Return to “CentOS 5 - Webhosting Support”