Can't login into cockpit with local users after joining domain(synology)

Support for security such as Firewalls and securing linux
Post Reply
wylandadm
Posts: 6
Joined: 2019/08/26 20:10:07

Can't login into cockpit with local users after joining domain(synology)

Post by wylandadm » 2020/10/29 20:54:07

When I try to login it just reloads the page without any message. I can still login through ssh though.
Funfact; domain-users work but when I added one to the wheel group same error as with the local user before. When I deleted him out of the wheel group the problem persists

Thanks a lot for help :o)


My /etc/pam.d/cockpit
----------------------------------------------------

Code: Select all

#%PAM-1.0
# this MUST be first in the "auth" stack as it sets PAM_USER
# user_unknown is definitive, so die instead of ignore to avoid subsequent modules mess up the error code
-auth      [success=done new_authtok_reqd=done user_unknown=die default=ignore]   pam_cockpit_cert.so
auth       required     pam_sepermit.so
auth       substack     password-auth
auth       include      postlogin
auth       optional     pam_ssh_add.so
account    required     pam_nologin.so
account    include      password-auth
password   include      password-auth
# pam_selinux.so close should be the first session rule
session    required     pam_selinux.so close
session    required     pam_loginuid.so
# pam_selinux.so open should only be followed by sessions to be executed in the user context
session    required     pam_selinux.so open env_params
session    optional     pam_keyinit.so force revoke
session    optional     pam_ssh_add.so
session    include      password-auth
session    include      postlogin

Post Reply

Return to “CentOS 8 - Security Support”