sudo woes

Support for security such as Firewalls and securing linux
Post Reply
horyo3127
Posts: 1
Joined: 2020/10/13 12:29:28

sudo woes

Post by horyo3127 » 2020/10/13 12:54:28

I been trying for hours now to get sudo to work i tried adding myself to the wheel with usermod but it says permission denied. when i tried using the su and log in it says authentication failed i not sure wat the root password is so i cant log in using ssh i though it would been my user password but that was not right. I also read that it might be blank as default tried that and that agin did not work. when i do usermod -aG wheel horyo it says permission denied. I also can not edit the suddoers file says permission denied and something i thin it either trying to edit it or do wheel i cant remember witch but one says you can not lock /etc/passwords.

User avatar
jlehtone
Posts: 3107
Joined: 2007/12/11 08:17:33
Location: Finland

Re: sudo woes

Post by jlehtone » 2020/10/17 09:01:37

To call 'usermod' or edit list of sudoers required admin privileges. Via sudo or su.
Those who have the right can 'sudo'. You can use 'su' if you know root's password.

Some cloud platforms add your SSH-key for root account on instance creation.

If you are not already a sudoer nor have any way to authenticate as root, then there really is nothing you can do.

Post Reply

Return to “CentOS 8 - Security Support”