DHCP Client Not Working

Issues related to configuring your network
Post Reply
rickyspanish
Posts: 1
Joined: 2023/03/15 17:30:54

DHCP Client Not Working

Post by rickyspanish » 2023/03/15 20:03:46

Hello,

I am using a CentOS VM running under VMware Workstation Pro v17 to learn about containers. This environment worked previously, but there have been some changes on my environment and now I am unable to get a DHCP address on the VM. I am a Linux beginner so please do not assume I know anything when it comes to Linux :) What am I missing?

Here are the things I tried while troubleshooting:
1.) Used wireshark & tcpdump to trace the packets through the whole chain. In the tcpdump output on the VM, I see the IP address that is being assigned to the VM and all the correct DHCP options.
2.) Removed the network profile and recreated it - no change in behavior
3.) Configured the network profile to have a static ip address and this works perfectly - including having internet access
4.) Used VMWare's virtual network editor to "reset vmware network adapter settings" back to default. - No change
5.) Created a new VM from scratch and installed CentOS v8 - same issue with DHCP not working
6.) Created a new VM from scratch and installed Windows Server 2022 - DHCP works perfectly
7.) Created a new VM from scratch and installed CentOS v9 - same issue with DHCP not working

Configuration:
1.) CentOS v8
2.) VMware Workstation Pro v17
3.) Network configuration as bridged
4.) Physical machine running VMware Workstation is using a wireless adapter for network connectivity

Things that have Changed:
1.) New Laptop w/ new hardware
2.) Installed VMware Workstation Pro v16, but than did an upgrade to v17 without running any of the VM's in my environment
3.) VM's copied to new laptop and imported
4.) My physical machine is running Windows 10, Version 10.0.19042.2604

User avatar
jlehtone
Posts: 4553
Joined: 2007/12/11 08:17:33
Location: Finland

Re: DHCP Client Not Working

Post by jlehtone » 2023/03/16 08:59:21

First, I know nothing about VMware.

You say that you see DHCP request and reply in the VM, yet the VM's connections do not update?

What config does it have/get? Both el8 and el9 do use NetworkManager, so one could ask:

Code: Select all

nmcli
nmcli c s
nmcli d s

Post Reply