Page 1 of 1

CentOS 8 IPv6 config help needed

Posted: 2020/12/12 00:07:03
by StarburstHost
I'm a newbie to these forums.
Been using CentOS for about 2 years, but am a IPv6 virgin, so I apologize.

On the CentOS 8 servers I've been given a /64 for each, so in ifcfg-eth0 I have it activated, or so I thought.
But it only sees that 1st IP, none of the others unless I list them in a line IPV6ADDR_SECONDARIES.


Here's the virgin question, how can I get the system to see the whole /64 range without having to enter each IP?


Re: CentOS 8 IPv6 config help needed

Posted: 2020/12/13 11:09:46
by jlehtone
StarburstHost wrote:
2020/12/12 00:07:03
On the CentOS 8 servers I've been given a /64 for each
Disclaimer: I know as much as you about IPv6.

My ISP delegates a /56 prefix to my router (which is not CentOS). The router picks one /64 subnet from that /56 for my LAN.
Each member in LAN gets thus a /64 IPv6 address (if they request it). Can't remember whether that is via SLAAC, radvd, dhcpd or what.
MS Windows client creates additional, temporary IPv6 addresses "for privacy" (via SLAAC). CentOS has ipv6.ip6-privacy disabled by default.
The default gateway is actually the link-local address of the router, not its address within the /64.

My CentOS 8 client has thus two IPv6 addresses, the link-local fe80::x/64 and a y:z/64 from the y::/64 of the LAN. With the default ipv6.method auto configuration.

With that background "server given a /64" is baffling. Besides, "whole /64 range" has over 1.8e+19 addresses. That is ... many.

Furthermore, I don't read ifcfg-* files any more. I use nmcli. man nm-settings has section "IPv6 Settings".

Re: CentOS 8 IPv6 config help needed

Posted: 2020/12/18 22:40:10
by StarburstHost
OK, don't need the whole /64.

But does anyone know how to get CentOS 8 to recognize a /120 without having a very long IPV6ADDR_SECONDARIES="x x x"

Someone on LinuxQuestions suggested using:

sed -i "s/IPV6ADDR_SECONDARIES=\"/IPV6ADDR_SECONDARIES=\"$(seq 1 1 200 | xargs printf "2605:a140:2045:8941::%x ")/" <filename>