Unable to attach VLAN-based logical networks to a bond oVirt 4.4

Issues related to configuring your network
Post Reply
Shimme67
Posts: 3
Joined: 2020/11/11 20:35:08

Unable to attach VLAN-based logical networks to a bond oVirt 4.4

Post by Shimme67 » 2020/11/11 20:57:09

Hi,

I'm at the point of replacing my Broadcom NICs with Intel to resolve the issue I'm facing.

As detailed in https://bugzilla.redhat.com/show_bug.cgi?id=1860479 - kernel-4.18.0-240.6.el8 is the fix to the issue but I have no idea how to get the get this from github.

Can anyone help/advise please?

Shimme

User avatar
TrevorH
Forum Moderator
Posts: 29915
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Unable to attach VLAN-based logical networks to a bond oVirt 4.4

Post by TrevorH » 2020/11/11 21:46:00

That's an 8.3 kernel so won't be out for a while.

RHEL 8.3 was released only a day or two ago and CentOS 8.3 has to be built before it too can be released. Red Hat only release the source for the new point release when they release their point release itself, which means that CentOS can only start to build once the new RHEL version is out. That means a delay as perhaps 1000 SRPMs need to be built and rebuilt in the correct order to produce the potentially several thousand binary rpms that will eventually be released.

In fact, I'm not even sure that is the new point release kernel, I just checked git.centos.org and the latest CentOS 8 kernel there is 4.18.0-240.1.1 which is a lower rev than the one you're looking for. That means it's not even a released kernel, it's entirely internal to Red Hat and maybe their paying customers.

So, step 1, wait for 8.3 to drop which might be days or it might be weeks or even months since the rebuild has only just started and there's no clue yet as to whether this will be an easy or a difficult point release to build. Step 2 is to hope that by the time it is released, Red Hat will have QA'ed that kernel and issued a bug fix kernel package containing the fix you're interested in. If they have then it will either come out with the new CentOS 8 point release or shortly after. If they haven't then CentOS cannot rebuild it because there is no public source.

Otherwise your choice is to buy a RHEL license with a support subscription and request access to that kernel via a support case. CentOS can't help until the source is released.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Shimme67
Posts: 3
Joined: 2020/11/11 20:35:08

Re: Unable to attach VLAN-based logical networks to a bond oVirt 4.4

Post by Shimme67 » 2020/11/11 22:12:16

Many thanks for the detailed explanation Trevor.

My easiest option would be to purchase Intel cards which haven't had the same issue.

I was under the impression that a patch could be applied from the details given in the Bugzilla link I posted.

Anyway, thanks again.

Shimme

User avatar
TrevorH
Forum Moderator
Posts: 29915
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Unable to attach VLAN-based logical networks to a bond oVirt 4.4

Post by TrevorH » 2020/11/11 22:47:42

Well the fix to the source is there in https://bugzilla.redhat.com/show_bug.cgi?id=1860479#c35 but to do anything with that would mean you downloading the current kernel source from git.centos.org and creating an SRPM from it then installing that SRPM so get a .spec file that you can add a Patchxxx: line to to include that comment's patch, rebuild the SRPM then rebuild it with mock. And that assumes it fits onto the current kernel and doesn't need to be adapted to fit the Red Hat source code.

https://wiki.centos.org/action/show/Sou ... .sh_script
https://wiki.centos.org/HowTos/RebuildSRPM
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Shimme67
Posts: 3
Joined: 2020/11/11 20:35:08

Re: Unable to attach VLAN-based logical networks to a bond oVirt 4.4

Post by Shimme67 » 2020/11/11 23:49:09

I really appreciate you taking the time to send the info - I have a Lab server I can try it out on.

Shimme :D

Post Reply

Return to “CentOS 8 - Networking Support”