No wired internet connection

Issues related to configuring your network
Post Reply
mikaknim
Posts: 2
Joined: 2020/10/27 09:44:12

No wired internet connection

Post by mikaknim » 2020/10/27 10:12:21

I've been trying to solve this now for a week. I tried everything under the sun by googling but nothing has solved the problem. I did a fresh install of centos 8 due to this problem 4 days ago. I switched out ethernet cards because when I tried to install centos 8 with the old ethernet card, on the install gui it stated there was no network connection. Swapped the cards and it showed there was a network connection with the new ethernet card. So I thought it was just a bad card. The first day of new install, everything worked. I additionally installed another kernel: kernel-4.18.0-80.11.2.el8_0.x86_64 next to the one installed already: kernel-4.18.0-193.19.1.el8_2.x86_64. Everything was fine on both kernels until yesterday. Here are the errors I am getting:

1. By a restart, I get the error "[FAILED] Failed to start Network Manager Wait Online. See 'systemctl status NetworkManager-wait-online.service' for details." after choosing a kernel.
2. This error only happens when the ethernet cord is plugged into the ethernet card.
3. When the cord is plugged in, the wired connection symbol tries to connect when logged in.
4. After about 1-2 minutes, a notification shows stating: "Connection failed. Activation of network connection failed."

Here is the output of

Code: Select all

systemctl status NetworkManager-wait-online.service

Code: Select all

● NetworkManager-wait-online.service - Network Manager Wait Online
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager-wait-online.service; enabled; vendor preset: disabled)
   Active: active (exited) since Tue 2020-10-27 10:45:41 CET; 23min ago
     Docs: man:nm-online(1)
 Main PID: 1453 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 203423)
   Memory: 0B
   CGroup: /system.slice/NetworkManager-wait-online.service

Oct 27 10:45:18 localhost.localdomain systemd[1]: Starting Network Manager Wait Online...
Oct 27 10:45:41 localhost.localdomain systemd[1]: Started Network Manager Wait Online.

I have Wifi access on .193 and no wifi access on .80. I needed .80 for an application but the company just released a new version which now works on .193 so I will be deleting the .80 kernel. I tried 5.9 kernel to see if it was/is a kernel problem but the internet issue is also there. What I find strange, is that the wired connection did work on a fresh install and doesn't work anymore. I haven't messed with any configurations outside of adding things to PATH, env and so on.

Any help/insight is greatly appreciated.

lightman47
Posts: 1222
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: No wired internet connection

Post by lightman47 » 2020/10/27 19:01:04

You can start (one-time) the NetworkManager-wait-online service with
systemctl start NetworkManager-wait-online

You can also enable AUTO startup during boot-up with:
systemctl enable NetworkManager-wait-online
Remember - importing/building packages will likely "byte you in the butt" come update time, long after you'd forgotten you did that! Use repos whenever possible.

mikaknim
Posts: 2
Joined: 2020/10/27 09:44:12

Re: No wired internet connection

Post by mikaknim » 2020/10/28 11:43:36

That didn't solve the problem unfortunately.

Post Reply

Return to “CentOS 8 - Networking Support”