wifi adapter not working

Issues related to configuring your network
Post Reply
munish259272
Posts: 5
Joined: 2016/10/24 15:07:37

wifi adapter not working

Post by munish259272 » 2020/08/23 10:13:44

device info after connecting the usb adapter:

Code: Select all

(base) [msingh@centos ~]$ lsusb | grep TP
Bus 003 Device 005: ID 2357:0109 TP-Link TL WN823N RTL8192EU
I have installed the driver 8188eu

Code: Select all

(base) [msingh@centos ~]$ lsmod | grep 81
snd_seq                81920  0
8188eu               1810432  0
8192eu               1552384  0
r8169                  90112  0
cfg80211              806912  2 8192eu,8188eu
(base) [msingh@centos ~]$ 
But it wifi is still not listed or working:

Code: Select all

(base) [msingh@centos ~]$ nmcli dev
DEVICE             TYPE      STATE         CONNECTION 
enp37s0            ethernet  connected     enp37s0    
virbr0             bridge    connected     virbr0     
D4:5D:64:12:17:1C  bt        disconnected  --         
lo                 loopback  unmanaged     --         
virbr0-nic         tun       unmanaged     --  

User avatar
TrevorH
Forum Moderator
Posts: 29961
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: wifi adapter not working

Post by TrevorH » 2020/08/23 12:14:55

That card appears to be supported by the rtl8xxxu module.

Code: Select all

[root@centos8 ~]# grep -i 2357 /lib/modules/$(uname -r)/modules.* | grep -i 0109
/lib/modules/4.18.0-193.14.2.el8_2.x86_64/modules.alias:alias usb:v2357p0109d*dc*dsc*dp*icFFiscFFipFFin* rtl8xxxu
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

munish259272
Posts: 5
Joined: 2016/10/24 15:07:37

Re: wifi adapter not working

Post by munish259272 » 2020/08/25 13:22:21

Ok,

Now i have removed the two wifi modules that were running and added rtl8xxxu module

Code: Select all

(base) [msingh@centos ~]$ lsmod | grep 81
snd_seq                81920  0
8188eu               1810432  0
8192eu               1552384  0
r8169                  90112  0
cfg80211              806912  2 8192eu,8188eu
(base) [msingh@centos ~]$ lsmod | grep rtl
btrtl                  16384  1 btusb
bluetooth             634880  31 btrtl,btintel,btbcm,bnep,btusb,rfcomm
(base) [msingh@centos ~]$ sudo modprobe -r 8188eu 8192eu
[sudo] password for msingh: 
(base) [msingh@centos ~]$ 
(base) [msingh@centos ~]$ sudo modprobe rtl8xxxu
(base) [msingh@centos ~]$ lsmod | grep rtl
rtl8xxxu              126976  0
mac80211              888832  1 rtl8xxxu
btrtl                  16384  1 btusb
bluetooth             634880  31 btrtl,btintel,btbcm,bnep,btusb,rfcomm
Wifi wlp41s0f3u2u4 is visible now but it hangs on connecting

Code: Select all

(base) [msingh@centos ~]$ nmcli dev
DEVICE             TYPE      STATE                     CONNECTION        
enp37s0            ethernet  connected                 enp37s0           
virbr0             bridge    connected                 virbr0            
wlp41s0f3u2u4      wifi      connecting (configuring)  ACT103292835565 1 
D4:5D:64:12:17:1C  bt        disconnected              --                
lo                 loopback  unmanaged                 --                
virbr0-nic         tun       unmanaged                 --                
(base) [msingh@centos ~]$ rfkill list all
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
It seems to me it is getting timed out due to authentication, I don't understand the reason

Code: Select all

(base) [msingh@centos ~]$ sudo tail -f /var/log/messages
Aug 25 18:46:25 centos NetworkManager[1498]: <info>  [1598361385.5323] device (wlp41s0f3u2u4): supplicant interface state: inactive -> scanning
Aug 25 18:46:26 centos NetworkManager[1498]: <info>  [1598361386.9740] device (wlp41s0f3u2u4): supplicant interface state: scanning -> inactive
Aug 25 18:46:30 centos NetworkManager[1498]: <info>  [1598361390.5315] device (wlp41s0f3u2u4): supplicant interface state: inactive -> scanning
Aug 25 18:46:31 centos dbus-daemon[1296]: [system] Activating via systemd: service name='net.reactivated.Fprint' unit='fprintd.service' requested by ':1.716' (uid=0 pid=46823 comm="sudo tail -f /var/log/messages " label="unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023")
Aug 25 18:46:31 centos systemd[1]: Starting Fingerprint Authentication Daemon...
Aug 25 18:46:31 centos dbus-daemon[1296]: [system] Successfully activated service 'net.reactivated.Fprint'
Aug 25 18:46:31 centos systemd[1]: Started Fingerprint Authentication Daemon.
Aug 25 18:46:31 centos NetworkManager[1498]: <info>  [1598361391.9816] device (wlp41s0f3u2u4): supplicant interface state: scanning -> inactive
Aug 25 18:46:33 centos NetworkManager[1498]: <info>  [1598361393.5289] device (wlp41s0f3u2u4): supplicant interface state: inactive -> scanning
Aug 25 18:46:34 centos NetworkManager[1498]: <info>  [1598361394.9739] device (wlp41s0f3u2u4): supplicant interface state: scanning -> inactive
Aug 25 18:46:35 centos journal[34735]: Failed to get application states: GDBus.Error:org.freedesktop.portal.Error.Failed: Could not get window list: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: App introspection not allowed
Aug 25 18:46:36 centos NetworkManager[1498]: <info>  [1598361396.5364] device (wlp41s0f3u2u4): supplicant interface state: inactive -> scanning
Aug 25 18:46:37 centos NetworkManager[1498]: <info>  [1598361397.9737] device (wlp41s0f3u2u4): supplicant interface state: scanning -> inactive
Aug 25 18:46:43 centos NetworkManager[1498]: <info>  [1598361403.5326] device (wlp41s0f3u2u4): supplicant interface state: inactive -> scanning
Aug 25 18:46:44 centos NetworkManager[1498]: <info>  [1598361404.9746] device (wlp41s0f3u2u4): supplicant interface state: scanning -> inactive
Aug 25 18:46:46 centos NetworkManager[1498]: <info>  [1598361406.5298] device (wlp41s0f3u2u4): supplicant interface state: inactive -> scanning
Aug 25 18:46:47 centos kernel: FINAL_REJECT: IN=enp37s0 OUT= MAC=01:00:5e:00:00:01:00:ad:24:f6:6a:d7:08:00 SRC=192.168.0.1 DST=224.0.0.1 LEN=28 TOS=0x00 PREC=0x00 TTL=1 ID=0 DF PROTO=2 
Aug 25 18:46:47 centos kernel: FINAL_REJECT: IN=enp37s0 OUT= MAC=01:00:5e:00:00:fb:d0:37:45:65:2d:a5:08:00 SRC=192.168.0.88 DST=224.0.0.251 LEN=32 TOS=0x00 PREC=0x00 TTL=1 ID=2052 PROTO=2 
Aug 25 18:46:47 centos kernel: FINAL_REJECT: IN=enp37s0 OUT= MAC=01:00:5e:00:00:fc:d0:37:45:65:2d:a5:08:00 SRC=192.168.0.88 DST=224.0.0.252 LEN=32 TOS=0x00 PREC=0x00 TTL=1 ID=9271 PROTO=2 
Aug 25 18:46:47 centos NetworkManager[1498]: <info>  [1598361407.9739] device (wlp41s0f3u2u4): supplicant interface state: scanning -> inactive
Aug 25 18:46:49 centos NetworkManager[1498]: <info>  [1598361409.5285] device (wlp41s0f3u2u4): supplicant interface state: inactive -> scanning
Aug 25 18:46:50 centos NetworkManager[1498]: <info>  [1598361410.9821] device (wlp41s0f3u2u4): supplicant interface state: scanning -> inactive
Aug 25 18:46:52 centos NetworkManager[1498]: <info>  [1598361412.5369] device (wlp41s0f3u2u4): supplicant interface state: inactive -> scanning
Aug 25 18:46:53 centos NetworkManager[1498]: <info>  [1598361413.9737] device (wlp41s0f3u2u4): supplicant interface state: scanning -> inactive
Aug 25 18:46:5
Last few lines of dmesg:

Code: Select all

[Tue Aug 25 18:38:47 2020] IPv6: ADDRCONF(NETDEV_UP): wlp41s0f3u2u4: link is not ready
[Tue Aug 25 18:38:47 2020] IPv6: ADDRCONF(NETDEV_UP): wlp41s0f3u2u4: link is not ready
[Tue Aug 25 18:43:47 2020] IPv6: ADDRCONF(NETDEV_UP): wlp41s0f3u2u4: link is not ready
[Tue Aug 25 18:43:48 2020] wlp41s0f3u2u4: authenticate with 00:ad:24:f6:6a:d9
[Tue Aug 25 18:43:48 2020] wlp41s0f3u2u4: send auth to 00:ad:24:f6:6a:d9 (try 1/3)
[Tue Aug 25 18:43:49 2020] wlp41s0f3u2u4: send auth to 00:ad:24:f6:6a:d9 (try 2/3)
[Tue Aug 25 18:43:49 2020] wlp41s0f3u2u4: send auth to 00:ad:24:f6:6a:d9 (try 3/3)
[Tue Aug 25 18:43:49 2020] wlp41s0f3u2u4: authentication with 00:ad:24:f6:6a:d9 timed out
[Tue Aug 25 18:44:01 2020] wlp41s0f3u2u4: authenticate with 00:ad:24:f6:6a:d9
[Tue Aug 25 18:44:01 2020] wlp41s0f3u2u4: send auth to 00:ad:24:f6:6a:d9 (try 1/3)
[Tue Aug 25 18:44:01 2020] wlp41s0f3u2u4: send auth to 00:ad:24:f6:6a:d9 (try 2/3)
[Tue Aug 25 18:44:01 2020] wlp41s0f3u2u4: send auth to 00:ad:24:f6:6a:d9 (try 3/3)
[Tue Aug 25 18:44:01 2020] wlp41s0f3u2u4: authentication with 00:ad:24:f6:6a:d9 timed out
I know there is nothing wrong with the password since the same password works for my mobile but it is giving error for PC. I have tried multiple times
Image

User avatar
TrevorH
Forum Moderator
Posts: 29961
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: wifi adapter not working

Post by TrevorH » 2020/08/25 14:57:35

Is your wifi access point locked down by MAC address and is the MAC address of this interface in its list?
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 8 - Networking Support”